Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Embedded google calendar not showing

more options

Not sure where this fits in so I started here. I have been running firefox for a very long time. For my home page, I am using Protopage. I have my google calendar as one of the widgets on the page. I have it set up correctly. It was showing up yesterday. Now today it is not showing. I am getting this error:

Firefox Can’t Open This Page

To protect your security, accounts.google.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

I have not made any changes to Protopage or Firefox.

Got any ideas what has changed? What I need to fix to get it working again?

Bob

Réiteach roghnaithe

I did send the same inquiry to Protopage right after I posted this question here. I let is set for awhile and when I was eating lunch I thought to go in and sign out of my google accounts.

I then signed back in to them and then everything started working and showing up again. So I really have no clues as to why it did what it did, but by signing out and then back in, it fixed it.

Thanks

Bob

Read this answer in context 👍 0

All Replies (7)

more options

Hi Bob, it's interesting that the error message refers to accounts.google.com rather than the calendar domain. It sounds like Google didn't recognize you as being logged in and redirected to the login page, but that is blocked.

One reason Google might not recognize you as logged in is if Firefox didn't send your Google cookie to the framed page. Firefox 96 now applies stricter rules to cross-site cookies, intended to synchronize with Chrome's behavior. However, users have noted a number of places that Firefox seems stricter than Chrome, or that web servers weren't prepared for this change and aren't following the same approach to both browsers.

You could submit this issue to Protopage for suggestions.

Until then, do you want to experiment with some settings through the back door?

Helpful?

more options

Réiteach Roghnaithe

I did send the same inquiry to Protopage right after I posted this question here. I let is set for awhile and when I was eating lunch I thought to go in and sign out of my google accounts.

I then signed back in to them and then everything started working and showing up again. So I really have no clues as to why it did what it did, but by signing out and then back in, it fixed it.

Thanks

Bob

Helpful?

more options

I just stumbled upon the same problem.

I have a public Google calendar. I embedded it in my website using the code provided by Google (using the iframe).

It used to work last week, so I suppose it's indeed related to Firefox 96 stricter rules.

Note that on other browsers like Chrome, the calendar shows up.

Strangely enough, it also works fine with Firefox on mobile (version 96.2).

Helpful?

more options

Does yours show the error about accounts.google.com or an error mentioning the actual calendar domain?

Mozilla issued a temporary rollback to the cookie changes, so if you check now, they should be marked false:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste samesite and pause while the list is filtered, these are the three to check:

  • network.cookie.sameSite.laxByDefault => was false in Fx95, true in Fx96, now false again temporarily
  • network.cookie.sameSite.noneRequiresSecure => was false in Fx95, true in Fx96, now false again temporarily
  • network.cookie.sameSite.schemeful => was false in Fx95, true in Fx96, now false again temporarily

If yours are not currently set to false, you can double-click the preference to switch between true and false.

Helpful?

more options

Well, kind of embarrassed with this problem.

Found out that the calendar that was giving me the issue, I was signed out of.

Signed back in. Everything is fine now.

Sorry.

Bob

Helpful?

more options

None of this is of any help except perhaps to view the calendar myself when editing a web page. Every viewer needs to view the calendar and not every one who visits site will know how, should or want to edit browser settings.

Likewise when someone clicks to load the site it asks to log into google. But the average person visiting the site does not have nor should they have those credentials to do so.

Not one of the solutions is acceptable as everyone who visit site needs to be able to view the calendar. It is intended for the public.

If there is no fix for this from Firefox or Google ( not sure who's to blame ) then the Google calendar simply cannot be used at all.

Helpful?

more options

pck24 said

Likewise when someone clicks to load the site it asks to log into google. But the average person visiting the site does not have nor should they have those credentials to do so.

Try regenerating your iframe using the steps in this article:

https://support.google.com/calendar/answer/41207

(Of course, specify that everyone can view, no one can edit.)

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.