Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox repeatedly opens with "Sorry, We're having trouble getting your pages back"

  • 7 bhfreagra
  • 1 leis an bhfadhb seo
  • 9 views
  • Freagra is déanaí ó Bill

more options

Since I upgraded to v96.0 I have been getting this error message every time I open Firefox. I read another thread that suggested I alter...

    browser.sessionstore.max_resumed_crashes

...to zero (0) in "about:config". However, I'm guessing this change basically turns off this functionality, which I wouldn't want if the browser actually crashed. However, this doesn't seem to work at all, either on the network "Data" folder or the local "Data" folder, so Firefox has become very annoying to use.  :-(

I have two (2) data directories (which, of course, contains my profile) for firefox; one on my local machine and one on the network. I normally use the network data directory and only use the local one if I'm traveling. I haven't used the local "Data" for three (3) months, and it worked fine for two weeks. As a test I activated the local "Data" directory (I renamed "Data" to "Data_network" and "Data_local" to "Data"). I got the same problem so I'm sure this has to do with the latest upgrade to v96.0.

My settings, which have always been set like this, are:

 + I have "Open previous windows and tabs" un-checked.
 + I have "Choose what you see when you open your homepage, new windows, and new tabs." set to "Custom URLs..." and my "Homepage and new windows" is set to my home page URL.

Any thoughts?

All Replies (7)

more options

Hi Bill, there is a similar recent thread here (unsolved): https://support.mozilla.org/questions/1364036

The browser.sessionstore.max_resumed_crashes preference sets the number of times Firefox tries an automatic crash restore before giving up and showing you that error screen. So whether it is set to 1 or 0, either way, Firefox thinks that it did not shut down properly at the end of the last session.

Since you are not interested in restoring your last session, you could try hiding all session files as follows:

(1) Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, find the Profile Folder row. On that row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

(2) Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

(3) Right-click > Rename the following files to hide them from Firefox (or you could move them out of the folder or delete them):

  • sessionstore.jsonlz4 => sessionstoreOLD.jsonlz4
  • sessionCheckpoints.json => sessionCheckpointsOLD.json

(4) Right-click > Rename the following folder to hide it from Firefox (or you could move it out of the folder or delete it):

  • sessionstore-backups => sessionstore-backupsOLD

At your next startup, finding none of the earlier session files, Firefox should show your home page.

Success?

Helpful?

more options

Success! Thanks very much.

Helpful?

more options

Well, I closed Firefox then opened about an hour later. The same problem appears. I don't believe one wants to continually go through these troubleshooting steps every time they open Firefox.

Interestingly, when I open Firefox then navigate around this error page I can open a new window and it doesn't happen.

So, is there a solution that is more permanent? Thanks,

Bill

Helpful?

more options

Hi Bill, it implies that Firefox is crashing a lot. Do you see evidence of that -- such as Mozilla Crash Reporter dialog, or a message from Windows -- or does it seem to be behaving normally?

Helpful?

more options

Not at all (it doesn't crash). It's as though the "...getting your pages back." is now the home page. When I click on any link in email FF opens with the first tab this page and the 2nd tab the link. Everything else works fine and I'm able to close FF with no issues, which I almost always do, before I leave my PC.

This just started happening when I allowed FF to upgrade to v96.0.1 within the past week or so. Even when I click the [Restore Session] button it does restore either my last page or the home page. However, when I close FF and reopen it the same issue occurs. If I open a new instance of FF (e.g. [shift]+click the FF icon) FF opens without this issue. This issue also occurs when I use a "local" profile, I normally keep my profile on a NAS device since it's backed up every day, so I don't think there is any corruption in my profile(s) since I haven't used my local profile since late October.

I almost never get crashes, except in the rare instances when I actually did reboot Windows while FF was open, and I've been using FF for many years. When testing this again (right now) FF just asked me to download the latest version of FF and was also asked to close FF to update (I did). When I look at the version it is the same v96.0.1 (64-bit) I had before, so I don't know what this is all about.

Helpful?

more options

Oh, is there a 96.0.1 now? I still have 96.0. The changes don't sound related to sessions:

https://www.mozilla.org/firefox/96.0.1/releasenotes/


In the other thread I mentioned, there seems to be an issue with the final step of setting up the sessionstore.jsonlz4 file and noting that in the sessionCheckpoints.json file. Hopefully they'll solve it and we can benefit from what they discover.

Helpful?

more options

Ok. I'll await development to fix this and hope it isn't too long as the error page is ugly as my home page.  :-)

Thanks.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.