Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

+ sign new tab not visible

  • 24 freagra
  • 1 leis an bhfadhb seo
  • 43 views
  • Freagra is déanaí ó cor-el

more options

New windows 10 install. After installing the newest firefox and copying over my profile from the old windows 7 disk the + new tab button is invisible unless I cursor over it. I am using no script, adblocker and tabs on bottom.css if that helps.

Réiteach roghnaithe

Maybe omit this rule:

#TabsToolbar {
 background-color: var(--toolbar-bgcolor) !important;
}
Read this answer in context 👍 0

All Replies (20)

more options

Hello jdevlin,

For now, you can use the Ctrl + T shortcut .....

Then, please go to 3-bar menu => Customize, and see if maybe you see that "+" sign there and drag it to where it belongs.

Another thing to do is to click on "Restore Defaults" (at the bottom) and then on the blue "Done" button.

Also see :

https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars

Any luck ?

Helpful?

more options

There is no + on the customize options. The + is there. It is just invisible unless I put the cursor over it.

Helpful?

more options

jdevlin said

There is no + on the customize options. The + is there. It is just invisible unless I put the cursor over it.

    Did you try my other suggestion ("Restore Defaults") ?

    And my first suggestion (as a workaround) : Ctrl + T (?)

Helpful?

more options

restore default did nothing but make my toolbars go away. ctrl- t is not required as the + is there and works. It is just invisible until I mouse over it.

I will next try uninstalling and reinstalling FF. This is a new computer build.

Helpful?

more options

reloaded FF and the + is there, visible and working. However I can not get the userchrome file to load. I copied the chrome folder and all its files over from the old PC but it does nothing. I do not get my tabs at the bottom like I want. Is there something I need to do to activate userchrome. I thought it was automatic if it existed.

Helpful?

more options

I only just now saw your last two posts .....

My next suggestion would have been to refresh Firefox, not uninstall and reinstall - but at least you got your plus sign back, so : well done !

However; I know nothing about userChrome.css - I'm hoping that someone else will see this and come to your rescue.

Helpful?

more options

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See:

Helpful?

more options

I got the tabs back to the bottom but now the + is hidden again. Something about the tabs on bottom .css is doing it but only in windows 10. It works fine in windows 7.

Helpful?

more options

Can you post the content of your userChrome.css ?

The new tab plus buttons have this selector. There are two buttons, one is a customizable toolbar button and the other snaps in after the last tab when this is possible.

Example:

#new-tab-button, #tabs-newtab-button {
 fill:red !important;
}

#new-tab-button:hover, #tabs-newtab-button:hover {
  fill: white !important;
  background-color: rgba(255,0,0,.7) !important;
  border-radius: 4px;
}

Helpful?

more options

I do not see that new tab code in my tabs on bottom file

/* TABS: on bottom */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}
#TabsToolbar {-moz-box-ordinal-group:1000!important}

#TabsToolbar {
 position: absolute !important; 
 bottom: 0 !important;
 width: 100vw !important;
 display: block !important;
}

#tabbrowser-tabs {
  top: 300 !important;
  width: 100vw !important;
}
#main-window:not([chromehidden*="toolbar"]) #navigator-toolbox {
	padding-bottom: calc(1px + var(--tab-min-height_tnot)) !important;
}

/* TABS: height */
:root {
 --tab-toolbar-navbar-overlap: 0px !important;
 --tab-min-height: 33px !important; /* adjust to suit your needs */
 --tab-min-height_tnot: 32px;
}
:root #tabbrowser-tabs {
 --tab-min-height: 33px !important; /* needs to be the same as above under :root */
 --tab-min-width: 80px !important;
}

#TabsToolbar {
	height: var(--tab-min-height) !important;
	margin-bottom: 1px !important;
	box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important;
	background-color: var(--toolbar-bgcolor) !important;
}
/* hide windows-controls */
#TabsToolbar #window-controls {display:none!important;}

/* move caption buttons to right of Tab bar */
#main-window[tabsintitlebar]:not([inFullscreen="true"]) #toolbar-menubar[autohide="true"] ~ #TabsToolbar .titlebar-buttonbox-container {
	position: fixed !important;
	right: 0 !important;
	top: calc(6px + var(--tab-min-height)) !important;
	display: block !important;
	visibility: visible !important;
}
#toolbar-menubar[autohide="true"] ~ #TabsToolbar {padding-right: 100px !important;}

Athraithe ag cor-el ar

Helpful?

more options

I inserted your code at the end of the file and now when I hover over it the + is red but it is still invisible otherwise.

Helpful?

more options

There is nothing in your userChrome.css that would affect the plus button.

Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display.

  • Right-click empty toolbar area -> Customize
  • "3-bar" menu button -> Customize
  • if missing items are in the Customize palette then drag them back from the Customize window to the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button in the Customize palette window to restore the default toolbar set.

Helpful?

more options

There is no option for the + button in customize. All restore defaults did was hide the menu and bookmarks toolbar. It is something about my new windows 10 install, because it works fine windows 7.

The + still works when hover over it. If I have to I guess I can live with but I would like it corrected if possible.

Athraithe ag jdevlin ar

Helpful?

more options

jdevlin said

There is no option for the + button in customize.
All restore defaults did was hide the menu and bookmarks toolbar.

We've already been over that in the first few posts in this thread.

But what I was going to suggest (before you decided to uninstall and reinstall) is to Refresh Firefox :

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Worth a try .....

Helpful?

more options

Another thing I just realized is that the unused part of the tab bar is plain white and not coloured like the windows 7 PC.

Athraithe ag jdevlin ar

Helpful?

more options

jdevlin said

Another thing I just realized is that the unused part of the tab bar is plain white and not coloured like the windows 7 PC.

Are you using a theme on the other device ?

And when you say "plain white"; isn't it a bit grey-ish ? (that's the color of my tab bar)

Helpful?

more options

No colour. It is pure white. I have classic shell installed on windows 10. But I already tried turning it off and it did not make a difference.

Helpful?

more options

Réiteach Roghnaithe

Maybe omit this rule:

#TabsToolbar {
 background-color: var(--toolbar-bgcolor) !important;
}

Helpful?

more options

jdevlin said

No colour. It is pure white.

    What color do you want it to be / did it used to be ?

    Just the tab bar ?

Helpful?

more options
  1. TabsToolbar {
background-color: var(--toolbar-bgcolor) !important;

}

elimination solved it.

Thank you.

Helpful?

  1. 1
  2. 2
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.