Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox won't keep me logged in to homepages and other webpages and I have to sign in every time I launch Firefox.

  • 4 fhreagra
  • 3 leis an bhfadhb seo
  • 46 views
  • Freagra is déanaí ó icemandave

more options

Firefox won't keep me signed in to anything, even though I've selected to remain signed in via websites' preferences and it has always kept me signed in before. Every time I relaunch Firefox, I have to sign in to my two homepages (Yahoo and Fark), even though the passwords are stored in Firefox, and they auto-fill in the appropriate slots. This happens with all other pages I've tried, even the Firefox help forum itself.

I've reset Firefox, I've cleared all my passwords (and re-entered a few of them) to make sure they are correct, and still no luck. I removed u-Block origins, thinking maybe it was causing it, but it's still happening even without u-Block installed.

Réiteach roghnaithe

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Read this answer in context 👍 0

All Replies (4)

more options

Réiteach Roghnaithe

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

Thanks for your prompt reply, Fred McD. I found those instructions in the list of help articles and followed them last night, but the problem still persisted for several hours.

Then, this morning, when I fired up the laptop, the problem had been corrected, and I can now stay logged in to webpages.

more options

Glad to help. Safe Surfing.

With some settings, you need to restart the browser after you make changes.

more options

Yeah, I restarted Firefox and rebooted the laptop a few times last night. I don't know why it waited until this morning to correct. I'm just glad that it did. Cheers.