Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

CPU usage spikes when using Firefox

  • 2 fhreagra
  • 3 leis an bhfadhb seo
  • 19 views
  • Freagra is déanaí ó cor-el

more options

After using Firefox for an hour or so, the CPU usage starts to spike and causing major lag and freezing. The spike will cause the CPU usage to jump up for about 4 or 5 seconds. During this time, everything is frozen. Then all of a sudden, the CPU usage will jump back down to a normal level and thing will continue working as usual. Then a few minutes later, the spike will happen again. This goes on and on and on and nothing will fix it. I've tried uninstalling and reinstalling the newest version. I've disabled and deleted all my plugins and add-ons. I've done the "refresh" of Firefox and that didn't work either. Closing Firefox and reopening doesn't work, rebooting the computer doesn't work. I use Firefox when I'm at work and it's starting to interfere with my productivity. I'd love to find a solution to this problem since it's just started happening the past several months. As far as I know, nothing has changed on this computer. No added programs or software. It's the same stuff I've been using since being assigned to this computer 5 years ago. I'd really like to find a solution. Thanks.

All Replies (2)

more options

For whatever reason, the picture I attached didn't show up in my original post. Here is a pic of my Windows Task Manager showing the spike in CPU usage. Note that when the spike occurs, the usage will jump up into the 50s and 60s normally, but sometimes it'll go into the 70s and occasionally into the 90s. It's so frustrating!

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect.

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.