Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

When viewing tumblr.com, memory usage goes over 4GB

more options

Latest firefox, windows 7 pro 64, 8GB ram

If I open a tab to a tumblr.com blog and keep scrolling, memory usage for the tab eventually goes well over 3 GB and my computer start acting strange (slowing down).

Try that, then, open another tab, and close the one you were scrolling on. When I close the tab, the hard drive light will stay lit for 10 minutes or more while firefox is thrashing as it tries to swap/clear/free memory. The computer essentially freezes while windows try to sort it out.

My question is how to stop a single firefox tab from using over 4GB of ram, triggering this issue.

I realize it has a lot to do with the way the webpage is designed, but how can I get firefox to not accumulate so much stuff in ram?

http://te5seract.tumblr.com/ will demonstrate the issue. Just scroll until firefox gets to 3.5GB, open a new tab, close the tab you were scrolling on, and watch what happens.

Thanks

Réiteach roghnaithe

Thanks for trying it, people. That motivated me to move forward.

I can get memory usage from 350MB to over 1GB scrolling down to pictures that are 3 days old (mouseover).

Using safe mode, it did not happen (well. I had to scroll WAAAAY back to get up to 2GB).

I eventually disabled adBlock Plus and the issue essentially went away. It can still use a lot of memory, but I have to scroll a long ways back.

Looks like it might be that the page uses tons of iframes, which, it seems, adblock plus does not handle well. Any of you have any experience with that issue?

I have gotten malware twice (when the computer was unattended) through ad servers on news sites (my wife leaves the browser open on news) so I'm really adamant about ad blocking for security (not privacy).

Thanks for helping.

Read this answer in context 👍 0

All Replies (12)

more options

I wonder why no one is responding? Has anyone tried this and not seen the issue? Is it an obvious issue with no solution? Did I not describe the problem clearly? Did I post this in the wrong forum? Is my description not clear?

Only 3 views makes me thing I'm posting in the wrong place.

Please advise, Thanks.

more options

What addons do you have installed? Did you try in Safe Mode?

more options

Hi   !
Are you using Multiprocess (e10s)  ? You can check whether you have this feature turned on as follows : • '3-bar' menu button => ' ? ' button => Troubleshooting Information • type 'about:support ' (without the commas) in the address bar and press Enter/Return

In the first table on the page, check the row for 'Multiprocess Windows' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s - otherwise it should read : 0/1 (Disabled). If you are using e10s: You could turn it off as follows :

Type in the address bar about:config (promise to be careful, if asked) Type and search for the preferences : browser.tabs.remote.autostart and set it's value to false browser.tabs.remote.autostart.2 and set it's value to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

more options

OK --- so no one is willing to try and see whether they have the same issue or if it is unique to me. Oh well. I'll just live with the bug/behavior until someone important sees the same thing and someone else duplicates it and it gets fixed (or at least acknowledged).

Athraithe ag easily_confused ar

more options

easily_confused said

OK --- so no one is willing to try and see whether they have the same issue or if it is unique to me. Oh well. I'll just live with the bug/behavior until someone important sees the same thing and someone else duplicates it and it gets fixed (or at least acknowledged).

We are trying to help you,   but : You haven't answered tomatoshadow2's questions   ....... Have you tried to see if you have Multiprocess enabled   ? If you want this problem solved :   please, work with us   !

more options

If someone said they tried it and did not see the issue (the memory usage did not increase continually as they scrolled down the page, but became bounded at XXX) and then asked questions or made suggestions, it would make sense to me. But, just asking random questions and making arbitrary suggestions without explaining why, or even trying the page, seems fruitless. That is not debugging, it is making wild guesses with no data.

I'm running adblock plus and duplicate tab.

The problem exists with only the 1 tab open.

Please explain to me how tab multiprocess settings could result in the behavior described. (BTW I tried it and it made no difference with respect to the page causing memory usage to grow without bound). Seems like a wild guess with no substance to me. Did that fix a problem for you once?

Sorry, but It's frustrating how people can try try to debug something without trying to duplicate it first.

more options

I'm not seeing a rise in memory usage if I scroll down the page for a while. It stays steady at about 200 MB for me.

There are a lot of images on that page, so the image cache might be a problem in your case.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Just trying to help you the best way we can, I went to the web page that you said and my Firefox only uses one GB to display the page with multi-process enabled, as you said about the heaviness of the page, I imagine that is the problem with the heavy ram use. Also did you try Happy112's suggestions?

more options

Also, Cor-el has great points as well.

more options

Réiteach Roghnaithe

Thanks for trying it, people. That motivated me to move forward.

I can get memory usage from 350MB to over 1GB scrolling down to pictures that are 3 days old (mouseover).

Using safe mode, it did not happen (well. I had to scroll WAAAAY back to get up to 2GB).

I eventually disabled adBlock Plus and the issue essentially went away. It can still use a lot of memory, but I have to scroll a long ways back.

Looks like it might be that the page uses tons of iframes, which, it seems, adblock plus does not handle well. Any of you have any experience with that issue?

I have gotten malware twice (when the computer was unattended) through ad servers on news sites (my wife leaves the browser open on news) so I'm really adamant about ad blocking for security (not privacy).

Thanks for helping.

more options

The current version of Adblock Plus has been reported to cause issues. See:

You can look at uBlock Origin instead.

more options

ublock-origins does not exhibit the memory usage problems that adblock has. I guess that http://te5seract.tumblr.com/ would be a good site for the ublock-origin developers to tout as showing a major performance advantage.