Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Twitter web player embed doesn't work on certain site

  • 26 freagra
  • 3 leis an bhfadhb seo
  • 1111 views
  • Freagra is déanaí ó Techno769

more options

Just a forewarning, I'm kindly asking to not have any political arguments or time-wasting here. On this page http://www.infowars.com/pathetic-hardly-anyone-shows-up-to-tim-kaine-florida-rally, there are multiple embedded HTML5 videos from Twitter. I am able to view the videos fine other ways, but not as they are embedded on that specific URL for me. I already tried safe mode, and the videos on that page would still not display. What I get instead is in the attached screenshot. Clicking the play or any other buttons in that blank white box does nothing.

Unfortunately, the videos embedded in the page play as intended on Google Chrome, and they even work on my Firefox only IF I go to the respective pages on twitter.com and play them.

I tried comparing the inspect element tool between both Chrome and Firefox, and I can only tell that Chrome has a LOT more coding for that 'player container' as it's called.

I do use both AdBlock Plus and NoScript, and disabling both (along with all other add-ons) surprisingly didn't fix the issue.

I'm running FF 49.0.2.

Thank you to anyone who might have the same issue or be able to help.


Once again, this is not an error with the way the specific site or page is encoded, because the page's player works on Google Chrome. Just not Firefox.

Also, I have noticed this same issue with other videos from Twitter on the same site (infowars.com) on my Firefox.

Athraithe ag Techno769 ar

Réiteach roghnaithe

Techno769 said

jscher2000 said
That's hard to read... The only thing I know to be related to framed pages is network.auth.allow-subresource-auth but I don't know why that would affect Twitter. You could try the half-at-a-time method: delete the first half of the preferences in prefs.js and see whether the problem goes away. If it does, try putting half of those back. If not, delete half of the remaining preferences. And so on.


Yaayyyy!!! After much trial and error (with my dummy profile of course), I found the culprit: *drum roll please...*

user_pref("network.cookie.cookieBehavior", 3);

It looks like I'll have to accept all cookies from all sites for this to work. Let's see.

That was it. I have to "Always" accept cookies from third-party sites for the players to work.

Thank you so much for pointing me in the right directions.

Read this answer in context 👍 0

All Replies (20)

more options

Do you use private browsing windows? If so, check for a shield icon toward the left end of the address bar indicating that Tracking Protection is being applied. More info: What happened to Tracking Protection?.

more options

jscher2000 said

Do you use private browsing windows? If so, check for a shield icon toward the left end of the address bar indicating that Tracking Protection is being applied. More info: What happened to Tracking Protection?.

Thank you for the reply. I'm just curious, is this related to my issue? I don't use private browsing, and I do have Tracking Protection and "Always Apply Do Not Track" on.

more options

Tracking Protection can block embedded Facebook content, so it seemed worth checking if you have ruled out all the extensions as potential culprits.

more options

jscher2000 said

Tracking Protection can block embedded Facebook content, so it seemed worth checking if you have ruled out all the extensions as potential culprits.

Ahh, I see. Thank you again. I definitely did rule those out. Do you have any idea what might be causing this issue?

more options

Techno769 said

jscher2000 said
Tracking Protection can block embedded Facebook content, so it seemed worth checking if you have ruled out all the extensions as potential culprits.

Could you please try viewing this page in your Firefox and let me know what happens, if you're able to view the videos as intended, or if you get the blank white player as well?

more options

I saw the Mike Pence video that is missing in your screen shot, yes.

more options

Alright. Do you have any other ideas? Thanks for your help so far.

more options

Well, if it happened to me, I would dive into the developer tools, starting with right-clicking the Twitter player area and choosing Inspect Element. This should open the Inspector to that section of the HTML. I'm attaching two screenshots:

  • initial view: this is after right-clicking on the "poster" image
  • updated view: this is after clicking the play button

If the video tag is set up properly, perhaps there is something in front of it? If it's not set up properly, perhaps something is blocking the script from loading that we haven't considered, or maybe Twitter thinks your Firefox doesn't support HTML5 video??

more options

jscher2000 said

Well, if it happened to me, I would dive into the developer tools, starting with right-clicking the Twitter player area and choosing Inspect Element. This should open the Inspector to that section of the HTML. I'm attaching two screenshots:
  • initial view: this is after right-clicking on the "poster" image
  • updated view: this is after clicking the play button
If the video tag is set up properly, perhaps there is something in front of it? If it's not set up properly, perhaps something is blocking the script from loading that we haven't considered, or maybe Twitter thinks your Firefox doesn't support HTML5 video??

Alright, thanks a lot again for the help. Oddly enough, my inspector on this page looks vastly different than yours. I'm also getting quite a few bugs noted in the console. I attached a few screenshots from the different views I have. The next to last screenshot is the only video that even begins to look like it's supposed to. Once I click the play button, it turns into the blank white box you see in the other screens. These were all taken in safe mode.

Also interesting to note: there is a mysterious small "ev" button with a grey box around it at the end of one of the lines of code. When I click it (it behaves like a button) my Firefox freezes every time, forcing a restart.

Athraithe ag Techno769 ar

more options

I can't really tell what those errors are associated with, whether they related to Twitter content or other content loaded by the page.

The "ev" button should display a small popup of script handlers attached to that element. These may include scripts that run on click, mouseover, etc. I would suggest checking it on another page, but let's just avoid that issue for now.

Are the "Media Source Extensions" and "MSE & H.264" boxes enabled (blue) on the following test page:

https://www.youtube.com/html5

more options

jscher2000 said

I can't really tell what those errors are associated with, whether they related to Twitter content or other content loaded by the page. The "ev" button should display a small popup of script handlers attached to that element. These may include scripts that run on click, mouseover, etc. I would suggest checking it on another page, but let's just avoid that issue for now. Are the "Media Source Extensions" and "MSE & H.264" boxes enabled (blue) on the following test page: https://www.youtube.com/html5

Ok, I gotcha. Yes, all of those boxes are checked:

more options

Maybe your Firefox has higher security on iframes than mine does? I don't know where/how that would have been set.

more options

Just some more information for you:

This is what I originally mentioned in the first post. If I go to the actual page on Twitter's domain for the same video, I am able to view it fine (see screenshots). For some very strange reason, it's only the embeds on this particular site that I'm unable to view the videos on.

more options

I also realized I had an old copy of the 32-bit Firefox on my computer. I uninstalled both copies and reinstalled the newest 64-bit. Still the same problem.

more options

Again, thank you for your time and help.

  • sigh* this is probably what I'll have to do... Start over with a brand new profile for Firefox and see what it does.

Is there a way to save my current profile and create a new one to test with?

Update: I have the support article for how to back up and restore profiles, but if there is any other solution I would love to try those first.

Hopefully we can get to the bottom of this.

Athraithe ag Techno769 ar

more options

You can create a parallel profile without losing anything.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Oct2016, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (Many other buttons are still "under construction" so please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new.

Any improvement?

When you are done with the experiment, open the about:profiles page in the new profile, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

If you want to migrate selected files between the two profile folders, see:

Recovering important data from an old profile

more options

I'll be damned. As soon as I made the new profile, the videos played fine on that page. I would like to clone all of my information from my default profile into a new one.

What do you think?

more options

Try troubleshooting in reverse: copy the prefs.js file from your normal profile to the test profile (while Firefox is not running) to see whether that breaks it. If that does break it, then you could look at customized preferences in about:config to see whether there is some obvious candidate for causing this problem.

more options

jscher2000 said

Try troubleshooting in reverse: copy the prefs.js file from your normal profile to the test profile (while Firefox is not running) to see whether that breaks it. If that does break it, then you could look at customized preferences in about:config to see whether there is some obvious candidate for causing this problem.

Wow ok, so it turns out the prefs.js did in fact break it. I'll start digging... Any clue what it could be?

Wait a minute... I remember changing this stupid setting for the annoying "x video player is now in fullscreen mode" to make it go away. Other than that I can't think of anything

I found a set of user set values called "vidadblocker." I noticed in my add-ons that the video part of the AdBlockPlus isn't verified so I can't even use it in this version of Firefox. Think I'm safe to delete these values?

Athraithe ag Techno769 ar

more options

vidadblocker sounds like an extension, but it's weird that they are not under extension.vidadblocker. ?? Anyway, if you delete them and they turn out to be important, you can restore them from the other copy.

The fullscreen warning shouldn't be a factor with the initial load/play in the frame.

What about customized security settings?

  1. 1
  2. 2