Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox 49 error "This browser does not support video playback" playing mp4 videos in Twitter in Win 8.1 with Flash Player 23.0.0.162

  • 22 freagra
  • 13 leis an bhfadhb seo
  • 21664 views
  • Freagra is déanaí ó 1artworkz

more options

About a month and a half ago MP4 videos in Twitter 29 played fine. Then I updated to the latest version of Adobe Flash player on both my Win 8.1 and old XP computers. That is when I started getting "This browser does not support video playback" error when trying to play a mp4 video in Twitter. I ran Firefox in Safemode ... no change. I removed all addons ... no change. All Plugins are Ask to Activate or Always Activated. I uninstalled Firefox and Flash player and reinstalled .. no change. The videos work fine in MS IE II and Chrome 53.0.2785.116 m. H264 Codec is installed. YouTube videos play fine.

Réiteach roghnaithe

SOLVED: I was wrong. This problem has nothing to do with the way Firefox handles videos in Twitter. It has to do with how Windows handles videos. I initially ran a System Restore which installs a fresh copy of Win 8. I installed A fresh copy of Firefox 43 and did not get the error. I then restored my system using a back up image. I then tried removing every possible file and folder that was installed by Firefox on my computer and installed several different versions of Firefox and still got the same error. Back in June 2016 I turned off Automatic Updates because of the annoying nag to upgrade to Win 10 and totally forgot about turning it back. After turning Auto Backup on and installing all the upgrades, I no longer get the error message. I am now running Firefox 49 with the New Tab URL addon which fixed the New Tab feature I did not like. I want to thank jscher2000 for his diligent help and others that sent me helpful suggestions. I still have this problem on my old XP computer but I'm not going to attempt to fix it as I don't use it much for accessing the Internet.

Read this answer in context 👍 0

All Replies (20)

more options

Please note that Twitter no longer uses the Flash Player for videos. Like many websites, they have moved to the newer HTML5 video player. This is the same technology used by YouTube.

Please navigate to the YouTube HTML5 information page and let us know which formats do not display a check mark.

Thanks.

more options

These do not have a check mark. H.264 WebM VP8 How ever H.264 is installed as Plugin.

more options

Correction: I Have disable all Flash Down Loaders and Flash Player addons and now all are checked. But I still can't play videos in Twitter.

Athraithe ag 1artworkz ar

more options

Does that help with Twitter, too?

more options

No that did not work.

more options

Shot in the dark,   see if there are updates for your graphics
drivers:   http://mzl.la/1xKsEca

more options

I believe that Twitter uses the H.264 codec, so we need to figure out why that is not enabled on your system. This should display a check mark on YouTube, even if the Cisco plugin is not installed or active.

Please check some hidden settings for me:

  1. Enter about:config in the Firefox address bar
  2. Bypass the warning message
  3. Ensure that the following preferences have a value of true:
    • media.mediasource.enabled
    • media.mediasource.mp4.enabled
    • media.mediasource.webm.audio.enabled
    • media.mediasource.webm.enabled
Warning: You may need to restart Firefox for the changes to take effect.
more options

I did all the thing recommended on that page. Updated drivers from computer manufacture, checked and installed all MS updates, turned off hardware acceleration and switched webgl.disabled to false. Videos still do not play in Firefox. As I said earlier. This problem arose about a month and a half ago and videos run fine in both MS IE and Chrome.

more options

RE: about:config Search media.media all were set to true prior to search, so no change occurred and problem still exists. media.mediasource.enabled media.mediasource.format-reader media.mediasource.format-reader.mp4 media.mediasource.mp4.enabled media.mediasource.webm. enabled media.mediasource.whitelist

Athraithe ag 1artworkz ar

more options

Another shot in the dark:

See:   'Fix video and audio playback problems on Firefox for Windows'

    http://mzl.la/1zLUDHu

Athraithe ag Happy112 ar

more options

You might need the media features pack linked in that last article if your Windows 8.1 is an unbundled N or KN version.

Otherwise, my question is:

If YouTube's HTML5 page says your Firefox can play MP4 video, why isn't it working on Twitter?

To see whether this is a general problem, could you try the test video on the following page -- ignore the table at the top, which is not live / not you, and scroll down to the first player labeled "H.264/MP4" -- does that video work?

http://www.quirksmode.org/html5/tests/video.html

If that works, it could be a problem specific to how Twitter is serving videos, which is sending a .m3u8 file full of various addresses to load instead of sending a full MP4 video.

more options

I've seen 'Fix video and audio playback problems on Firefox for Windows' before and it does not apply.

From what I've read online is that Firefox does not internally support AVC/H.264. I don't know if this is true but the problem definitely reside with Firefox.

What about, media.hardware-video-decoding.failed being set to false?

more options

My version is not Windows 8.1 unbundled N or KN version.

All the videos on the test page run fine. My problem is with videos in Twitter.

Athraithe ag 1artworkz ar

more options

Twitter actually does some unique things. I used Firefox's Network Console to check on that, and there was an unfamiliar content type for their videos, mp2t instead of mp4. (Screenshot attached.) It plays on my Windows 7, so I don't think it's something that only works on newer versions of Windows.

If you want to see whether your Firefox is even retrieving those files, you can open the Network Monitor in the lower part of a Twitter tab using either:

  • Ctrl+Shift+q (if not intercepted by the page or an add-on)
  • Ctrl+Shift+k then click Network along the top bar
  • menu button > Developer > Network
  • (menu bar) Tools > Web Developer > Network

Then reload the Twitter page and the monitor should start filling with requests. You may need to scroll the top part of the tab to get to the video, then look for the M3U8 requests and see whether Firefox extracts out the .ts addresses and requests those.

more options

If this is not a common problem with other users, could it be some about:config leftover from and addon? I see a lot of BOLD entries that are USER SET.especially for media.gmp-. Is there any way to reset the CONFIG to default? I tried a fresh reinstall after uninstalling Firefox and Flash Player and running a couple Registry cleaners and deleting the Profile. The fresh install did not write a new Profile and the new install would not run because it could not find the Profile.

more options

RE: ' Firefox's Network Console' I found one *.m3u8 file from video.twitter.com. No *.ts listied.

As a side note, when I scroll down the page the video appears for a second and briefly runs for a millisecond before going black with the error message.

Athraithe ag 1artworkz ar

more options

Hmm... could you check that line in the network monitor for a few things:

(1) Does the Type column show x-mpegURL ?

(2) If you click the line and then the Response panel, does it look something like this (telling Firefox to request additional .m3u8 files):

#EXTM3U #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=320000,RESOLUTION=180x320,CODECS="mp4a.40.2,avc1.42001f" /ext_tw_video/779035755041656832/pu/pl/180x320/6Xnq_6z9mQw5YBYk.m3u8 #EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=832000,RESOLUTION=360x640,CODECS="mp4a.40.2,avc1.42001f" /ext_tw_video/779035755041656832/pu/pl/360x640/n7z-c6scOz7MOFpY.m3u8

Or like this (telling Firefox to retrieve .ts files):

#EXTM3U #EXT-X-VERSION:6 #EXT-X-MEDIA-SEQUENCE:0 #EXT-X-TARGETDURATION:3 #EXTINF:3.000, /ext_tw_video/779035755041656832/pu/vid/0/3000/180x320/hPHKeQRWZxIyeJIY.ts #EXTINF:2.267, /ext_tw_video/779035755041656832/pu/vid/3000/5267/180x320/-DsJluFrME5YLq8y.ts #EXT-X-ENDLIST

Nerd note: To paste text here that starts new lines with # and not have it turned into numbering, you need to surround the pasted text with

<nowiki>pasted text</nowiki>


Either way, I'm guessing your Firefox has a problem with M3U8 files, but I'm not sure what could cause that.

To try clean settings, you could do this:

New Profile Test

This takes about 3 minutes, plus the time to test Twitter.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Sept2016, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button.

Firefox should exit and then start up using the new profile, which will just look brand new.

Does Twitter video work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

1. Network m3u8 file Response window is blank. No text. The file type is x-mpegURL

2. about:profiles does not do anything but produces an error message, "The address isn't valid" "The URL is not valid and cannot be loaded."

Athraithe ag 1artworkz ar

more options

1artworkz said

2. about:profiles does not do anything but produces an error message, "The address isn't valid" "The URL is not valid and cannot be loaded."

Whoops, I thought you had Firefox 47. Now that I look closer, it seems to be Firefox 41. Why Firefox 41???

Here's the old way to create and switch among profiles:

Exit Firefox and start up in the Profile Manager using the Windows Run dialog (hold down Windows key and tap R) or the system search box -- type this and press Enter:

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like Sept2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

I am using 41 because I tried 49 and I didn't like the New Tab feature The message said it was for security reasons. I didn't like the Default Home Page with all the tiles.

I fixed my problem with a completely clean install of Firefox. Now the videos in Twitter play fine as described here. https://support.mozilla.org/en-US/questions/1062472

I will add each of the extensions and test Twitter and post my findings here when I find the culprit.

  1. 1
  2. 2