X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to I set add-ons to be enabled by default?

Postáilte

All of my add-ons are disabled each bootup or wake it from sleep and start of Firefox session. Once I decide an add-on is desired, I want it to default to be enabled rather than disabled on statup. I've done my best to set preferences to allow my add-ons by default, but either I'm ignorant of how to do it, or it is not obvious

Example add-ons: 1Password; Adobe Acrobat Create PDF; Disconnect; NoScript: Open With Photoshop; Privacy Badger; Self-Destructing Cookies

I've been a very satisfied Firefox user for years but since about ver. 41 (i'm on v. 41.0.2 now) Firefox has become too inconvenient

All of my add-ons are disabled each bootup or wake it from sleep and start of Firefox session. Once I decide an add-on is desired, I want it to default to be enabled rather than disabled on statup. I've done my best to set preferences to allow my add-ons by default, but either I'm ignorant of how to do it, or it is not obvious Example add-ons: 1Password; Adobe Acrobat Create PDF; Disconnect; NoScript: Open With Photoshop; Privacy Badger; Self-Destructing Cookies I've been a very satisfied Firefox user for years but since about ver. 41 (i'm on v. 41.0.2 now) Firefox has become too inconvenient

Tuilleadh mionsonraí faoin chóras

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Tuilleadh Eolais

FredMcD
  • Top 10 Contributor
4270 réiteach 59887 freagra

Normally, add-ons are already active during the install. What is your computer system?

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.


dtvz said

All of my add-ons are disabled each bootup

If you close Firefox, then re-start it, is the same problem still there?

Normally, add-ons are already active during the install. What is your computer system? Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.''' ------------- ''dtvz [[#question-1091512|said]]'' <blockquote> All of my add-ons are disabled each bootup </blockquote> If you close Firefox, then re-start it, is the same problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159010 freagra

What security software do you have?

Make sure that you do not have security software or other software that protect files against changes is causing your issue.


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.

What security software do you have? Make sure that you do not have security software or other software that protect files against changes is causing your issue. ---- It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available. If this hasn't helped then also delete the addons.json file.

Úinéir na ceiste

Note: it's not that I'm unable to install an add-on (same as extension?)... its that once I enable my extension, it becomes "Enabled: false" after reboot and Firefox startup. All extensions are the latest build. Upon startup, all extensions appear in their own tab, each entitled " Install Add-on". I can enable each add-on, one-at-a-time and have them all be enabled for a given Firefox session... but the enabling process is not sticky.

Deleting extensions.* files did not correct this issue. Uninstalling and reinstalling Firefox did not correct.

Within Application Basics file, below, I realize that Norton Toolbar and Adobe Acrobat - Create PDF are not compatible with Firefox V. 41.0.2 . I don't even try to enable these.

Here is the Application Basics file:

Application Basics


Name: Firefox Version: 41.0.2 Build ID: 20151014143721 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 Multiprocess Windows: 0/1 (default: false)

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: 1Password Version: 4.4.3 Enabled: false ID: onepassword4@agilebits.com

Name: Adobe Acrobat - Create PDF Version: 2.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: Disconnect Version: 3.15.3.1-signed Enabled: false ID: 2.0@disconnect.me

Name: Norton Toolbar Version: 2015.5.4.10 Enabled: false ID: {EBA722F5-038F-4CAF-9EE2-545A221628BC}

Name: NoScript Version: 2.6.9.39 Enabled: false ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Open With Photoshop Version: 41.1 Enabled: false ID: {f3f219f9-cbce-467e-b8fe-6e076d29665c}

Name: Privacy Badger Version: 1.0.3 Enabled: false ID: jid1-MnnxcxisBPnSXQ@jetpack

Name: Self-Destructing Cookies Version: 0.4.8 Enabled: false ID: jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack

Graphics


Adapter Description: ATI Radeon HD 4800 Series Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 1024 Asynchronous Pan/Zoom: none Device ID: 0x9442 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.17461) Driver Date: 7-3-2012 Driver Version: 8.970.100.3000 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC) Subsys ID: 15301462 Supports Hardware H264 Decoding: true Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4800 Series Direct3D11 vs_4_1 ps_4_1) windowLayerManagerRemote: true AzureCanvasBackend: direct2d 1.1 AzureContentBackend: direct2d 1.1 AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 1 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20151014143721 browser.startup.homepage: file:///H:/dvz_index.htm browser.startup.homepage_override.buildID: 20151014143721 browser.startup.homepage_override.mstone: 41.0.2 browser.tabs.drawInTitlebar: false browser.tabs.warnOnClose: false dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 41.0.2 gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 41.0.2 gfx.driver-init.deviceID: 0x9442 gfx.driver-init.driverVersion: 8.970.100.3000 gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 media.gmp-gmpopenh264.lastUpdate: 1446402621 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20151014143721 media.gmp-manager.lastCheck: 1446402620 media.hardware-video-decoding.failed: false network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.donottrackheader.value: 1 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8

NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2

Experimental Features


Note: it's not that I'm unable to install an add-on (same as extension?)... its that once I enable my extension, it becomes "Enabled: false" after reboot and Firefox startup. All extensions are the latest build. Upon startup, all extensions appear in their own tab, each entitled " Install Add-on". I can enable each add-on, one-at-a-time and have them all be enabled for a given Firefox session... but the enabling process is not sticky. Deleting extensions.* files did not correct this issue. Uninstalling and reinstalling Firefox did not correct. Within Application Basics file, below, I realize that Norton Toolbar and Adobe Acrobat - Create PDF are not compatible with Firefox V. 41.0.2 . I don't even try to enable these. Here is the Application Basics file: Application Basics ------------------ Name: Firefox Version: 41.0.2 Build ID: 20151014143721 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 Multiprocess Windows: 0/1 (default: false) Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: 1Password Version: 4.4.3 Enabled: false ID: onepassword4@agilebits.com Name: Adobe Acrobat - Create PDF Version: 2.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom Name: Disconnect Version: 3.15.3.1-signed Enabled: false ID: 2.0@disconnect.me Name: Norton Toolbar Version: 2015.5.4.10 Enabled: false ID: {EBA722F5-038F-4CAF-9EE2-545A221628BC} Name: NoScript Version: 2.6.9.39 Enabled: false ID: {73a6fe31-595d-460b-a920-fcc0f8843232} Name: Open With Photoshop Version: 41.1 Enabled: false ID: {f3f219f9-cbce-467e-b8fe-6e076d29665c} Name: Privacy Badger Version: 1.0.3 Enabled: false ID: jid1-MnnxcxisBPnSXQ@jetpack Name: Self-Destructing Cookies Version: 0.4.8 Enabled: false ID: jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack Graphics -------- Adapter Description: ATI Radeon HD 4800 Series Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 1024 Asynchronous Pan/Zoom: none Device ID: 0x9442 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.17461) Driver Date: 7-3-2012 Driver Version: 8.970.100.3000 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC) Subsys ID: 15301462 Supports Hardware H264 Decoding: true Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4800 Series Direct3D11 vs_4_1 ps_4_1) windowLayerManagerRemote: true AzureCanvasBackend: direct2d 1.1 AzureContentBackend: direct2d 1.1 AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 Important Modified Preferences ------------------------------ browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 1 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20151014143721 browser.startup.homepage: file:///H:/dvz_index.htm browser.startup.homepage_override.buildID: 20151014143721 browser.startup.homepage_override.mstone: 41.0.2 browser.tabs.drawInTitlebar: false browser.tabs.warnOnClose: false dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 41.0.2 gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 41.0.2 gfx.driver-init.deviceID: 0x9442 gfx.driver-init.driverVersion: 8.970.100.3000 gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 media.gmp-gmpopenh264.lastUpdate: 1446402621 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20151014143721 media.gmp-manager.lastCheck: 1446402620 media.hardware-video-decoding.failed: false network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.donottrackheader.value: 1 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true Important Locked Preferences ---------------------------- JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8 NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2 Experimental Features ---------------------

Athraithe ag dtvz ar

cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159010 freagra

Freagra Cabhrach

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Úinéir na ceiste

cor-el, Thank you for the suggestion! Deleting the prefs.js file solved my issue. I lost a few of my settings and had to reinstall and enable 1 Password, but upon computer reboot and Firefox startup, all my previously enabled extensions became sticky and do not need to be re-enabled. This is exactly what I had hoped. You solved my problem. Thank you again!

cor-el, Thank you for the suggestion! Deleting the prefs.js file solved my issue. I lost a few of my settings and had to reinstall and enable 1 Password, but upon computer reboot and Firefox startup, all my previously enabled extensions became sticky and do not need to be re-enabled. This is exactly what I had hoped. You solved my problem. Thank you again!
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159010 freagra

I see that the solution is removed.

Did the problem return?

Did you check for other software on your computer causing this issue?

I see that the solution is removed. Did the problem return? Did you check for other software on your computer causing this issue?

Úinéir na ceiste

Yesterday after deleting prefs.js, computer reboot and start of Firefox session I had a successful sticky enabling of all my chosen extensions and wrote that my problem was solved. But this morning upon startup all extensions were disabled in tabs again, forcing me to go through the re-enabling process. Problem not solved.

Is there anything in about:config I might try? The only place that lists my extensions is:

extensions.xpiState =

{"app-profile":{"2.0@disconnect.me":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\2.0@disconnect.me.xpi","e":false,"v":"3.15.3.1-signed","st":1446408319769},"jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack.xpi","e":false,"v":"0.4.8","st":1446402790982},"jid1-MnnxcxisBPnSXQ@jetpack":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\jid1-MnnxcxisBPnSXQ@jetpack.xpi","e":false,"v":"1.0.3","st":1446402742398},"onepassword4@agilebits.com":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\onepassword4@agilebits.com.xpi","e":false,"v":"4.4.3","st":1446442595200},"{73a6fe31-595d-460b-a920-fcc0f8843232}":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\{73a6fe31-595d-460b-a920-fcc0f8843232}.xpi","e":false,"v":"2.6.9.39","st":1446402815573},"{f3f219f9-cbce-467e-b8fe-6e076d29665c}":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\{f3f219f9-cbce-467e-b8fe-6e076d29665c}.xpi","e":false,"v":"41.1","st":1446408320689}},"app-global":{"{972ce4c6-7e08-4474-a285-3208198ce6fd}":{"d":"C:\\Program Files (x86)\\Mozilla Firefox\\browser\\extensions\\{972ce4c6-7e08-4474-a285-3208198ce6fd}","e":true,"v":"41.0.2","st":1446233928659,"mt":1444864260000}},"winreg-app-global":{"web2pdfextension@web2pdf.adobedotcom":{"d":"C:\\Program Files (x86)\\Adobe\\Acrobat 11.0\\Acrobat\\Browser\\WCFirefoxExtn","e":false,"v":"2.0","st":1437083478870,"mt":1348461836000},"{EBA722F5-038F-4CAF-9EE2-545A221628BC}":{"d":"C:\\ProgramData\\Norton\\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\\N360_22.5.2.15\\coFFPlgn","e":false,"v":"2015.5.4.10","st":1446431301825,"mt":1446476419576}}}

Yesterday after deleting prefs.js, computer reboot and start of Firefox session I had a successful sticky enabling of all my chosen extensions and wrote that my problem was solved. But this morning upon startup all extensions were disabled in tabs again, forcing me to go through the re-enabling process. Problem not solved. Is there anything in about:config I might try? The only place that lists my extensions is: extensions.xpiState = {"app-profile":{"2.0@disconnect.me":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\2.0@disconnect.me.xpi","e":false,"v":"3.15.3.1-signed","st":1446408319769},"jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack.xpi","e":false,"v":"0.4.8","st":1446402790982},"jid1-MnnxcxisBPnSXQ@jetpack":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\jid1-MnnxcxisBPnSXQ@jetpack.xpi","e":false,"v":"1.0.3","st":1446402742398},"onepassword4@agilebits.com":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\onepassword4@agilebits.com.xpi","e":false,"v":"4.4.3","st":1446442595200},"{73a6fe31-595d-460b-a920-fcc0f8843232}":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\{73a6fe31-595d-460b-a920-fcc0f8843232}.xpi","e":false,"v":"2.6.9.39","st":1446402815573},"{f3f219f9-cbce-467e-b8fe-6e076d29665c}":{"d":"C:\\Users\\DVZ\\AppData\\Roaming\\Mozilla\\Firefox\\Profiles\\uo057io4.default-1446402514596\\extensions\\{f3f219f9-cbce-467e-b8fe-6e076d29665c}.xpi","e":false,"v":"41.1","st":1446408320689}},"app-global":{"{972ce4c6-7e08-4474-a285-3208198ce6fd}":{"d":"C:\\Program Files (x86)\\Mozilla Firefox\\browser\\extensions\\{972ce4c6-7e08-4474-a285-3208198ce6fd}","e":true,"v":"41.0.2","st":1446233928659,"mt":1444864260000}},"winreg-app-global":{"web2pdfextension@web2pdf.adobedotcom":{"d":"C:\\Program Files (x86)\\Adobe\\Acrobat 11.0\\Acrobat\\Browser\\WCFirefoxExtn","e":false,"v":"2.0","st":1437083478870,"mt":1348461836000},"{EBA722F5-038F-4CAF-9EE2-545A221628BC}":{"d":"C:\\ProgramData\\Norton\\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\\N360_22.5.2.15\\coFFPlgn","e":false,"v":"2015.5.4.10","st":1446431301825,"mt":1446476419576}}}
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159010 freagra

All extensions except the default theme show as disabled ("e":false).

Did you check the settings in your Norton software to make sure it isn't causing this problem?

Does "e":false change to "e":true once you have enabled the extensions?

You can try to make a backup copy of prefs.js when Firefox is running and a second copy when you close Firefox and check of both have "e":true. Check the prefs.js file in the profile folder after a reboot to see if the content hasn't changed and extensions are still enabled.

All extensions except the default theme show as disabled ("e":false). Did you check the settings in your Norton software to make sure it isn't causing this problem? Does "e":false change to "e":true once you have enabled the extensions? You can try to make a backup copy of prefs.js when Firefox is running and a second copy when you close Firefox and check of both have "e":true. Check the prefs.js file in the profile folder after a reboot to see if the content hasn't changed and extensions are still enabled.

Úinéir na ceiste

"e":false DOES change to "e":true once I have enabled the extensions... for a period of time. On bootup extensions revert to disabled. As far as I can tell, Norton is not the problem. It has not cause an issue in the past. My problem seems not to be common, but Norton is common.

Win10 machine does not have this issue with same extensions. Win7 desktop does.

In order to do a completely clean install, I'm not experienced enough to remove ALL traces of Firefox on my computer, including preferences, extensions, deep background files left after uninstalling program. Some files and folders associated with Firefox simply do not delete manually.

This issue began after v.41

"e":false DOES change to "e":true once I have enabled the extensions... for a period of time. On bootup extensions revert to disabled. As far as I can tell, Norton is not the problem. It has not cause an issue in the past. My problem seems not to be common, but Norton is common. Win10 machine does not have this issue with same extensions. Win7 desktop does. In order to do a completely clean install, I'm not experienced enough to remove ALL traces of Firefox on my computer, including preferences, extensions, deep background files left after uninstalling program. Some files and folders associated with Firefox simply do not delete manually. This issue began after v.41
FredMcD
  • Top 10 Contributor
4270 réiteach 59887 freagra

Follow these instructions;

Follow these instructions; *1 '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]v41''' {web link} *2 '''[https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer Uninstall Firefox from your computer]''' {web link}<br>DO NOT remove your profiles. *3 After, reboot the computer. Then run the full installer.
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159010 freagra

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Úinéir na ceiste

I don't know what exactly happened to fix my issue, but my extensions have now finally defaulted to a sticky enabled state.

If I was to make a guess, I would say that the order in which I opened each tab to enable each extensions was important. Some of my extensions required a restart of Firefox... others did not. After enabling those extensions that did NOT require a restart, those extensions became sticky enabled. I then enabled one-at-a-time those extensions that required a restart.... after which, those extensions became sticky enabled as well.

Issue resolved, but unsure of why it occurred in the first place, nor the exact reason it resolved. Thanks for the help.

I don't know what exactly happened to fix my issue, but my extensions have now finally defaulted to a sticky enabled state. If I was to make a guess, I would say that the order in which I opened each tab to enable each extensions was important. Some of my extensions required a restart of Firefox... others did not. After enabling those extensions that did NOT require a restart, those extensions became sticky enabled. I then enabled one-at-a-time those extensions that required a restart.... after which, those extensions became sticky enabled as well. Issue resolved, but unsure of why it occurred in the first place, nor the exact reason it resolved. Thanks for the help.
cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159010 freagra

You normally only need to tick the box and click the Continue button to confirm the change and proceed to the next page.

You normally only need to tick the box and click the Continue button to confirm the change and proceed to the next page.