Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

"When Firefox Starts" setting keeps getting changed to "Show my home page"

  • 13 freagra
  • 6 leis an bhfadhb seo
  • 5 views
  • Freagra is déanaí ó duechi

more options

I keep changing the option about what to show on next startup to "Show my windows and tabs from last time". Every time I restart Firefox, it gets changed back to "Show my home page". I've uninstalled Firefox, deleted the Mozilla folders under AppData, reinstalled, and it still keeps losing my selection.

All Replies (13)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Nothing else in that post fixed it. Refresh didn't work and I don't see any Plugins that would affect it. Firefox remembers every setting change I've tried except for what to show on next startup.

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the current Firefox profile folder:

"AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.

more options

I've uninstalled, deleted everything Firefox (that I know of), and reinstalled. Same issue with that one setting.

more options

Did you check your security software?

Some security software has a browser protection.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

more options

No change. I can make any other setting change but not that one though.

more options

Now that is very odd.

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

Application Basics


Name: Firefox Version: 40.0.3 Build ID: 20150826023504 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0 Multiprocess Windows: 0/1 (default: false)

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: McAfee ScriptScan for Firefox Version: 15.3.0 Enabled: false ID: {D19CA586-DD6C-4a0a-96F8-14644F340D60}

Graphics


Adapter Description: Intel(R) HD Graphics Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32 Adapter RAM: Unknown Asynchronous Pan/Zoom: none Device ID: 0x0046 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.17461) Driver Date: 6-10-2011 Driver Version: 8.15.10.2418 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC) Subsys ID: 04281028 Supports Hardware H264 Decoding: true Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: true AzureCanvasBackend: direct2d 1.1 AzureContentBackend: direct2d 1.1 AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 (#0) Error: OpenSharedResource failed for format 65

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 2 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20150826023504 browser.startup.homepage_override.mstone: ignore dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 40.0.3 gfx.direct3d.last_used_feature_level_idx: 1 media.gmp-eme-adobe.lastUpdate: 1442252061 media.gmp-eme-adobe.version: 12 media.gmp-gmpopenh264.lastUpdate: 1442252062 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20150826023504 media.gmp-manager.lastCheck: 1442252061 network.automatic-ntlm-auth.trusted-uris: https://fs.tceq.texas.gov network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1442253054 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1442253054

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8

NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2

Experimental Features


more options

Hey, cor-el, what is browser.startup.homepage_override.mstone: ignore


Issues have been previously linked to the McAfee Site Advisor extension. Try to disable it and see if the problem persists.

http://service.mcafee.com/faqdocument.aspx?id=TS100162 How to uninstall SiteAdvisor

To disable it: Type "about:addons" in the Location bar Find the extension and click on its "Disable" button

more options

I don't find a McAfee Site Advisor extension. The McAfee ScriptScan for Firefox is already disabled.

more options
more options

Interesting. The article talks about startup.homepage_override_url but there is no such setting above.

more options

I found the setting in about:config, and its current value is 'ignore'.