Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

When I try to share on Pinterest, I get a blank page titled "about blank". I can't connect to pinterest

  • 12 freagra
  • 3 leis an bhfadhb seo
  • 124 views
  • Freagra is déanaí ó cor-el

more options

I'm a member of Shopstyle, and have never had a problem posting to pinterest. Now I can't seem to connect to facebook or twitter either. Instead of going to the sites, I receive the "about blank" box. It won't connect!

All Replies (12)

more options

Thank you for your system information (Question Details > More System Details). I don't see the Pinterest extension listed, so are you using a button in the site that you want to share?

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

It worked in safe mode but Only in safe mode. Now what??

more options

jscher2000 said

Thank you for your system information (Question Details > More System Details). I don't see the Pinterest extension listed, so are you using a button in the site that you want to share? Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode. If Firefox is not running: Hold down the Shift key when starting Firefox. If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any improvement?
more options

Only works in safe mode. Is there something else I should do?

more options

Then I think there is a good chance that Ghostery is blocking something. The way the sharing buttons are set up may be tripping its anti-tracking protection. I don't use Ghostery myself, but can you find a way to make an exception or temporarily turn it off when you want to share?

more options

I have checked ghostery and didn't see a problem. I will check again and try to turn it off! Thanks so much!

more options

Checked ghostery and even disable it when trying to share to pinterest. I even whitelisted the site I want to pin from. When I tried to share to facebook, I got the message (40) post to facebook.

more options

I don't now what to make of that message. Could you give a sample address of the page you're starting from and trying to use the sharing buttons?

Also, I skipped over one of our general recommendations for when pages do not behave normally, which is to clear Firefox's cache. This article has the steps: How to clear the Firefox cache. If you have a large hard drive, that usually takes a minute or two.

more options

I cleared the cache, history, everything. The site I try to share from is: link text I have contacted their site as well as pinterest help. I don't know what to make of this either!

I appreciated your help!

more options

Note that you may have to clear the cache and remove cookies only from websites that cause problems after having disabled Ghostery.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

No luck yet! I've tried everything! I'm thinking it may be my windows settings or something like that. Thanks for your help.

more options

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content from specific domains fails to load or possibly is blocked (file size is zero).

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.