Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Bookmark this page shortcut is not working

  • 10 bhfreagra
  • 1 leis an bhfadhb seo
  • 32 views
  • Freagra is déanaí ó jscher2000

more options

My hard drive got fried during a power outage and the repair shop was able to clone it. Firefox seemed to work fine once I got it back but the "bookmark this page" button on my toolbar no longer works. I have to manually add them. I've tried various solutions: deleted places.sqlite, only worked temporarily refreshed Firefox, only worked temporarily uninstalled/reinstalled Firefox, did nothing

I frequently bookmark things and while I can do them manually, I really like the ease of the button. Would really love some help, please!

All Replies (10)

more options

Is the problem limited to the button? For example, does it work to use any of these:

  • Ctrl+d
  • right-click the page > star icon
  • (menu bar) Bookmarks > Bookmark This Page

It's a little puzzling that some things fixed the problem, but only temporarily. When bookmarking stopped working, did you notice any other changes around the same time?

more options

The first two don't work. I wanted to clarify that by menu bar, you mean the star button? If so, that doesn't work.

The only other thing I noticed is that FIrefox no longer saves whatever tabs I had open when I previously closed Firefox. I usually close it with my mailbox open (Yahoo) and now when it opens, it goes to the default home page.

more options

Could you check these settings:

(1) Whether Firefox is set for automatic private browsing

"3-bar" menu button (or Tools menu) > Options > Privacy

If the selector says "Firefox will: Never remember history" change it to "Firefox will: Use custom settings for history"

If the box for "Always use private browsing mode" is checked, uncheck it and allow Firefox to restart (assuming you do not have any pending work/transactions that would get lost

(2) Whether Firefox is set to clear history at shutdown

Further down on that panel, if the box for "Clear history when Firefox closes is checked", click the Setting button and make sure "Browsing and download history" is NOT selected

(3) Your startup setting

"3-bar" menu button (or Tools menu) > Options > General

If it does not already say "When Firefox starts: Show my windows and tabs from last time" go ahead and select that

I think that covers the main things. Does Firefox restore your session at the next startup?

more options

1. I changed it and it reverted back when I restarted.

2. "Clear history" was NOT checked.

3. I don't have that option...

My session wasn't restored when I restarted.

more options

We have a help article on possible reasons that changes such as starting normally might not be saved. Could you review this for things you have not tried yet and see whether any of them are helpful: How to fix preferences that won't save.

more options

I'm at the bottom of those options, the prefs.js part. In my profile folder, I have just a prefs file, no .js after it. Since it's not exactly the same, I didn't want to delete it without checking if that was the right one or not.

more options

I was thinking about when the issue with the bookmarks started and realized that it was when I updated to 40. I just reinstalled 39 and bookmarks work again. I know for security reasons I should stay with the newest version but I need Firefox to work!

more options

We didn't discuss extensions as a potential issue because you mentioned using Refresh. In case the problem returned after reloading some extensions, I read on another site that various IE Tab extensions and possibly the Tree Style Tab extension could be affecting the bookmark dialog.

more options

I noticed that all forms of "Bookmark this page" stopped working after I upgraded to the newest Firefox. Now the only way I can add a bookmark is to show all bookmarks and use the add button there. Nothing else works.

I did see that someone mentioned that the IETab extensions could be causing the problem and I do have that - but I have to have it for work as some of out internal pages will not work otherwise.

more options

Hi VMGuru, although IE Tab extensions are convenient, you still could use IE separately from Firefox. There are extensions to make it easy to launch IE for a given link, such as https://addons.mozilla.org/firefox/addon/open-in-ie/