Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Click X (Twitter) link always goes back to previous link when Google Analytics Suppression AddOn installed

  • 5 antwurd
  • 0 hawwe dit probleem
  • 41 werjeftes
  • Lêste antwurd fan Bill

more options

Running Firefox 120.0.1 on Windows 10. I also run Vivaldi and test with Chrome. I installed Google Analytics Opt-Out add-ons on FF, Vivaldi, and Chrome. When I go to any site with links to X (Twitter), and click on the link, instead of that link appearing the last X link I went to appears. If I click again I get to the correct link.

When I disable the Google Analytics Opt-Out add-on all works fine. This doesn't happen with either of the Chromium browsers, so I'm thinking there's something happening in Firefox by avoiding Google analytics that isn't in the Chromium browsers. In addition, this behavior began within the past couple of weeks of recent FF updates.

I installed several different Google Analytics add-ons and the same thing happened in FF, but not in the Chromium browsers.

Any ideas? I know I can disable the analytics crushers but I really don't want Google hijacking my browsing.

Running Firefox 120.0.1 on Windows 10. I also run Vivaldi and test with Chrome. I installed Google Analytics Opt-Out add-ons on FF, Vivaldi, and Chrome. When I go to any site with links to X (Twitter), and click on the link, instead of that link appearing the last X link I went to appears. If I click again I get to the correct link. When I disable the Google Analytics Opt-Out add-on all works fine. This doesn't happen with either of the Chromium browsers, so I'm thinking there's something happening in Firefox by avoiding Google analytics that isn't in the Chromium browsers. In addition, this behavior began within the past couple of weeks of recent FF updates. I installed several different Google Analytics add-ons and the same thing happened in FF, but not in the Chromium browsers. Any ideas? I know I can disable the analytics crushers but I really don't want Google hijacking my browsing.

Keazen oplossing

Well, this was helpful. I have "Enhanced Tracking Protection" set to strict. I also have the following entries in my "hosts" file (I'm on Windows 10 Pro):

0.0.0.0 google-analytics.com 0.0.0.0 www.google-analytics.com 0.0.0.0 ssl.google-analytics.com

I think I will now leave well enough alone. Thanks for your thoughts.  :-)

Dit antwurd yn kontekst lêze 👍 1

Alle antwurden (5)

more options

Sounds like you need to report it to the devs for the add-on. The 2 add-ons have not been updated in a few years. see screenshot

Bewurke troch jonzn4SUSE op

more options

You can set Enhanced Tracking Protection to Strict to block Google Analytics as you can see if you click the shield.

more options

You can see a message about this in the Web Console.

Google Analytics (legacy version) is being shimmed by Firefox. See https://bugzilla.mozilla.org/show_bug.cgi?id=1487072 for details.
more options

The Google Analytics Opt-Out is just a polite request which could easily be dishonored by a technical glitch or mishap. It is better to do the blocking pro-actively yourself with Strict Tracking Protection or uBlock Origin.

more options

Keazen oplossing

Well, this was helpful. I have "Enhanced Tracking Protection" set to strict. I also have the following entries in my "hosts" file (I'm on Windows 10 Pro):

0.0.0.0 google-analytics.com 0.0.0.0 www.google-analytics.com 0.0.0.0 ssl.google-analytics.com

I think I will now leave well enough alone. Thanks for your thoughts.  :-)