Passer à Thunderbird

Passer d'Apple Mail à Thunderbird

Thunderbird peut importer vos messages et carnets d'adresses OS X, mais il ne peut pas importer les paramètres de votre compte. (Actuellement l'importation des messages et carnets d'adresses fonctionne uniquement avec Apple Mail 5.0 ou les versions antérieures).

Importation des messages d'Apple Mail

  1. Dans la barre de menus, ouvrez le menu Outils et cliquez sur Importer… L'assistant d'importation s'ouvre.

    mac-toolsimport

  2. Sélectionnez Messages, puis cliquez sur le Suivant

    mac-ImportWizard

  3. Sélectionnez Apple Mail, puis cliquez sur Suivant

    mac-importmail

  4. Vous verrez un journal des dossiers qui ont été importés avec succès. Cliquez ensuite sur le bouton Terminer pour fermer l'assistant d'importation.

    mac-mailimportedsuccess

Vos messages importés apparaissent dans le compte Dossiers locaux, dans un dossier appelé Importation Apple Mail.
mac-whereimportedmail

Importation du carnet d'adresses de OS X

Thunderbird va importer votre carnet d'adresses et l'afficher dans la fenêtre du carnet d'adresses de Thunderbird. Dans la barre de menus, sélectionnez le menu Fenêtre puis cliquez sur Carnet d'adresses. Votre carnet d'adresses apparaît dans le volet gauche.
mac-OSXaddressbook

Si vous voulez importer des adresses vers le carnet d'adresse Thunderbird, il suffit de glisser-déposer les contacts à partir du dossier Carnet d'adresses Mac OS X vers le carnet Adresses personnelles.

Note : vous pouvez sélectionner tous les contacts à la fois en appuyant simultanément sur les touches et A

Passer de Windows Mail ou Windows Live Mail à Thunderbird

Windows Mail est le client de messagerie par défaut inclus dans Windows Vista. Windows Live Mail est le client de messagerie fourni avec Windows Essentials. Les messages de ces programmes sont stockés dans le format de fichier .eml. Afin de pouvoir exporter les messages depuis Windows Mail ou Windows Live Mail vers Thunderbird, vous devez exporter les messages depuis l'application Windows et les importer dans Thunderbird. Une approche similaire est nécessaire pour importer les contacts depuis Windows Mail ou Windows Live Mail dans Thunderbird.

Pour trouver l'emplacement des messages de Windows Mail ou Windows Live Mail, allez dans Outils > Options > Avancés > Maintenance > Dossier de stockage

Si vous ne voyez pas Outils, essayez à la place Fichier > Options > Messages… > Avancé > Maintenance…

Importer les messages de Windows Mail

L'importation du courrier Windows (fichiers .eml) dans Thunderbird est facilitée avec le module complémentaire ImportExportTools. Téléchargez et installez ce module pour transférer des messages de Windows Live Mail à Thunderbird.

  1. Exportez vos messages depuis Windows Mail dans le format .eml.
  2. Dans Thunderbird, créez un dossier (IMPORT MESSAGES WLM par exemple) dans Dossiers Locaux pour y mettre les messages importés et sélectionnez-le.
  3. Faites un clique droit sur le dossier puis sélectionnez Outils > Importer/Exporter au format <.mbox> / <.eml>
  4. Choisissez Importer tous les fichiers <.eml> depuis un dossier > aussi depuis les sous-dossiers
  5. L'explorateur s'ouvre. Recherchez le dossier contenant les fichiers eml. L'emplacement par défaut (Sous Windows 7) pour Windows Live Mail est : C:\Utilisateur\<nom_session>\AppData\Local\Microsoft\Windows Live Mail\<nom_utilisateur>
  6. Cliquez sur Sélectionner un dossier. Vos messages seront importés dans le dossier sélectionné.
Note : pour être en mesure de voir le dossier « AppData » vous devez d'abord, depuis Windows, changer les options des dossiers pour Afficher les fichiers cachés, dossiers et lecteurs. Consultez l'article du support Microsoft Afficher les fichiers cachés pour plus d'informations.
impo_eml_wlm_iet_6.png

Importer les contacts de Windows Mail

Pour importer les contacts depuis Windows dans Thunderbird, vous devez d'abord les exporter dans des fichiers vCard (format .vcf), puis les importer dans Thunderbird.

  1. Dans Windows Live Mail, ouvrez les Contacts et sélectionnez tous les contacts que vous souhaitez exporter.
  2. Cliquez sur Exporter > Carte de visite (.VCF)
  3. Sélectionnez un dossier vide pour les sauvegarder dedans.

Dans Thunderbird, installez le module complémentaire MoreFunctionsForAddressBook en suivant ces instructions.

  1. Cliquez sur Carnet d'adresses
  2. Sélectionnez le carnet d'adresses dans lequel vous souhaitez importer les contacts
  3. Cliquez sur Outils > MoreFunctionsForAddressBook > Actions for Contacts > Import vCard / VCF
  4. Naviguez jusqu'au dossier où vous avez exporté vos contacts
  5. Sélectionnez tous les contacts que vous souhaitez importer
  6. Cliquez sur Open pour importer tous les contacts sélectionnés

Si cela ne fonctionne pas ou n'est pas applicable dans votre cas, vous pouvez essayer cette alternative :

Consultez l'article Exporter des contacts à partir d’Outlook sur Microsoft.com pour obtenir des instructions sur la façon d'exporter des contacts dans Windows.

Après avoir créé le fichier (format .csv), vous pouvez importer vos contacts à l'aide de l'assistant d'importation :

  1. Dans Thunderbird, allez à Outils > Importer…
  2. Choisissez Carnet d'adresses et cliquez sur Suivant
  3. Choisissez Fichier texte (LDIF, .tab, .csv, .txt) et cliquez sur Suivant
  4. Choisissez Séparé par des virgules(*.csv) (ou Tous les fichiers(*.*) dans la liste déroulante en bas à droite, accédez au fichier .csv que vous venez de créer, sélectionnez-le et cliquez sur Ouvrir.
  5. Attendez que l'importation se termine et cliquez sur Terminer.

Dans la fenêtre Importer un carnet d'adresses qui apparaît, utilisez les boutons Monter et Descendre pour faire correspondre les champs du carnet d'adresses sur la gauche avec les données correctes pour l'importation sur la droite, et décocher les éléments que vous ne voulez pas importer. Lorsque vous avez terminé, cliquez sur OK. Vos contacts doivent maintenant être importés et prêt à l'emploi dans Thunderbird.

Notez que si vous rencontrez des problèmes pour importer correctement les champs (comme lorsque toutes les données d'enregistrement à importer s'affichent dans la première ligne de champ à l'intérieur de la fenêtre Importer le carnet d'adresses), il s'agit probablement d'un fichier .csv exporté contenant des points-virgules au lieu de virgules, ou l'inverse. Dans ce cas, vous devez modifier le fichier .csv déjà exporté à l'aide d'un éditeur de texte et remplacer tous les points-virgules par des virgules avant d'importer avec Thunderbird.

Importation depuis Outlook et Eudora

Le processus normal d'importation de Thunderbird nécessite que vous ayez Eudora ou Outlook installé sur votre ordinateur. Si vous ne les avez pas installés, il existe des alternatives comme indiqué ci-dessous.

Pour utiliser l'assistant d'importation de Thunderbird, vous devez utiliser une version antérieure de Thunderbird, car l'assistant est désactivé pour Outlook et Eudora dans Thunderbird version 38 et les versions plus récentes. Installez la version 31.8, importez vos données, puis mettez à niveau vers la dernière version de Thunderbird via le processus de mise à jour.

Pour Eudora, si vous avez des problèmes de données ou des incidents, essayez une version plus ancienne de Thunderbird et un outil pour nettoyer les données. Un exemple d'outil de nettoyage de données pour Mac OS est Eudora Mailbox Cleaner.

Une alternative à l'assistant d'importation de Thunderbird consiste à trouver un outil pour transformer vos données au format mbox (.mbx), puis à utiliser le module complémentaire Import Export Tools pour importer les fichiers mbox. Un autre outil de conversion mbox pour Eudora est Eudora Rescue.

Eudora n'est pas installé

Si Eudora n'est pas installé et que vous souhaitez utiliser l'assistant d'importation de Thunderbird, vous pouvez facilement changer le registre Windows pour pointer vers vos fichiers Eudora, puis exécuter l'assistant d'importation.

  • Créez un fichier .reg appelé eudora.reg contenant les lignes suivantes. Remplacez H:\\SCRATCH\\Eudoradata par l'emplacement de vos données Eudora. (Notez le double backslashes et la ligne vierge)

Fichier du Registre, ajuster l'emplacement du fichier si nécessaire

Éditeur du Registre Windows Version 5.00 [HKEY_CURRENT_USER\Software\Qualcomm\Eudora\CommandLine] "Current"="Tout ce que H:\\SCRATCH\\Eudoradata Anything"===

  • Dans une invite de commande Windows, exécutez "regedit/s eudora.reg".
  • Utilisez l'assistant d'importation de Thunderbird.

Passage d'Evolution à Thunderbird

Les instructions suivantes décrivent comment importer des messages et des contacts depuis Evolution.

Importation des messages d'Evolution

Thunderbird et Evolution utilisent le même format de fichier (appelé mbox) pour stocker vos mails, il n'est donc pas difficile de les importer manuellement.

  1. Ouvrez Nautilus.
  2. Ouvrez ~/.local/share/evolution/mail/local qui est l’emplacement où Evolution stocke vos messages.
  3. Copiez tout le fichier sans extension (comme Inbox, Outbox, ..) dans l'emplacement utilisé par Thunderbird pour stocker son courrier (quelque chose comme ~/.thunderbird/uk41lql0 .utilisateur par défaut/Mail/Local Folders, où vous devez adapter uk41lql0.utilisateur par défaut à votre propre installation).
  4. Lancez Thunderbird pour vérifier que tous vos messages ont été correctement importés.

Importation des contacts d'Evolution

  1. Ouvrez votre carnet d'adresses dans Evolution, faites un clic droit dessus et choisissez : Enregistrer comme vcard… pour l'exporter au format de fichier vCard.
  2. Dans Thunderbird, ouvrez le menu Outils > Importer…, sélectionnez Carnet d'adresses puis Fichier vCard (*.vcf) et sélectionnez votre fichier de contacts.

Passer d'applications de messagerie web à Thunderbird

Si vous utilisez une application web fournie par votre fournisseur d'accès à Internet (FAI) pour accéder à votre courrier électronique, vous avez seulement besoin de configurer vos informations de compte pour passer à Thunderbird. Consultez l'article Configurer un compte manuellement pour les instructions.

Une fois que vous avez configuré votre compte dans Thunderbird, vous devriez être en mesure d'accéder à tous vos messages (entrants et envoyés). Cependant, votre carnet d'adresses (contacts), les filtres de courrier et d'autres paramètres ne seront pas automatiquement transférés à Thunderbird.

Certaines applications de messagerie web vous permettent d'exporter des contacts sous forme de texte ou de formats séparés par des virgules. Consultez la documentation de votre FAI pour plus d'informations. Pour importer des contacts dans Thunderbird, sélectionnez Outils > Importer… et suivez les instructions à l'écran.

Voir aussi

// Ces formidables personnes ont aidé à écrire cet article :Goofy, Banban, Imen, J2m06, Cécile. Vous pouvez également aider — découvrez comment.

Cet article vous a-t-il été utile ? Veuillez patienter…

Devenir bénévole pour l’assistance de Mozilla