Les modules complémentaires qui causent des problèmes de stabilité ou de sécurité sont mis dans une liste de blocage

Les modules complémentaires (extensions, thèmes et plugins) qui violent les directives de Mozilla concernant les modules complémentaires (en) sont mis dans une « liste de blocage ».

Que fait la liste de blocage ?

Désactiver les modules complémentaires non sûrs

Firefox empêchera le module complémentaire non sûr de se charger et vous avertira avec le message suivant :

Firefox a déterminé que les modules complémentaires suivants sont connus pour causer des problèmes de stabilité ou de sécurité


Add-ons Blocklist Mac1

Pour empêcher ces modules complémentaires de s'exécuter, cliquez sur Redémarrer Firefox.

Empêcher les modules complémentaires non sûrs d'être installés

Quand vous essayez d'installer un module complémentaire non sûr qui est dans la liste de blocage, Firefox empêchera son installation et affichera le message :

Le module complémentaire {nom du module} a de grandes chances de causer des problèmes de stabilité et de sécurité et ne peut être installé.

Empêcher les plugins de s'exécuter automatiquement

Firefox peut empêcher un plugin de s'exécuter automatiquement (ce qui évite de nombreux problèmes). Quand Firefox bloque un plugin, vous verrez un message semblable à celui-ci :

plugin-vulnérable.png

Vous pouvez alors choisir d'exécuter le plugin ou de le mettre à jour (si une mise à jour est disponible). Pour en savoir plus, consulter Pourquoi dois-je cliquer pour activer les plugins ?

Mesures à prendre

Si le module complémentaire installé est désactivé

Extension ou thème

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, puis sélectionnez Modules complémentairesSur la barre de menus, cliquez sur le menu Outils, puis sélectionnez Modules complémentairesEn haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez Modules complémentaires. Le gestionnaire des modules complémentaires s'ouvre.
  2. Sur le menu « Outils pour tous les modules complémentaires » Add-on Tools Icon , assurez-vous que l'élément de menu Mettre à jour les modules automatiquement est coché.

Plugin

Pour vérifier si chacun de vos plugins installés est à jour, visitez la page de vérification des plugins de Mozilla.

Note : S'il n'y a pas de mises à jour disponibles, vous aurez peut-être besoin de contacter le développeur du plugin qui a été bloqué.

Installation bloquée

Si vous êtes empêché d'installer un module complémentaire, vérifiez s'il y a une version à jour du module complémentaire que vous avez essayé d'installer.

Note : S'il n'y a pas de version à jour à installer, vous aurez peut-être besoin de contacter le développeur du module complémentaire qui a été bloqué.

Quels modules complémentaires non sûrs sont dans la liste de blocage ?

Consultez la liste de blocage des modules complémentaires.



Partager cet article : http://mzl.la/PSKXSM

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, Mozinet, irahal, nicodel. Vous pouvez également aider - découvrez comment.