Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox show images I upload different than they are??

  • 4 vastausta
  • 1 henkilöllä on sama ongelma
  • 2511 näyttöä
  • Viimeisin kirjoittaja Enrique_Agustini

more options

Every image I upload looks different in Firefox than the file opened in other programs and different than Google Chrome. It looks with less contrast for sure, and I think a little bit reddish. I noted it when I opened the file with Firefox and when I saw pictures in Facebook. My Firefox version is 47.0, my OS is Ubuntu 16.04 and I already tried in Firefox safe mode.

Valittu ratkaisu

By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx.c and pause while the list is filtered

gfx.color_management.mode - governs application of color management to images

0 = off 1 = on for ALL images 2 = on for TAGGED images (default)

I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.

I think the following are only relevant if you have profiled your monitor (e.g., pro photographer).

gfx.color_management.display_profile - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here.

gfx.color_management.enablev4 - double-click to toggle to true if your custom monitor profile is an ICC v4 profile

gfx.color_management.rendering_intent - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual

For details, see: https://developer.mozilla.org/Firefox/Releases/3.5/ICC_color_correction_in_Firefox

Can you find a combination of settings that gives you the colors you expect?

Lue tämä vastaus kontekstissaan 👍 0

Kaikki vastaukset (4)

more options

Valittu ratkaisu

By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx.c and pause while the list is filtered

gfx.color_management.mode - governs application of color management to images

0 = off 1 = on for ALL images 2 = on for TAGGED images (default)

I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.

I think the following are only relevant if you have profiled your monitor (e.g., pro photographer).

gfx.color_management.display_profile - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here.

gfx.color_management.enablev4 - double-click to toggle to true if your custom monitor profile is an ICC v4 profile

gfx.color_management.rendering_intent - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual

For details, see: https://developer.mozilla.org/Firefox/Releases/3.5/ICC_color_correction_in_Firefox

Can you find a combination of settings that gives you the colors you expect?

more options

gfx.color_management.mode = 0

was the solution for me, thanks jscher2000. Firefox should turn off this option by default til properly implemented.

more options

You can search for bugs related to color management or file a new one here:

https://bugzilla.mozilla.org/

more options

This could relate to a confirmed bug in Ubuntu's ICC profile management:

https://bugs.launchpad.net/ubuntu/+source/eog/+bug/938751?comments=all

I found out that in Windows this issue doesn't occur. Looks like a guilt chain, first I thought it was Facebook, then I thought it was Firefox but it looks like it all is because of Ubuntu. :-D