Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Etsi tuesta

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autofill works for forms with autocomplete="off"

  • 2 vastausta
  • 2 henkilöllä on sama ongelma
  • 15 näyttöä
  • Viimeisin kirjoittaja Nauraushaun

more options

From what I can grasp here: https://developer.mozilla.org/en-US/Firefox/Releases/30/Site_Compatibility#Security

If a field or form has autocomplete="off" set, the password manager should prompt the user to save the password, but the password can not be auto-filled into the field. This is not what I'm experiencing. I have a simple form with email and password field. Both the form itself and the fields have autocomplete="off", but Firefox 30 will still let me store the details and auto-fill them.

I cannot allow this, as it breaks Angular JS's binding causing things to not work.

From what I can grasp here: https://developer.mozilla.org/en-US/Firefox/Releases/30/Site_Compatibility#Security If a field or form has autocomplete="off" set, the password manager should prompt the user to save the password, but the password can not be auto-filled into the field. This is not what I'm experiencing. I have a simple form with email and password field. Both the form itself and the fields have autocomplete="off", but Firefox 30 will still let me store the details and auto-fill them. I cannot allow this, as it breaks Angular JS's binding causing things to not work.

Kaikki vastaukset (2)

more options

You can try to set the signon.autofillForms pref to false on the about:config page.

Note that the signon.overrideAutocomplete pref controls the behavior with autocomplete=off

You can open the about:config page via the location/address bar and you can accept the warning and click "I'll be careful" to continue.

more options

Ah, sorry. Yes that would solve the problem for me. But I'm building a website and need to fix it for all users.