Java, Silverlight, Adobe Acrobat ja muut laajennukset eivät enää toimi

Alkaen Firefoxin versiosta 52, joka julkaistiin 7. maaliskuuta 2017, asennettuja NPAPI liitännäisiä ei enää tueta Firefoxissa Adobe Flashia lukuunottamatta. Joitakin näistä asennetuista liitännäisistä jotka eivät enää toimi ovat esimerkiksi Java, Microsoft Silverlight ja Adobe Acrobat. Tästä englanninkielisestä Firefox Site Compatibility dokumentista voit lukea lisätietoja.

Viimeisten vuosien aikana Firefox on ottanut käyttöön useita Web API-tekniikoita, jotta verkkosivustot voisivat toimia kuten ennenkin, ilman lisäosia, joten et todennäköisesti huomaa mitään muutoksia.

Syyt tähän muutokseen

Internet on täynnä verkkosivustoja, jotka käyttävät muutakin kuin staattisia verkkosivuja, sisältäen esimerkiksi videoita, ääntä ja pelejä. NPAPI-liitännäiset, etenkin Flash, ovat auttaneet näiden interaktiivisten sivujen ylläpitämisessä. Ne ovat kuitenkin tehneet selaamisesta hitaampaa, vähemmän turvallista ja alttiimpia kaatumiselle.

Viimeisten vuosien aikana Firefox on työskennellyt uutterasti rakentaakseen korvaavia ratkaisuja näille liitännäisille. Yhdessä näistä käytetään nimitystä Web API. Ne on suunniteltu korvaaman liitännäisten toiminnallisuutta ilman verkkoturvallisuuden, ohjelmien vakauden ja suorituskyvyn vaarantamista.

Aikaisemmin nämä Web APIt eivät olleet aivan valmiita, joten Firefox aloitti muutoksen siten, että nämä liitännäiset käynnistettiin napsauttamalla.

Nykyään ne ovat jo valmiita. Useat sivustot ovat ottaneet ne käyttöön ja useimpia suosittuja sivustoja pystyy jo käyttämään ilman turvattomia liitännäisiä. Firefox on liittynyt muiden nykyaikaisten selaimien - kuten Google Chrome ja Microsoft Edge - rintamaan lopettaessaan tukensa NPAPI-liitännäisille.

// Nämä mahtavat henkilöt auttoivat kirjoittamaan tämän artikkelin:Jarmo. Sinäkin voit auttaa.

Oliko tästä artikkelista apua? Odota hetki...

Ilmoittaudu avustajaksi