Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Turning off location sharing

more options

How can I stop Firefox from asking me whether to share my location every time I visit a new page, after I've repeatedly answered Never Share My Location? I did the whole ABOUT:CONFIG thing and clicked on false for geo-location. After that, I tried to check the weather on the Weather Channel Website and the website won't show me anything except a partially loaded website. No weather! I went back to ABOUT:CONFIG and changed geo-location back to true and the Weather Channel website loaded correctly, but asked me whether I wanted to share my location, yet again! This is so frustrating!! Any other suggestions would be appreciated!

Chosen solution

Firefox should store individual site permissions (allow/block) indefinitely, you shouldn't have to re-enter them.

There may be problem storing site permissions if you are using a private window. However, I haven't experimented with this particular one.

If you have Firefox set to Clear history when Firefox closes, make sure not to clear the "Site Preferences" category to avoid losing your permission decisions. You can check that on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Privacy. On the right side, if the selector is set to "Firefox will: remember history", change that to "Firefox will: use custom settings for history" to double-check on this setting.

If there is a checkmark next to "Clear history when Firefox closes" click the settings button over to the right to review the categories Firefox is set to clear. Make sure anything you want to carry over is NOT checked, especially Site Preferences.

Does any of that help?

Read this answer in context 👍 7

All Replies (2)

more options

Chosen Solution

Firefox should store individual site permissions (allow/block) indefinitely, you shouldn't have to re-enter them.

There may be problem storing site permissions if you are using a private window. However, I haven't experimented with this particular one.

If you have Firefox set to Clear history when Firefox closes, make sure not to clear the "Site Preferences" category to avoid losing your permission decisions. You can check that on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Privacy. On the right side, if the selector is set to "Firefox will: remember history", change that to "Firefox will: use custom settings for history" to double-check on this setting.

If there is a checkmark next to "Clear history when Firefox closes" click the settings button over to the right to review the categories Firefox is set to clear. Make sure anything you want to carry over is NOT checked, especially Site Preferences.

Does any of that help?

more options

Thanks! Problem solved :)