Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

no recently closed tabs or windows option on history menu

more options

recently closed tabs and windows options are greyed out on history dropdown menu. I've set the preferences to not having private browsing history, and still can't get the history to display these options in black

recently closed tabs and windows options are greyed out on history dropdown menu. I've set the preferences to not having private browsing history, and still can't get the history to display these options in black

All Replies (9)

more options

Remember History

-> When you use Clear Recent History feature, make sure NOT to select Browsing and Download History.

-> IF you use Privacy Cleanup software like CCleaner, don't select Firefox in its Settings. These softwares might be responsible for clearing your Browsing History.

Check and tell if its working.

more options

I've never used a privacy cleanup program, but this is a used computer, and I can't tell if any of the applications on it include that kind of program. I don't use the Clear Recent History feature, not yet anyway. Thanks for the suggestions.

more options

Use this setting and see if it works in the coming days. Then reply back and tell if its working.

more options

I don't use the clear recent history feature. And mine doesn't list Firefox or anything but how far back to clear.

more options

-> click Firefox button and click Options -> Privacy -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> 4a) Accept Third-party Cookies -> Keep Until : select They Expire

-> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES

-> Click OK on Options window -> Restart Firefox

Just use this setting and see if it starts Remembering your History. Then reply back some time later (1-2 days if you want to test it) and tell if its working.

Muudetud Hasan poolt

more options

Make sure that you use Firefox > Quit Firefox to close the Firefox application and all open tabs and not close a window.
If you close a window and the Firefox menu bar is still visible then you can't restore tabs.

more options

I had already done those things to my history settings. My history is remembered; I just want to be able always to use the "restore previous session" and "recently closed tabs" and "recently closed windows" options on the history drop down menu. I currently don't get all three of those options at the same time. Firefox always greys out one, two or three of those options. I think it's a glitch, error in Firefox 5. Because of this and because Firefox sometimes subtracts the navigation bar and disables or subtracts the Apple/Firefox/File etc. bar, I tried to get Firefox Mozilla 4 or 3, but all previous versions of Mozilla have been wiped from all the websites I tried.

more options

Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

I tried to follow the directions in "Managing profiles" but when I opened Terminal, a window with this content appeared:

Last login: Tue Aug 9 16:45:37 on console MacBook-Pros-MacBook-Pro-4:~ macbookpro$

Right clicking brought up the Inspector and a search function which didn't work. Neither led to Profile Manager window. There was nothing else I could do with Terminal.

The second article is for Windows.