Search Support

Αυτό το νήμα έκλεισε και αρχειοθετήθηκε. Παρακαλούμε κάντε νέα ερώτηση αν χρειάζεστε βοήθεια.

Disable pop-up "add yahoo! (us-mg5.mail.yahoo.com) as an application for mailto links"

  • 11 απαντήσεις
  • 22 έχουν αυτό το πρόβλημα
  • 2872 προβολές
  • Τελευταία απάντηση από Moses

more options

How can I permanently block the Yahoo Mail website from making this message pop up below the address bar?

add yahoo! (us-mg5.mail.yahoo.com) as an application for mailto links

Do not suggest using NoScript because that will disable Yahoo Mail and most other websites entirely. - unless NoScript has a way to block this message while allowing everything else.

Τροποποιήθηκε στις από το χρήστη arminius1

All Replies (11)

more options

Simply click the Add Application button. All it does is add "Yahoo!" as an option under Options - Applications - mailto. It doesn't affect you in any way. Detailed explanation:

If for some reason you still want to hide these notifications without adding Yahoo as a handler for mailto links,

The easy way

  1. Install Stylish and restart Firefox when prompted.
  2. Open the Add-ons Manager (Ctrl+Shift+A), then the User Styles category.
  3. Click the Write New Style button at the top. Paste the following in the text box, give the style a name, then click the Save button.

    @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
    /*
    Title: Yahoo! Mail - hide "add as an application for mailto links" notification
    Author: http://forums.mozillazine.org/memberlist.php?mode=viewprofile&u=261941
    Tested on: Firefox 28, Firefox 31
    */

    notification[label^="Add Yahoo!"][value="Protocol Registration: mailto"] {
      display: none !important;
    }

The hard way
If you don't want to install Stylish, you can put the style in the userChrome.css file instead. Make sure the first line of the style only appears once in that file.

Edit: I filed a bug report. If anyone here has the privileges to mark it NEW, please do so. There's already an identical one for Firefox OS that's ASSIGNED, so I think it's perfectly reasonable.

Τροποποιήθηκε στις από το χρήστη Gingerbread Man

more options

So you have to install an application to stop an application pestering you, how stupid is that, there ought to be a BAN list where we can list sites that are not allowed to make such requests.

I wonder what changes when this app from Yahoo is installed?

Is there a string that we can put in that makes it think it is installed so it does not annoy and pester over and over and over and over and over again.

more options

FedUpWithFirefox wrote:

So you have to install an application to stop an application pestering you

No, you don't. Just click the Add Application button when prompted.

Even if you want to hide the notification bar — I really can't stress enough that there's absolutely no reason to ignore it — you can use the userChrome.css file if you don't want to install the Stylish add-on.

FedUpWithFirefox wrote:

I wonder what changes when this app from Yahoo is installed?

Like I said,
Gingerbread Man wrote:

All it does is add "Yahoo!" as an option under Options - Applications - mailto. It doesn't affect you in any way. 

I'll add that it also sets that to "Always ask", in case it wasn't already set to that.

So what that means is, when you come across a link like this one,

mailto:user@example.com

Firefox will ask you if you want to launch it in Gmail, Yahoo!, or in your local mail client (Outlook or Thunderbird, etc.). You can select what you want to do, check the "Remember my choice" box, click OK, and then you never see that dialog or the notification bar again.

more options

Thanks for the lesson but what I and the OP wanted was a way to disable this, not a justification nor a dismissal.

What I object to is Yahoo kicking this off without my permission and Firefox allowing them to do it.

Yahoo should have an option in the user account and Firefox should not have this open door.

Oh no it is just for email...

NO, I do not want that behaviour, I already always want my local client I do not want a bloody barrier each and every time I click on a mailto link.

AND we know that we will soon need firefox Ver 433 a fix of the vulnerability when websites decided they could hack this.

I just want it to stop and the programmer that wrote it shot, OK perhaps a bit harsh, fire him or his boss.

more options

I added it because I assumed Firefox detected that I had deleted the built-in mailto for Yahoo. However, this new application is server specific. Since it's possible a user will be switched among Yahoo's many, many servers, it seems a bit dysfunctional for them to be asking us to create server-specific handlers instead of relying on Firefox's built-in one, which uses Yahoo's redirector. This may end up annoying many of their users.

Anyway...

There probably will be sites where you want this infobar to appear so you CAN install what they have to offer. To allow for that, you probably do not want to disable all sites from showing it. And for that reason, hiding it just on Yahoo! seems like the best option, and a Stylish rule is the most convenient way to do that. (Or a rule in userChrome.css.)

See also:

If, on the other hand, you do not want any site to be able to use the navigator.registerProtocolHandler() method, you probably would need an extension or perhaps a userscript to override it.

more options

Hi FedUpWithFirefox, you wrote:

Oh no it is just for email...

NO, I do not want that behaviour, I already always want my local client I do not want a bloody barrier each and every time I click on a mailto link.

If you check the box to remember your preferred mail client, or select it in Options > Applications > mailto, then there is no additional barrier. That dialog only appears the first time after adding a new mailto handler.

more options

Maybe it's a UI problem.

The prompt is ambiguous about exactly what will happen if you click the button.

You aren't being asked to install a new application, you are being asked to add an external application to a list of handlers for a particular protocol (in this case mailto:).

Would that make anyone feel more confident in dealing with the prompt?

more options

I filed a bug report. If anyone here has the privileges to mark it NEW, please do so. There's already an identical one for Firefox OS that's ASSIGNED, so I think it's perfectly reasonable.

jscher2000 wrote:

it seems a bit dysfunctional for them to be asking us to create server-specific handlers instead of relying on Firefox's built-in one, which uses Yahoo's redirector.

The built-in one doesn't work properly. I guess that was the reason for this. Though why they didn't fix that one instead of adding a new handler is anyone's guess.

Τροποποιήθηκε στις από το χρήστη Gingerbread Man

more options

Gingerbread Man

You should be a politician, I mean do you not have ANY listening skills or do you work for Yahoo?

In your bug report you suggest that we are all bloody morons and do not understand the problem, then you do the ONE thing that NONE of us want, you suggest that it is added without our authority for Yahoo.

So let me make it clear

WE DO NOT WANT IT

WE WANT AN OPTION TO STOP IT ASKING

WE WANT THAT OPTION TO PREVENT ALL SUCH REQUESTS

WE WANT THAT OPTION TO BE RESPECTED FOREVER

WE WANT THAT OPTION TO BE A TICK BOX NOT CODING

Is that clearer now?

more options

I've been more than gracious and patient,

  1. By explaining the situation at length.
    • There's already a "Yahoo! Mail" option under Options/Preferences - Applications - mailto built into Firefox. No reason to get upset about adding another one that works properly. You don't have to use either one.
  2. By providing a workaround.
    • You can hide the message with the user style I posted, either with the Stylish add-on or with the userChrome.css file (i.e. without installing an add-on).
  3. By filing a bug report to request a "Don't Ask Again" option so you can avoid adding a site as a protocol handler and never get prompted again.

Why that is deserving of insults and belligerence, I'll never know. I won't be reading any further replies in this thread.

more options

FedUpWithFirefox,

Thought there was a moderator in this thread....
It's obvious Gingerbread Man has gone to great lengths to assist you. Furthermore, this isn't even your thread so technically, he shouldn't even be helping you since this is arminius1's thread and we haven't heard back from him at all since you decided to hijack this thread. Also, we are NOT Firefox developers so we don't even have the power to add this as we aren't associated with the Mozilla Corporation/Foundation in any way. We're volunteers, so the time and attention you've received from Gingerbread Man and jscher2000 have been outstanding!

Also, since you refuse to listen to Gingerbread's repeated explanations about this issue, I'll be closing it. Please feel free to open up a new thread for your issue if need be at /questions/new. There's also been a bug filed if you even care to look at that.

arminius1,
If you still have this issue, please PM me and I'll unlock it.

Τροποποιήθηκε στις από το χρήστη Moses