Αναζήτηση υποστήριξης

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox displays my web site wrong; other browsers work fine.

  • 8 απαντήσεις
  • 9 έχουν αυτό το πρόβλημα
  • 756 προβολές
  • Τελευταία απάντηση από treefree

more options

I recently purchased a new computer, and now my website (www.tree.org) shows in italics! It is probably not the fault of the computer (ASUS 1215B), because the problem only appears on Firefox. I upgraded to the latest version (6.0),and it still shows in italics. In Google Chrome the pages display correctly. However, my desktop computer, running the same versions of Firefox, displays correctly. I thought my font file might be corrupted (Goudy Old Style), so I copied a known good font source (from my other computer that displays correctly) -- no change. I have tried clearing cache.

  All I can figure out is that there is something between the ASUS processing and Firefox that is causing this.  I have written also to ASUS, but this problem baffles me.  Any ideas?

Επιλεγμένη λύση

"... my page is prepared correctly ..."
Based upon what gauge or standard of correctness?
http://validator.w3.org/check?uri=http://www.tree.org/

Have you considered fixing that web page so that web browsers would display it on the standards compliant mode, rather than the quirks mode which forces the browser to guess how you want that page to be displayed?

http://en.wikipedia.org/wiki/Quirks_Mode

Firefox 4+ version are less tolerant of non-compliant code than earlier versions were.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (8)

more options

No problem here with italic fonts in Firefox 6.0.1 in WinXP SP3 - ASUS M2V-MX SE motherboard

more options

That's right -- my page is prepared correctly, and displays properly everywhere else, including my desktop computer. But with my new ASUS 1215B, it displays every word in italics. It does this from the web, and it does the same thing when I open the page from the copy on my own desktop. For some reason, it only seems to happen when I use my new computer with Firefox. It was happening with firefox 4 (I didn't upgrade because none of my add-ins would work), and it happens now that I finally upgraded again to version 6.0. Only on the new computer. And other browsers display just fine. It must be a browser problem, and something has gotten screwed up -- but why would the problem persist after upgrading to the new version?? I can't imagine how anything in the new computer might make that happen.

more options

Επιλεγμένη λύση

"... my page is prepared correctly ..."
Based upon what gauge or standard of correctness?
http://validator.w3.org/check?uri=http://www.tree.org/

Have you considered fixing that web page so that web browsers would display it on the standards compliant mode, rather than the quirks mode which forces the browser to guess how you want that page to be displayed?

http://en.wikipedia.org/wiki/Quirks_Mode

Firefox 4+ version are less tolerant of non-compliant code than earlier versions were.

more options

Thank you -- that looks like useful advice.

more options

There may be a problem with the specified "Goudy Old Style" font.

Do you have that font installed?

Does it help if you disable website fonts?

  • Tools > Options > Content : Fonts & Colors > Advanced : [x] "Allow pages to choose their own fonts, instead of my selections above"
more options

the font is installed and I have checked "allow pages to choose..."

more options

Is that font working properly?

more options

Thank you! The report shows my Goudy Old Style in Italics! The funny thing is that I already tried that -- first, I checked that everything displays correctly on my desktop computer, then I copied the font file and copied it onto my new computer. I will try that again, only first I will uninstall the GOS before installing my new font file, and see if that helps.