X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Your Firefox profile cannot be loaded. It may be missing or inaccessible.

Posted

Why is Firefox so unstable? It used to be great, now it's just a headache. I often get an issue where Firefox will not close normally and I have to do a force quit. This morning, my computer did a software update to and now I get the following message: "Your Firefox profile cannot be loaded. It may be missing or inaccessible." The browser is completely non-functional. I cannot get to my bookmarks or any other part of the browser. I tried to go back to just using Safari or another browser but Safari will not let me import my bookmarks from Firefox. How can I get Firefox to work properly, or recover my bookmarks so I can use them in a browser that will actually work without all of these glitches? I tried to download Firefox again and reinstall with no luck. Thank you.

Additional System Details

This happened

Not sure how often

This started when...

Today

Installed Plug-ins

Not sure? Can't access Firefox to look it up.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3

More Information

I cannot access :Help > Troubleshooting Information. When I open Firefox the browser gives he pop-up immediately and then I cannot access anything else in the menus.

Hasan 477 solutions 5600 answers

tglavas: If youre on a Mac with this problem, try:

"/Applications/Firefox.app/Contents/MacOS/firefox-bin -profile /tmp/newdir"

This worked for me. As found in https://bugzilla.mozilla.org/show_bug.cgi?id=581182

And after several months, I can now use firefox.

Taken from: https://support.mozilla.com/en-US/questions/831625#answer-197725

zensa: I found this information from some other site and this command fix the firefox after time machine restore for me. Run this command in terminal from your home directory

sudo chown -R `id -un`:`id -gn` ~

Taken from: https://support.mozilla.com/en-US/questions/785562

Check and tell if its working.

tara52 0 solutions 1 answers

Where do I go to enter

/Applications/Firefox.app/Contents/MacOS/firefox-bin -profile /tmp/newdir

on my Mac. I tried finding Applications Utilities Terminal. Also tried About this Mac - More Info where I can see firefox but can't type. "Run this command in terminal from your home directory". Where is the home directory located?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96771 answers

See Profile Manager:

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Bidli 0 solutions 1 answers

I have had the same problem with Mac users who have a network account on a Mac OS X server. I've found the solution at bynkii.com: The users had an invalid alias named "Caches" in their ~/Library folder instead of a Caches folder.

Replacing the alias with a real Caches folder has fixed the problem.

Modified by Bidli