Avatar for Username

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Cannot enter Cox E-mail on Firefox, can with Google Chrome

  • 6 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 1 προβολή
  • Τελευταία απάντηση από cussboy

more options

Today, I cannot open Cox E-mail using Firefox, but I can with Google Chrome (which I pretty much never use). See the error message below, can someone help? I have a Dell E6520 laptop running Window 7. Thanks.

Today, I cannot open Cox E-mail using Firefox, but I can with Google Chrome (which I pretty much never use). See the error message below, can someone help? I have a Dell E6520 laptop running Window 7. Thanks.
Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

"Did you contact COX as to why it's not accepting Firefox Browser login? This seems more like a site issue then a Browser." Yes, spoke to a real live agent; she had me clear cache and cookies, gave me Dell laptop support number, like it was Dell's fault, ridiculous.

"Also if did you try Firefox Private Mode Browser to verify this isn't a Addon issue." That's way over my head, never heard of that.

But I fixed it myself, apparently wiser than a Cox agent. Somehow - swear I didn't touch it - the URL for the Bookmark in FireFox for my Cox account had changed to "cox.net" (which isn't a real URL) where it should have been "https://www.cox.com/residential/home.html" So I edited that Bookmark, that fixed it. None of my other Bookmarks had changed.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (6)

more options

Did you contact COX as to why it's not accepting Firefox Browser login? This seems more like a site issue then a Browser. Also if did you try Firefox Private Mode Browser to verify this isn't a Addon issue.

more options

Επιλεγμένη λύση

"Did you contact COX as to why it's not accepting Firefox Browser login? This seems more like a site issue then a Browser." Yes, spoke to a real live agent; she had me clear cache and cookies, gave me Dell laptop support number, like it was Dell's fault, ridiculous.

"Also if did you try Firefox Private Mode Browser to verify this isn't a Addon issue." That's way over my head, never heard of that.

But I fixed it myself, apparently wiser than a Cox agent. Somehow - swear I didn't touch it - the URL for the Bookmark in FireFox for my Cox account had changed to "cox.net" (which isn't a real URL) where it should have been "https://www.cox.com/residential/home.html" So I edited that Bookmark, that fixed it. None of my other Bookmarks had changed.

Τροποποιήθηκε στις από το χρήστη cussboy

more options

The article linked below may help. The certificate relates to the wrong name. Are you using DNS over HTTPS? That may help.

https://support.mozilla.org/en-US/kb/secure-connection-failed-firefox-did-not-connect

more options

" Are you using DNS over HTTPS?"

Well, since I've never heard of DNS, I would doubt that I would be using that. I do know HTTPS is some kind of security thing.

Did you even read my reply posted above at 7:26pm, your response was almost an hour later: I fixed it myself, apparently wiser than a Cox agent. Somehow - swear I didn't touch it - the URL for the Bookmark in FireFox for my Cox account had changed to "cox.net" (which isn't a real URL) where it should have been "https://www.cox.com/residential/home.html" So I edited that Bookmark, that fixed it. None of my other Bookmarks had changed.

more options

If you are unable to access your Cox email on Firefox but can do so on Google Chrome, it may be related to browser settings or extensions. Here are some steps you can take to troubleshoot the issue:

Clear Browser Cache: Clearing the cache can resolve many browsing issues. In Firefox, go to "Menu" (three horizontal lines) > "Library" > "History" > "Clear Recent History." Select the time range to clear, and make sure to check "Cache" in the list of items to clear. Then click "Clear Now."

Disable Browser Extensions: Some browser extensions can interfere with website functionality. Try disabling any extensions you have installed in Firefox and see if that resolves the issue. You can do this by going to "Menu" > "Add-ons" > "Extensions," and then click the toggle button to disable each extension.

more options

Terry and Jimmy.wick90 might know computers, but they need to learn to read better. TWICE previously I posted in this thread that I had fixed the issue, was a corrupt/changed URL in the Cox E-mail Bookmark on FireFox. All other Bookmarks were OK.

So FIXED !!!