X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

Bookmarks bar above URL bar when I open FireFox

Δημοσιεύτηκε

For awhile now, every time I open FireFox, the menu icon bar and bookmarks bar have switched positions so that the menu icon bar is immediately above the tabs, and the bookmarks bar is above that, instead of the other way around (see screenshot). If I open customize, and then close it, without changing anything, they switch places and go back to where they should be (bookmarks bar above the tabs, menu icon bar above that), but it's annoying to have to do this every time I use FF. I only have one extension related to menu bars, Tabs on Bottom, and I deactivated it and rebooted FireFox, but that didn't solve the problem. I also tried changing themes, to no avail. Is this a bug or is there some setting I can change?

Other stuff that may or may not be relevant: I have the awesome bar, URL bar, and all of my menu icons (sans text) on one line. I have the text menu bar also visible. I'm running Windows 7 Ultimate, 1152x864 res with text at 125%. I always have at least a couple of tabs pinned.

On another computer I use (Windows 7 Home Premium, 1366x768 res, 100% text, also always have something pinned), I do not have this problem. However, on that computer, there is empty vertical space between the tabs bar and the bookmarks bar, as if another bar should be there (see second screenshot). I realize these may be two separate issues, but then again, they both seem to suggest an overflow issue, so maybe not.

For awhile now, every time I open FireFox, the menu icon bar and bookmarks bar have switched positions so that the menu icon bar is immediately above the tabs, and the bookmarks bar is above that, instead of the other way around (see screenshot). If I open customize, and then close it, without changing anything, they switch places and go back to where they should be (bookmarks bar above the tabs, menu icon bar above that), but it's annoying to have to do this every time I use FF. I only have one extension related to menu bars, Tabs on Bottom, and I deactivated it and rebooted FireFox, but that didn't solve the problem. I also tried changing themes, to no avail. Is this a bug or is there some setting I can change? Other stuff that may or may not be relevant: I have the awesome bar, URL bar, and all of my menu icons (sans text) on one line. I have the text menu bar also visible. I'm running Windows 7 Ultimate, 1152x864 res with text at 125%. I always have at least a couple of tabs pinned. On another computer I use (Windows 7 Home Premium, 1366x768 res, 100% text, also always have something pinned), I do not have this problem. However, on that computer, there is empty vertical space between the tabs bar and the bookmarks bar, as if another bar should be there (see second screenshot). I realize these may be two separate issues, but then again, they both seem to suggest an overflow issue, so maybe not.
Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

That can happen when you move the tab bar from its default position at the top to the down position just above the website content. This doesn't seem to work properly. Usually the toolbars move back to the correct order if you open the customize window.

Try the userChrome.css solution I posted in this thread:

  • [/questions/1049464] Bookmarks toolbar POSITION resets to the very top after closing firefox
Ανάγνωση απάντησης σε πλαίσιο 1

Επιπρόσθετες λεπτομέρειες συστήματος

Εγκατεστημένα αρθρώματα

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Advanced web conferencing functionality.
  • Google Update
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

Περισσότερες πληροφορίες

cor-el
  • Top 10 Contributor
  • Moderator
17670 λύσεις 159854 απαντήσεις
Δημοσιεύτηκε

Επιλεγμένη λύση

That can happen when you move the tab bar from its default position at the top to the down position just above the website content. This doesn't seem to work properly. Usually the toolbars move back to the correct order if you open the customize window.

Try the userChrome.css solution I posted in this thread:

  • [/questions/1049464] Bookmarks toolbar POSITION resets to the very top after closing firefox
That can happen when you move the tab bar from its default position at the top to the down position just above the website content. This doesn't seem to work properly. Usually the toolbars move back to the correct order if you open the customize window. Try the userChrome.css solution I posted in this thread: *[[/questions/1049464]] Bookmarks toolbar POSITION resets to the very top after closing firefox
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Actually, I didn't need to mess with the css. Another poster in the thread you linked to pointed out that there are two tabs-on-bottom add-ons. I just switched to the other one, and it works fine. I posted in that thread, since it was already started. Thanks a lot for pointing me in the right direction!

Actually, I didn't need to mess with the css. Another poster in the thread you linked to pointed out that there are two tabs-on-bottom add-ons. I just switched to the other one, and it works fine. I posted in that thread, since it was already started. Thanks a lot for pointing me in the right direction!
john_w 0 λύσεις 1 απαντήσεις
Δημοσιεύτηκε

I didn't run into this issue until 40.0, when suddenly my bookmarks toolbar was above the address bar upon start up. If I clicked the customize button, the bookmarks bar would relocate under the address bar.

I tried the Australis tabs on bottom, but neither the tabs on bottom worked, nor did it solve the toolbar issue. Then I tried a complete reset. After reset, I re-installed the Australis tabs on bottom, re-installed no-script, set my theme, and all works well.

Except now, if I select private browsing mode in options, the tabs on bottom stops working.

I didn't run into this issue until 40.0, when suddenly my bookmarks toolbar was above the address bar upon start up. If I clicked the customize button, the bookmarks bar would relocate under the address bar. I tried the Australis tabs on bottom, but neither the tabs on bottom worked, nor did it solve the toolbar issue. Then I tried a complete reset. After reset, I re-installed the Australis tabs on bottom, re-installed no-script, set my theme, and all works well. Except now, if I select private browsing mode in options, the tabs on bottom stops working.

Τροποποιήθηκε στις από το χρήστη john_w