Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox 25.0 for x86-64 Linux no longer finds Flashplayer

  • 12 Antworten
  • 23 haben dieses Problem
  • 43 Aufrufe
  • Letzte Antwort von cor-el

more options

I had to update Firefox manually from 21.0 to 25.0, since it told me it was up to date. probably an issue with all versions being x86-64 Linux versions, and not i386 versions.

I also updated to the newest x86-64 Linux Flashplayer (V11.2.202.310 from 2013-08-20) and put the libflashplayer.so in its usual place on a Linux x86-64 system: /usr/lib64/mozilla/plugins/libflashplayer.so

But FFx and sites like youtube insist I have no flashplayer installed...

Addons/Plugins tells me I have no plugins of that kind installed. Youtube tells me "Flash player is required for video playback".

Where is the error? The user can access the file in /usr/lib64/mozilla/plugins/libflashplayer.so, and its the right version as well:

  1. file /usr/lib64/mozilla/plugins/libflashplayer.so

/usr/lib64/mozilla/plugins/libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

Ausgewählte Lösung

You can try to create a ~/.mozilla/plugins folder and copy the symlinks to the plugin to this folder see if that makes Firefox find and use them.

Diese Antwort im Kontext lesen 👍 3

Alle Antworten (12)

more options

This might have something to do with your previous issue with Firefox.


Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to soon.

more options

^Never like those instructions as they are most suited for Windows and not Mac and Linux especially. There is also no installer on Mac and Linux.


The issue may be due to you using 32-bit Firefox 25.0 instead of 64-bit Firefox 25.0. If using 32-bit Firefox you need 32-bit Plugins, not 64-bit.

The 64-bit Linux build of Firefox 25.0 can be found at http://download.cdn.mozilla.net/pub/mozilla.org/firefox/releases/25.0/linux-x86_64/ Just pick your language.

Mozilla only lists the 32-bit Linux releases on mozilla.org

Geändert am von James

more options

@james, I installed the 64 bit Verrsion... and also the 64 bit version of Flashplayer.

Strange enough, now I realized that *some* youtube videos first give me error message "no flashplayer installed", but then they load and play the clip... (Strange enough...) Still, some other clips not play and insist on the error...

@ComputerWhiz I don't want to lose all my Bookmarks and all of my (lots) installed plugins...

What would happen if I just exit FFX and delete all my extension files, that are currently: extensions.ini extensions.sqlite extensions.sqlite-journal


Then FFx should find all installed plugins, and create new extensions.* files, yes?

more options

Your Settings like Bookmarks and such are not in program folder but in a Profile in ~/.mozilla/firefox/

If Youtube is the only site you have tried with Flash and have issues, perhaps make sure you are not on the html5 trial. http://www.youtube.com/html5

more options

@James: That site tells me: "You are not currently in the HTML5 trial. "

Which other video sites are recommended for testing?

About the Settings in the program folder: I removed all of the program folder of the old FFx, and only use the new settings and files from the program folder. Aside from my plugins, which all (with the exception of the Flashplayer), are in ~/.mozilla/firefox/[random].default

more options

Does Firefox show the Flash plugin in Firefox/Tools > Add-ons > Plugins and on the about:plugins page?

See also:

more options

@cor-el FFx doesn't show the plugin in either Firefox/Tools > Add-ons > Plugins or on the about:plugins page. (Still, like I said, some youtube clips do play!)

https://developer.mozilla.org/en/Gecko_Plugin_API_Reference/Plug-in_Basics#How_Gecko_finds_plug-ins tells me /usr/lib64/mozilla/plugins is the right folder for x86-64 Linux systems, and just there is the flash player:

$ ls -l /usr/lib64/mozilla/plugins

-rw-rw-r-- 1 501 501 19233136 Aug 20 18:10 libflashplayer.so

Geändert am von Rava

more options

Are you sure that you start a 64 bit Firefox version and not a possible 32 bit Firefox version?

more options

Sorry for the late reply, have been busy, and since most youtube and other sites videos worked, I let it slide...

But now, after updating to newest FFx and Flash, not a single video won't work: Updated to newest Linux x86-64 FFx (26.0) and newest 64 Bit Flashplayer (11.2.202.332)

Firefox is 64 bit Linux, most recent: (from http://http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-x86_64/en-GB/firefox-26.0.tar.bz2) /usr/lib64/firefox$ file firefox firefox: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), BuildID[sha1]=0xa9cfeaccb5afff4b8c898f207b88414b71af0f52, stripped

Flashplayer is also x86-64 (v11.2.202.332): /usr/lib64/mozilla/plugins$ file libflashplayer.so libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped


Flashplayer lies in the folder it should be in on a 64 bit system, /usr/lib64/mozilla/plugins (instead of /usr/lib/mozilla/plugins on a 32 bit system)


Add-Ons manager / Plugins tells me "You don't have any add-ons of this type installed"

I deleted *all* my local settings but the extensions folder, and restarted firefox so he can set up brand new settings. he asked me that "an external program" wants to install all my add ons, and so all are installed again, the extenstions work fine, but still: no flash player...

I made a clean insall, removed the old (64 bit) version of Firefox, installed the new 64 bit version ( there is no 32 bit version on my system at all ) and only one 64 bit version of Flash... and removed all settings (but the extensions themselves) in my user's home folder.. but nope, no flash player...

The only thing that I can think of is that one of my extensions messes up FFX and disables it from finding the Flashplayer, but that would be a huuuge bug if it was the reason...

Any ideas?

more options

Ausgewählte Lösung

You can try to create a ~/.mozilla/plugins folder and copy the symlinks to the plugin to this folder see if that makes Firefox find and use them.

more options

cor-el, you are my hero! That did the trick!

But why did I find it nowhere in any documentation? It should be on every wiki page on that issue!

more options