X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Tab Utilities is incompatible with FF17. Many thousands of users are now without a much needed add-on. Is there a fix?

Veröffentlicht

This add-on is an important one to me and tens of thousands of others as well. Sadly this very useful add-on and functionality is now gone from my FF as of 17.. Many people are downgrading or refusing to upgrade solely because it will break this add-on.

In FF17 a major change was made to the function tosource's return value that broke not just this but many other add-ons as well. Now I don't have a problem with a change of standards and requiring everyone to update code to work with that. But this was handled in completely the wrong way by Mozilla IMO.

Where is the support to the add-on community that has loyally supported your product all these years and giving them a proper chance to migrate/change code to work with the new function return values? Why was there no schedule with a phase-in plan and a deadline for such changes?

Heck, a phase-in plan could have included a phase-in period where the function would support both methods by issuing an extra parameter for the new functionality. Then you could gradually switch the main return to be the new format. That way existing plugins would still be fine.

It seems a bit horrible from an end user standpoint suddenly not having this great tool that improves the firefox experience so much. I know many others feel that same way about this add-on as i've seen countless comments about it, and i'm sure many others feel that way about add-ons that they use that also are now broken too.

I'm writing here to ask either Mozilla to offer a fix, or the larger community to see if there is some workaround/middle ground that could be found. Perchance write a JS Function that could be included/injected into the broken add-ons that would convert/reformat the response of that function call so it remains usable to them with the data they need?

I really hope someone can come up with some temp solution for everyone until more permanent ones can be developed.

Thanks for reading..

This add-on is an important one to me and tens of thousands of others as well. Sadly this very useful add-on and functionality is now gone from my FF as of 17.. Many people are downgrading or refusing to upgrade solely because it will break this add-on. In FF17 a major change was made to the function tosource's return value that broke not just this but many other add-ons as well. Now I don't have a problem with a change of standards and requiring everyone to update code to work with that. But this was handled in completely the wrong way by Mozilla IMO. Where is the support to the add-on community that has loyally supported your product all these years and giving them a proper chance to migrate/change code to work with the new function return values? Why was there no schedule with a phase-in plan and a deadline for such changes? Heck, a phase-in plan could have included a phase-in period where the function would support both methods by issuing an extra parameter for the new functionality. Then you could gradually switch the main return to be the new format. That way existing plugins would still be fine. It seems a bit horrible from an end user standpoint suddenly not having this great tool that improves the firefox experience so much. I know many others feel that same way about this add-on as i've seen countless comments about it, and i'm sure many others feel that way about add-ons that they use that also are now broken too. I'm writing here to ask either Mozilla to offer a fix, or the larger community to see if there is some workaround/middle ground that could be found. Perchance write a JS Function that could be included/injected into the broken add-ons that would convert/reformat the response of that function call so it remains usable to them with the data they need? I really hope someone can come up with some temp solution for everyone until more permanent ones can be developed. Thanks for reading..

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 11.4 r402
  • Google Update
  • NPWLPG
  • Amazon MP3 Downloader Plugin 1.0.17
  • GEPlugin
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • 0.80.0
  • 0.70.0
  • Plugin for Wacom tablets.
  • Wacom Dynamic Link Library
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Windows Activation Technologies Plugin for Mozilla
  • Yahoo Application State Plugin version 1.0.0.7
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Office Plugin for Netscape Navigator

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

Weitere Informationen

the-edmeister
  • Top 25 Contributor
  • Moderator
5399 Lösungen 40167 Antworten
Veröffentlicht

A fix is going to have to come from the developer of Tab Utilities.

I have been around as Firefox user since the 0.3 release of Phoenix and have had many dozens of extensions get broken as a result of the Mozilla developers changing and improving Phoenix/Firebird/Firefox. Yes, it hurts when it happens, but that's the price of progress.

As far as that change being handled in the wrong manner, unfortunately Mozilla evidently doesn't care as they have been doing that for the last ten years. "Stuff" like this is one reason that add-on developers quit developing add-ons when major changes such as this come about. And it is one reason that users stop using Firefox, but considering that all the other browsers aren't anywhere as "extensible" as Firefox is, the user is "stuck" with learning to live with this situation of Mozilla breaking add-ons.

Any possibility that the "lite" version has most of the features which you have been using that extension for?
https://addons.mozilla.org/en-US/firefox/addon/tab-utilities-lite/

A fix is going to have to come from the developer of Tab Utilities. I have been around as Firefox user since the 0.3 release of Phoenix and have had many dozens of extensions get broken as a result of the Mozilla developers changing and improving Phoenix/Firebird/Firefox. Yes, it hurts when it happens, but that's the price of progress. As far as that change being handled in the wrong manner, unfortunately Mozilla evidently doesn't care as they have been doing that for the last ten years. "Stuff" like this is one reason that add-on developers quit developing add-ons when major changes such as this come about. And it is one reason that users stop using Firefox, but considering that all the other browsers aren't anywhere as "extensible" as Firefox is, the user is "stuck" with learning to live with this situation of Mozilla breaking add-ons. Any possibility that the '''"lite"''' version has most of the features which you have been using that extension for?<br /> https://addons.mozilla.org/en-US/firefox/addon/tab-utilities-lite/
ShanG 0 Lösungen 8 Antworten
Veröffentlicht

I'm also one of the many who have been adversely affected by the latest FF update. I only want my Tab Utilities to WORK so my workflow isn't FUBARED by the tabs opening at the end of a very long string.

Can this be fixed sooner rather than later? Please?

I'm also one of the many who have been adversely affected by the latest FF update. I only want my Tab Utilities to WORK so my workflow isn't FUBARED by the tabs opening at the end of a very long string. Can this be fixed sooner rather than later? Please?
cor-el
  • Top 10 Contributor
  • Moderator
17482 Lösungen 158011 Antworten
Veröffentlicht
See also: *http://forums.mozillazine.org/viewtopic.php?f=48&t=1702465&start=2205
Matt_G 365 Lösungen 1860 Antworten
Veröffentlicht

Ausgewählte Lösung

Looks like the author has posted an update: https://addons.mozilla.org/en-US/firefox/addon/tab-utilities/versions/?page=1#version-1.5pre1
ShanG 0 Lösungen 8 Antworten
Veröffentlicht

Hilfreiche Antwort

I'll wait until all the bugs are worked out of that one before I add it. Right now, I'm using the Chinese version someone posted about last week. It works very well.

I'll wait until all the bugs are worked out of that one before I add it. Right now, I'm using the Chinese version someone posted about last week. It works very well.
1kenthomas 0 Lösungen 3 Antworten
Veröffentlicht

New release still seems to have a problem opening new tabs in FF 17?

New release still seems to have a problem opening new tabs in FF 17?
1kenthomas 0 Lösungen 3 Antworten
Veröffentlicht

P.S. I've held at FF 16 to keep functionality.

P.S. I've held at FF 16 to keep functionality.
1kenthomas 0 Lösungen 3 Antworten
Veröffentlicht

Belay the above. 1.5.1 works fine in FF 17. Carry on.

Belay the above. 1.5.1 works fine in FF 17. Carry on.