X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Adobe flash keeps crashing I can't watch videos

Veröffentlicht

I tried everything. Deleting cookies. Un installing and re installing adobe flash. I tried the suggestions listed on the firefox site Adobe flash works fine when I open google chrome. Why does firefox suck? Its ridiculous... Its so bad...

I tried everything. Deleting cookies. Un installing and re installing adobe flash. I tried the suggestions listed on the firefox site Adobe flash works fine when I open google chrome. Why does firefox suck? Its ridiculous... Its so bad...

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

Weitere Informationen

AliceWyman
  • Moderator
240 Lösungen 2597 Antworten
Veröffentlicht

Tylerdowner, you said, This fix was not released for older versions of Flash (such as 10.3 or 11.2) but those versions are vulnerable to this security issue..

However, the reference link you posted, http://forums.adobe.com/message/4621126#4621126 8/14/2012 - Flash Player Security Update ... says this:

Flash Player 10.3.183.20 was not impacted by this security issue and was not updated.

'''Tylerdowner,''' you said, ''This fix was not released for older versions of Flash (such as 10.3 or 11.2) but those versions are vulnerable to this security issue.''. However, the reference link you posted, http://forums.adobe.com/message/4621126#4621126 ''8/14/2012 - Flash Player Security Update'' ... says this: '''Flash Player 10.3.183.20 was not impacted by this security issue and was not updated.'''
briggl 0 Lösungen 5 Antworten
Veröffentlicht

I am already using the latest flash update: 11.3.300.271.

So that is not the fix for this problem with firefox.

I am already using the latest flash update: 11.3.300.271. So that is not the fix for this problem with firefox.
Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 Lösungen 10733 Antworten
Veröffentlicht

briggl, have you disabled protected mode?

briggl, have you disabled protected mode?
briggl 0 Lösungen 5 Antworten
Veröffentlicht

I do not want to disable protected mode. I reiterate:

I WANT IT TO WORK THE WAY IT IS SUPPOSED TO WORK.

I do not want to disable protected mode. I reiterate: I WANT IT TO WORK THE WAY IT IS SUPPOSED TO WORK.
Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 Lösungen 10733 Antworten
Veröffentlicht

briggl, I understand. Unfortunately Flash's protected mode doesn't work properly, and until they fix it, there is nothing you can do except disable it.

briggl, I understand. Unfortunately Flash's protected mode doesn't work properly, and until they fix it, there is nothing you can do except disable it.
John99 971 Lösungen 13138 Antworten
Veröffentlicht

Note FlashPlayer 11.4 has now been released, it may resolve some of these issues, use /plugincheck to upgrade. You may then be able to use protected mode again as intended.

(If you have manually disabled protected mode you will need to re-enable it by editing mms.cfg file to remove line ProtectedMode=0 see http://kb.mozillazine.org/Flash#Flash_Player_11.3_Protected_Mode_-_Windows )

'''Note FlashPlayer 11.4 has now been released''', it may resolve some of these issues, use [/plugincheck] to upgrade. You may then be able to use protected mode again as intended. (If you have manually disabled protected mode you will need to re-enable it by editing ''mms.cfg '' file to remove line ''ProtectedMode=0'' see http://kb.mozillazine.org/Flash#Flash_Player_11.3_Protected_Mode_-_Windows )
AliceWyman
  • Moderator
240 Lösungen 2597 Antworten
Veröffentlicht

John99 wrote, (If you have manually disabled protected mode you will need to re-enable it by editing mms.cfg file to remove line ProtectedMode=0 see http://kb.mozillazine.org/Flash#Flash_Player_11.3_Protected_Mode_-_Windows ).

MozillaZine's KB is currently down but this is from the cached version of that article:


Starting in Flash Player 11.3, the Flash plugin used in current versions of Firefox and SeaMonkey runs in a Protected Mode in Windows Vista and above. Note that, when Flash is running in Protected Mode, you will see two "FlashPlayerPlugin_<version>.exe processes in Windows Task Manager (e.g., “FlashPlayerPlugin_11_300_257.exe”).

<snip>

Disabling Protected Mode in Flash 11.3

You can disable Protected Mode in Flash 11.3 by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in:

   (Windows 32bit) C:\Windows\System32\Macromed\Flash 
   (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. You can later re-enable protected mode by either restoring the backup or by editing the mms.cfg file to remove the ProtectedMode=0 line you added.


Adobe references:

John99 wrote, ''(If you have manually disabled protected mode you will need to re-enable it by editing mms.cfg file to remove line ProtectedMode=0 see http://kb.mozillazine.org/Flash#Flash_Player_11.3_Protected_Mode_-_Windows )''. MozillaZine's KB is currently down but this is from the [http://www.google.com/search?hl=en&ie=UTF-8&q=cache:http://kb.mozillazine.org/Flash cached version of that article]: ----- Starting in Flash Player 11.3, the Flash plugin used in current versions of Firefox and SeaMonkey runs in a [http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html Protected Mode] in Windows Vista and above. Note that, when Flash is running in Protected Mode, you will see two "FlashPlayerPlugin_<version>.exe processes in Windows Task Manager (e.g., “FlashPlayerPlugin_11_300_257.exe”). <snip> '''Disabling Protected Mode in Flash 11.3''' You can disable Protected Mode in Flash 11.3 by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in: (Windows 32bit) C:\Windows\System32\Macromed\Flash (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. '''You can later re-enable protected mode by either restoring the backup or by editing the mms.cfg file to remove the ProtectedMode=0 line you added.''' ----- Adobe references: *http://forums.adobe.com/message/4588765#4588765 *http://forums.adobe.com/thread/1018071?tstart=0

Geändert am von AliceWyman

AliceWyman
  • Moderator
240 Lösungen 2597 Antworten
Veröffentlicht

P.S. To upgrade Flash, see Flash Plugin - Keep it up to date and troubleshoot problems under Updating Flash.

Adobe's 8/21/2012 - Flash Player 11.4 Release Announcement has more information.

P.S. To upgrade Flash, see [[Flash Plugin - Keep it up to date and troubleshoot problems]] '''under Updating Flash'''. Adobe's [http://forums.adobe.com/message/4637119#4637119 8/21/2012 - Flash Player 11.4 Release Announcement] has more information.
cutmetal 0 Lösungen 23 Antworten
Veröffentlicht

I was having the same problem.... But I keep forgetting that when you upgrade firefox... or it updates automatically... you need to right click on the firefox start up icon, go into properties, click on the compatibilities tab, and put a check in the "Run This Program As An Administrator" box, then hit apply. Start Firefox, and it should work OK. Problem is...each time you upgrade firefox and/or I think Adobe flash... you need to make sure that box is checked. This is on Firefox 15.0.1 with Adobe Flash 11.4.402.278 all up to date, Windows 7 64bit. If Firefox has Adobe flash add-on, it needs to run in admin mode or it will crash.

I was having the same problem.... But I keep forgetting that when you upgrade firefox... or it updates automatically... you need to right click on the firefox start up icon, go into properties, click on the compatibilities tab, and put a check in the "Run This Program As An Administrator" box, then hit apply. Start Firefox, and it should work OK. Problem is...each time you upgrade firefox and/or I think Adobe flash... you need to make sure that box is checked. This is on Firefox 15.0.1 with Adobe Flash 11.4.402.278 all up to date, Windows 7 64bit. If Firefox has Adobe flash add-on, it needs to run in admin mode or it will crash.
jscher2000
  • Top 10 Contributor
8785 Lösungen 71851 Antworten
Veröffentlicht

Hi cutmetal, I haven't had to use "run as administrator" on either of my Win7 Pro x64 systems (1 desktop, 1 laptop). There may be some difference in how user permissions are configured at the Windows level. I don't know whether there is a support article on that anywhere, but it probably would be a good idea to have one.

Hi cutmetal, I haven't had to use "run as administrator" on either of my Win7 Pro x64 systems (1 desktop, 1 laptop). There may be some difference in how user permissions are configured at the Windows level. I don't know whether there is a support article on that anywhere, but it probably would be a good idea to have one.
AliceWyman
  • Moderator
240 Lösungen 2597 Antworten
Veröffentlicht

cutmetal,

Checking your username for previous posts (here) I see that you also posted the same information in a number of other threads today.

You don't normally need to check the "Run This Program As An Administrator" box in Firefox -> Properties -> Compatibility tab, to prevent crashes after updating Firefox or Flash. If you need help with this issue, you should ask a new question. You can use this link as a starting point: https://support.mozilla.org/questions/new

cutmetal, Checking your username for previous posts ([https://support.mozilla.org/en-US/search?answered_by=cutmetal&a=1&sortby=1&w=2 here]) I see that you also posted the same information in a number of other threads today. You don't normally need to check the "Run This Program As An Administrator" box in Firefox -> Properties -> Compatibility tab, to prevent crashes after updating Firefox or Flash. If you need help with this issue, you should ask a new question. You can use this link as a starting point: https://support.mozilla.org/questions/new

Geändert am von AliceWyman

alienalias28 0 Lösungen 1 Antworten
Veröffentlicht

Well, I have used and sworn by Firefox for more than 5 years and I am about to BAIL on this latest piece of crap they have released. SAME thing as everyone else. I can go to IE or Chrome and videos work flawlessly. Whereas with FF 90% of my videos, whether Youtube, or flash, or whatever, won't load, causing the page to freeze, my pages to load slowly, or similarly. This seems to have been going on MONTHS and I am sick and tired of having to keep a Chrome browser open simply to watch video's.

I am not going to deal with, "Uninstall this and reinstall... then try this... then try this..." Why in the heck would I possibly put myself through that when Chrome has the functionality to migrate all my bookmarks, of which I have hundreds, and not wanting to go through the pain in the butt that would be migrating those, THAT is all that has prevented me from switching thus far. I am about 2 millimeters from migrating to Chrome and deleting Firefox from my system altogether.

Firefox, you are only as good as your latest release, of which the current one SUCKS. You better have an autoupdate soon fixing the bugs, or myself and many others will be gone for good.

Well, I have used and sworn by Firefox for more than 5 years and I am about to BAIL on this latest piece of crap they have released. SAME thing as everyone else. I can go to IE or Chrome and videos work flawlessly. Whereas with FF 90% of my videos, whether Youtube, or flash, or whatever, won't load, causing the page to freeze, my pages to load slowly, or similarly. This seems to have been going on MONTHS and I am sick and tired of having to keep a Chrome browser open simply to watch video's. I am not going to deal with, "Uninstall this and reinstall... then try this... then try this..." Why in the heck would I possibly put myself through that when Chrome has the functionality to migrate all my bookmarks, of which I have hundreds, and not wanting to go through the pain in the butt that would be migrating those, THAT is all that has prevented me from switching thus far. I am about 2 millimeters from migrating to Chrome and deleting Firefox from my system altogether. Firefox, you are only as good as your latest release, of which the current one SUCKS. You better have an autoupdate soon fixing the bugs, or myself and many others will be gone for good.

Geändert am von alienalias28

jscher2000
  • Top 10 Contributor
8785 Lösungen 71851 Antworten
Veröffentlicht

Hi alienalias28, you wrote:

This seems to have been going on MONTHS and I am sick and tired of having to keep a Chrome browser open simply to watch video's.

Since the release of Flash 11.3 on June 8th, which added a unique protected mode feature for users of Windows Vista and Windows 7, there have been a lot of Flash problems in Firefox due to conflicts with certain add-ons and settings. Adobe has fixed many of these in Flash 11.4, but apparently some remain. Real Networks also has updated its add-ons to resolve issues those were causing.

I understand you are frustrated having to do third party software updates and in some cases make manual configuration changes, but there isn't an automated solution, as far as I know.

Just to recap, the headline suggestions for working around Flash problems usually include the following (try in this order) -- no uninstalls or reinstalls required:

(1) Disable Flash player protected mode (Win Vista and Win 7 only)

This involves creating or editing a text file buried in the Windows folder. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Check for and resolve conflicts with other Firefox add-ons (e.g., using Safe Mode or a clean profile)

(4) For display issues with scrolling, disable Smooth Scrolling and Autoscrolling here:

orange Firefox button or classic Tools menu > Options > Advanced > General

Hi alienalias28, you wrote: ''This seems to have been going on MONTHS and I am sick and tired of having to keep a Chrome browser open simply to watch video's.'' Since the release of Flash 11.3 on June 8th, which added a unique protected mode feature for users of Windows Vista and Windows 7, there have been a lot of Flash problems in Firefox due to conflicts with certain add-ons and settings. Adobe has fixed many of these in Flash 11.4, but apparently some remain. Real Networks also has updated its add-ons to resolve issues those were causing. I understand you are frustrated having to do third party software updates and in some cases make manual configuration changes, but there isn't an automated solution, as far as I know. Just to recap, the headline suggestions for working around Flash problems usually include the following (try in this order) -- no uninstalls or reinstalls required: '''(1) Disable Flash player protected mode (Win Vista and Win 7 only)''' This involves creating or editing a text file buried in the Windows folder. See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] '''(2) Disable hardware graphics acceleration in Firefox and in Flash''' (A) In Firefox, un-check the box here and restart: orange Firefox button ''or'' classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues '''(3) Check for and resolve conflicts with other Firefox add-ons''' (e.g., using Safe Mode or a clean profile) '''(4) For display issues with scrolling, disable Smooth Scrolling and Autoscrolling''' here: orange Firefox button ''or'' classic Tools menu > Options > Advanced > General