Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Alt codes not showing.

more options

I bought a new laptop a few months ago with windows 7, and found right away that with firefox, alt codes/symbols are not displayed properly. They work correctly on other browers, but firefox specifically will not render the characters, showing me spaces instead. For example, code number (&)#10077, which normally displays a quotation mark, only appears as a space. On chrome, it renders perfectly. My firefox is up to date. The problem has spanned all of the versions of firefox installed on this computer, with and without addons, and changing the encoding of the page does nothing to remedy it. Is there a way to correct this behaviour in firefox?

I bought a new laptop a few months ago with windows 7, and found right away that with firefox, alt codes/symbols are not displayed properly. They work correctly on other browers, but firefox specifically will not render the characters, showing me spaces instead. For example, code number (&)#10077, which normally displays a quotation mark, only appears as a space. On chrome, it renders perfectly. My firefox is up to date. The problem has spanned all of the versions of firefox installed on this computer, with and without addons, and changing the encoding of the page does nothing to remedy it. Is there a way to correct this behaviour in firefox?

Ausgewählte Lösung

hydeist wrote:

Now, it shows as space. Literally " ".

It sounds like the same problem as

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (7)

more options

❝ (&amp#x275d;) is a quote (❝) and shouldn't display as a ? or otherwise.
If you previously saw a ? then that means that you do not have a (dingbat) font that maps that symbol.

more options

Yes, as stated in the post, I saw it as I was intended to, as a quote. It appears as a quote on other browsers. Now, it shows as space. Literally " ". This only happens in firefox, so I assume that it's a firefox related problem.

Thank you for the reply.

more options

This may be related to the font that is used.

You can use this extension to see which fonts are used for selected text.

Does it help if you set another font as the default font?

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
more options

"Allow pages to choose their own fonts" is already selected for me. This machine is has the same settings that another windows 7/firefox 12 machine is running in my house that work.

I included an image of the options in this menu as they have been set.

more options

Ausgewählte Lösung

hydeist wrote:

Now, it shows as space. Literally " ".

It sounds like the same problem as

more options

Although I was a bit hesitant to uninstall them, I decided to go after those fonts anyway. With chs_boot, cht_boot, jpn_boot, kor_boot, and wgl4_boot uninstalled, firefox now seems to render characters on multiple sites for me correctly.

Thank you so much! I wasn't entirely sure how to search for my problem, so I missed that discussion on the cause. This has given me a lot of headaches, and it's so nice to see everything in working order.

Again, thank you so much, Gingerbread_Man!

more options

You're quite welcome. As I understand it, once Windows is installed, those fonts no longer serve a purpose. If you need to recover them, you can find them in the boot\fonts folder of your Windows installation disc.

When I tested, Firefox no longer had this issue starting with version 13, which is slated for release today (it may take a while until it's available as an update though).