Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Translate Icon and Menu Item do not appear?

  • 2 Antworten
  • 0 haben dieses Problem
  • Letzte Antwort von Mike Pureka

more options

I was browsing a webpage that turned out to be in Portuguese, and I was looking for how to translate it, but the internet indicated that Firefox has built in transation! However, neither the Translate Toolbar Icon nor the Translate menu option appear, even if I visit a site that absolutely should be translatable (https://fr.wikipedia.org/wiki/Mozilla_Firefox)

Additionally, if I go to Settings -> General, there is a Translations section, but if I click the Settings button, there are no languages in any of the boxes and no option to add any.

I am on Firefox 126.0 for Windows.

Here are the things I have tried:

  • Restarting Firefox
  • Rebooting my PC
  • Disabling all my extensions
  • Running Firefox in Troubleshooting Mode
  • Clearing my Startup Cache
  • Performing a "Refresh Firefox"
  • Toggling and Untoggling browser.translations.enable and browser.translations.automaticallyPopup

Does anyone have any suggestions of something I could have missed?

I was browsing a webpage that turned out to be in Portuguese, and I was looking for how to translate it, but the internet indicated that Firefox has built in transation! However, neither the Translate Toolbar Icon nor the Translate menu option appear, even if I visit a site that absolutely should be translatable (https://fr.wikipedia.org/wiki/Mozilla_Firefox) Additionally, if I go to Settings -> General, there is a Translations section, but if I click the Settings button, there are no languages in any of the boxes and no option to add any. I am on Firefox 126.0 for Windows. Here are the things I have tried: * Restarting Firefox * Rebooting my PC * Disabling all my extensions * Running Firefox in Troubleshooting Mode * Clearing my Startup Cache * Performing a "Refresh Firefox" * Toggling and Untoggling browser.translations.enable and browser.translations.automaticallyPopup Does anyone have any suggestions of something I could have missed?
Angefügte Screenshots

Alle Antworten (2)

more options

You can set browser.translations.logLevel => All in about:config, and then close and restart Firefox and check for issues with translation in the Browser Console.

Do not forget to reset the pref after you are done testing.

Hilfreich?

more options

I followed your instructions, but did not see any errors that looked translation related in the browser console, even after switching to multiprocess.

It's almost like translation is somehow just disabled and not even being attempted.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.