Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

No extension icons in toolbar, extensions menu, or toolbar customize menu

  • 2 Antworten
  • 0 haben dieses Problem
  • 36 Aufrufe
  • Letzte Antwort von zeroknight

more options

Just to preface I have already tried looking for a similar issue in support and most of the answers are like "just make sure to not be in private browsing" but I am sure that I am not and my extensions are all allowed in private browsing anyways. I also know this is not a theme issue as after I removed ublock origin and re-added it to firefox the extension icon showed up in the menu just like usual, but I do not want to do this for every single extension as I have a large amount and I am worried about personal settings that I have saved being undone. In the past I have used this same firefox setup without any of these issues whatsoever and without changing any settings since then.

The main issue is that when I click the extensions menu toolbar icon (the puzzle piece) it only takes me to about:addons. On this page I can confirm all my extensions are there, and I know that they are working, due to things like ads still being blocked from ublock origin or tracking links being blocked from clearURLs. However there is no icon for them after clicking/right clicking the the extensions puzzle piece, or when using the "customize toolbar" feature, or in the overflow menu, or in any other possible place. I have also tried telling the toolbar to reset to default and this does not help. Since the puzzle piece icon never shows me a menu, there is no way to right-click an extension and get the menu option to "pin to toolbar" as this option can't be found in the about:addons page as far as I have found.

Is there any way to fix this beyond just re-adding every single one of my extensions?

Just to preface I have already tried looking for a similar issue in support and most of the answers are like "just make sure to not be in private browsing" but I am sure that I am not and my extensions are all allowed in private browsing anyways. I also know this is not a theme issue as after I removed ublock origin and re-added it to firefox the extension icon showed up in the menu just like usual, but I do not want to do this for every single extension as I have a large amount and I am worried about personal settings that I have saved being undone. In the past I have used this same firefox setup without any of these issues whatsoever and without changing any settings since then. The main issue is that when I click the extensions menu toolbar icon (the puzzle piece) it only takes me to about:addons. On this page I can confirm all my extensions are there, and I know that they are working, due to things like ads still being blocked from ublock origin or tracking links being blocked from clearURLs. However there is no icon for them after clicking/right clicking the the extensions puzzle piece, or when using the "customize toolbar" feature, or in the overflow menu, or in any other possible place. I have also tried telling the toolbar to reset to default and this does not help. Since the puzzle piece icon never shows me a menu, there is no way to right-click an extension and get the menu option to "pin to toolbar" as this option can't be found in the about:addons page as far as I have found. Is there any way to fix this beyond just re-adding every single one of my extensions?

Ausgewählte Lösung

Gonna assume this was some small issue from a slightly broken update in the past as I just rebooted and firefox installed an update, and now the problem seems to be fixed.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (2)

more options

Ausgewählte Lösung

Gonna assume this was some small issue from a slightly broken update in the past as I just rebooted and firefox installed an update, and now the problem seems to be fixed.

more options

If this happens again in the future, you can go to about:config in the address bar, delete extensions.databaseSchema, then restart the browser.