Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Language Randomly Changed to Greek, Can't Change it Back

  • 9 Antworten
  • 0 haben dieses Problem
  • 28 Aufrufe
  • Letzte Antwort von captainlaurie

more options

Hi,

First off, I have only ever used Firefox in English. I don't speak enough of any other language well enough to do otherwise. I booted up my gaming PC today and opened Firefox, and the language on my menus, bookmarks toolbar, and almost all Firefox UI has randomly changed to what looks like it might be Greek. I can't change it back. It looks from the settings page that the selected language is English, but again I don't speak or read Greek so I have no idea what's going on here. I've run a virus scan, nothing came up. I tried clearing the Firefox startup cache, that didn't help. It's only the Firefox menus that are in Greek, webpages are still showing up in English like they should.

Can somebody help me fix this please? I use Firefox as my main browser on all of my PCs and I don't want to have to switch to using Chrome on one of them. Thanks!

Hi, First off, I have only ever used Firefox in English. I don't speak enough of any other language well enough to do otherwise. I booted up my gaming PC today and opened Firefox, and the language on my menus, bookmarks toolbar, and almost all Firefox UI has randomly changed to what looks like it might be Greek. I can't change it back. It looks from the settings page that the selected language is English, but again I don't speak or read Greek so I have no idea what's going on here. I've run a virus scan, nothing came up. I tried clearing the Firefox startup cache, that didn't help. It's only the Firefox menus that are in Greek, webpages are still showing up in English like they should. Can somebody help me fix this please? I use Firefox as my main browser on all of my PCs and I don't want to have to switch to using Chrome on one of them. Thanks!
Angefügte Screenshots

Ausgewählte Lösung

I figured it out! This actually was not really a problem with Firefox, even though it was only appearing in Firefox for some reason. I went into my font settings and reset Windows back to default fonts, which removed any third party fonts I had installed. Then I restarted and opened Firefox, it looks normal again.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (9)

more options

Oh also I tried completely uninstalling and installing a fresh copy of Firefox, no joy.

Hilfreich?

more options

Looks like you got ended up with installing the Greek Firefox version.

You can find the full installer of the current Firefox release (103.0.2) in all languages and all operating systems here:

Hilfreich?

more options

You may have to use "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Hilfreich?

more options

cor-el said

Looks like you got ended up with installing the Greek Firefox version. You can find the full installer of the current Firefox release (103.0.2) in all languages and all operating systems here:

This is exactly what I downloaded earlier today when I reinstalled Firefox (made sure it was the EN-US version), and then I did clear the startup cache, which didn't help. See the attached screenshot from my control panel program list. I'll try reinstalling again I guess.

Hilfreich?

more options

cor-el said

You may have to use "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Nope, no go. Tried uninstalling Firefox, reinstalling via the version you linked to (yes I am downloading the English version), cleared startup cache, still looks the same. Greek everywhere except in the webpages themselves.

I don't know what else to do here.

Hilfreich?

more options

If something has corrupted within your Firefox profile, then re-installing won't help if you then continue using the same profile.

Have you tried setting the UI language to something else, and then setting it back to English? (possibly with a Firefox restart between operations)

Or have you tried running in Troubleshoot Mode to saee if an add-on may be causing this?

You may also wish to check your OS language setting to make sure everything is as it should be.

Or as a last resort, you could try refreshing Firefox to see if that helps. (backing up your Firefox profile folder first, naturally)

Hilfreich?

more options

TechHorse said

If something has corrupted within your Firefox profile, then re-installing won't help if you then continue using the same profile. Have you tried setting the UI language to something else, and then setting it back to English? (possibly with a Firefox restart between operations) Or have you tried running in Troubleshoot Mode to saee if an add-on may be causing this? You may also wish to check your OS language setting to make sure everything is as it should be. Or as a last resort, you could try refreshing Firefox to see if that helps. (backing up your Firefox profile folder first, naturally)

I don't think I'm using the same profile though. I've uninstalled Firefox and removed all of the user folders, and cleared any entries in the registry, and am not signed in to my Firefox Account on that computer -- I don't want to risk syncing something that might cause issues on my other computers. I have 2 other desktops I use (media PC and office PC) plus a laptop, and most of those are signed in to my account, but this one wasn't.

What can I do to completely wipe any profile info from my PC before reinstalling?

Additionally: I suspect, on looking more closely, that this could be a font issue instead of being in real Greek. If it were real Greek, I shouldn't be able to guess what some of the words are. Photo attached of the words "questions about" to clarify what I mean

Hilfreich?

more options

I hadn't looked too closely to the Greek text, but you are right about that this isn't Greek text, but merely Greek characters are used to display the English text. So this is more likely a font issue and for some reason a font with Greek characters in the main ASCII range is used. I assume that if you do a copy and paste elsewhere that you get proper English text ?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Hilfreich?

more options

Ausgewählte Lösung

I figured it out! This actually was not really a problem with Firefox, even though it was only appearing in Firefox for some reason. I went into my font settings and reset Windows back to default fonts, which removed any third party fonts I had installed. Then I restarted and opened Firefox, it looks normal again.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.