Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Even though I don't have it selected every time I open a new tab Firefox switches to it

  • 4 Antworten
  • 1 hat dieses Problem
  • 8 Aufrufe
  • Letzte Antwort von Figureguy

more options

Good evening. I have Firefox set to NOT switch to a new tab when it opens from a link but it does anyway. I clicked the box and unclicked it but it still switches over. Any help would be appreciated.

Also, how can I stop the address bar from searching the web and just search bookmarks and history? I have a separate bar for searching and prefer my web searches show up there.

Thanks in advance.

Alle Antworten (4)

more options

You can set keyword.enabled = false on the about:config page to disable searching via the location bar, Also see the settings for the location bar in "Settings -> Search".

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Geändert am von cor-el

Hilfreich?

more options

Thanks for responding, Cor-El. That did the trick for searches as I am now only getting bookmarks and history. Anything to stop switching to the new tab when opened? I didn't have any trouble before but my computer had a major hiccup and I had to reset windows. Firefox needed some adjusting while things had worked fine before.

Hilfreich?

more options

There are a couple different scenarios for opening a link in a new tab:

(A) Manual method -- opening it yourself, for example:

  • right-click > Open Link in New Tab
  • Ctrl+click
  • Middle-click with the mouse wheel

Usually the checkbox on the Settings page handles these

(B) Diversion method -- Firefox diverts a new window to a new tab instead

This is not covered by the checkbox, you need to go under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

Firefox should list several preferences:

  • browser.search.context.loadInBackground -- for searching selected text from the right-click context menu
  • browser.tabs.loadBookmarksInBackground -- for bookmarks
  • browser.tabs.loadDivertedInBackground -- for scenario (B) above
  • browser.tabs.loadInBackground -- checkbox on the Settings page

(3) Double-click any preference to switch its value between false and true

Can you get it working the way you want?

More info on about:config: Configuration Editor for Firefox.

Hilfreich?

more options

jscher200,

Thanks to you as well. That seems to be working great. I believe that is all the problems I am having now but I will check throughout the day as I didn't finish getting everything set until late last night and haven't had much time to try it out today. But these two seem to make a big difference.

I appreciate your time, everyone.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.