Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Tabs gone after V89.0 update

  • 17 Antworten
  • 3 haben dieses Problem
  • 51 Aufrufe
  • Letzte Antwort von SirusZex

more options

Mt tab bar is set up to appear underneath the bookmarks bar. I just updated to version 89.0 (64 bit) and the tabs bar is there but NO tabs are appearing on it or anywhere. How do I fix this?

Ausgewählte Lösung

Hi Briankarens, you've probably noticed that you need to update your userChrome.css code for this every 10-15 versions, and it's time to update again. You can check this thread on Reddit:

https://www.reddit.com/r/FirefoxCSS/comments/nq2d0q/tabs_on_bottom_for_firefox_89/

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (17)

more options

If you go to customize toolbar (right click in a blank space beside the address bar and choose Customize Toolbar) - if you see an icon for tabs, click and drag it to the space that you want it to go. I think that the only spot that it can go at this point is above the address bar.

I already made a post here inquiring how to move the tab bar to below the bookmarks bar in 89.0 - no reply yet but if I get one I will post the answer here for you. Cheers and I hope that this helps sir.

Geändert am von bob245

Hilfreich?

more options

Bob:

Thanks for the suggestion, but there is no "Tabs" icon on the Customize toolbars screen. For many, many years I have had the tabs below the bookmarks and would like to keep it that way. I have previously used the "Userchrome.css" configuration approach to keep it in place, but that doesn't work anymore.

Hopefully you will find a solution and let me know.

Hilfreich?

more options

apparently this seems to work for some people: https://www.reddit.com/r/FirefoxCSS/comments/nq2d0q/tabs_on_bottom_for_firefox_89/

but sadly it doesnt seem to work for me, tabs keep moving to the bottom of the browser and l only see the first Tab while the rest arent clickable. why is it Mozilla breaks this CSS hack every new version? wish there was still a tick box to move the tabs bar back to the area below the bookmarks toolbar....

Hilfreich?

more options

Ausgewählte Lösung

Hi Briankarens, you've probably noticed that you need to update your userChrome.css code for this every 10-15 versions, and it's time to update again. You can check this thread on Reddit:

https://www.reddit.com/r/FirefoxCSS/comments/nq2d0q/tabs_on_bottom_for_firefox_89/

Hilfreich?

more options

l found that link earlier, for some reason it moves my tabs to the bottom of the browser for me rather than the intended location of below my bookmarks toolbar... and has the unintended bug that l can only see one opened tab with the rest hidden.

Hilfreich?

more options

SirusZex said

l found that link earlier, for some reason it moves my tabs to the bottom of the browser for me rather than the intended location of below my bookmarks toolbar... and has the unintended bug that l can only see one opened tab with the rest hidden.

Wow, that's annoying, sorry. cor-el has a note on a possible error in that code over in another thread. Maybe this will fix it? https://support.mozilla.org/en-US/questions/1338147#answer-1416717

Hilfreich?

more options

jscher2000:

Yay! Thank you for the solution. That worked fine and tabs are back just below the bookmark bar. Perfecto!

Hilfreich?

more options

sadly it didnt work for me, l did update the code with the suggested fix to an unclosed bracket but l was returned to my previous issue where the tab was at the bottom of the browser, in fact lve added a screen cap to this post, l should also note that its not the only issue as l opened six tabs as well but only see the first one while the rest are missing.

Hilfreich?

more options

Hi SirusZex, the old code does cause tabs to stack up along the bottom, but the new code shouldn't -- that's the whole reason it was created. I'm sorry that I haven't had time to test personally, but perhaps you could follow up in the other thread with your screenshot to see whether a further tweak is possible.

Hilfreich?

more options

thats the weird part l used the new code posted on reddit but also visited the other link for the code that was missing the closing bracket that was missing.

Hilfreich?

more options

ok turns out l messed up, l kinda have a shortcut to my chrome profile folder and didnt think to look in the /profile folder, turns out l have more than one profile (didnt know that there was a a new one as ld always directed myself towards my usual links) lve managed to get my tabs back below my bookmarks nav bar.

only weirdness is the fact that it messes up some of the theme, selected tabs look fine, unselected one just sort of look like l long tab, only thing that defines them is the red x to close the tab, not to mention there is an annoying amount of space below the tabs.

Geändert am von SirusZex

Hilfreich?

more options

You could try picking up some tweaks from here:

https://www.userchrome.org/firefox-89-styling-proton-ui.html#tabstyler

If you like what you see on the preview bar for an option, scroll down to copy relevant bits of code.

Hilfreich?

more options

lm assuming l just add the code to the userchrome? generally lve just searched and changed code rather than custom coded anything myself.

Hilfreich?

more options

SirusZex said

lm assuming l just add the code to the userchrome? generally lve just searched and changed code rather than custom coded anything myself.

For example, this is the code for little lines between background tabs. It's just a right-side border, but I don't know whether it will look good with your color scheme:

    .tab-background:not([selected=true]):not([multiselected=true]):not([beforeselected-visible="true"]) {
        border-right: 1px solid rgba(0, 0, 0, .20) !important;
    }
    /* For dark backgrounds */
    [brighttext="true"] .tab-background:not([selected=true]):not([multiselected=true]):not([beforeselected-visible="true"]) {
        border-right: 1px solid var(--lwt-selected-tab-background-color, rgba(255, 255, 255, .20)) !important;
    }
    .tab-background:not([selected=true]):not([multiselected=true]) {
        border-radius: 0 !important;
    }
    /* Remove padding between tabs */
    .tabbrowser-tab {
        padding-left: 0 !important;
        padding-right: 0 !important;
    }

Hilfreich?

more options

yeah lve tweaked it so l can see outlines around the tabs which l feel looks better and makes the tabs more distinguishable, just noticed my tab notification addon isnt working (by notification it showed me which tabs l had not read yet) l really miss tab mix plus where l styled unloaded tabs as bold red, would be kinda neat to have bold text on other tabs.. god l miss that addon lol.

the only other issue is whats in my last screen cap the space below my tabs.

Hilfreich?

more options

I don't know why that space is there. Perhaps it is meant to be filled by another bar such as the Bookmarks Toolbar???

Hilfreich?

more options

lve not set any other toolbars to active, and the bookmarks toolbar is above it now.. that said the tabs are smaller than they would be if they appeared above, maybe if they tabs were made bigger it wouldnt show as much blank space or if that part of the line were made smaller, not exactly sure what part of the code ld need to edit tho.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.