Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

pop out videos wont stop. Have unchecked the box, but still chewing up my bandwidth.

  • 7 Antworten
  • 1 hat dieses Problem
  • 28 Aufrufe
  • Letzte Antwort von j.searle01

more options

Please make videos stop playing when I go to a website. Now (25/9/20) pop out videos have started cluttering my screen and are difficult to shut down. I do not want picture in picture and I do not want videos to play automatically. I have been through all the settings, but nothing makes any difference.

Ausgewählte Lösung

These are just in-page frames, not Firefox's Picture-in-Picture feature. There's nothing built-in to Firefox to block floating or fixed-position video frames, you would need to use an extension to block them. (I actually haven't researched which extensions can do it.)

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (7)

more options

It shouldn't autoplayed, but it doesn't look like our picture in picture. It's the feature of this website. Ask its owners, how to disable it.

Hilfreich?

more options

You can disable PiP via about:config (media.videocontrols.picture-in-picture.enabled = false), but you need a content blocking extension or possibly disable autoplay in Firefox to prevent a website from showing a floating media player window.

You can look at these prefs on the the about:config page to see if these settings work for you to block autoplay and possibly prevent opening a popup player.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Hilfreich?

more options

Hi, thanks for your post, unfortunately it did not work. Everything was fine until the most recent update, now PiP is on all the time.

Hilfreich?

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Can you attach a screenshot?

Hilfreich?

more options

Hi, thanks - an easy site to access - [https://www.dailymail.co.uk/home/index.htm

Screenshot is PiP.jpg

Hilfreich?

more options

Ausgewählte Lösung

These are just in-page frames, not Firefox's Picture-in-Picture feature. There's nothing built-in to Firefox to block floating or fixed-position video frames, you would need to use an extension to block them. (I actually haven't researched which extensions can do it.)

Hilfreich?

more options

Thanks for your help. I have found Pop Up Blocker (Strict) in the add-ons, it seems to have stopped the problem.

Geändert am von j.searle01

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.