Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I can't open a Spotify URI from Firefox

  • 3 Antworten
  • 1 hat dieses Problem
  • 99 Aufrufe
  • Letzte Antwort von Jamesjayne100

more options

I can't open a Spotify URI from Firefox But I can open it from command line using the --uri option. As in, this works fine from the terminal:

spotify --uri="spotify:artist:6OqhFYFJDnBBHas02HopPT"

and whatever Firefox is doing just launches Spotify without navigating to the thing indicated by the URI

Is there, perchance, a simple file edit I can do that will fix this for me?

I can't open a Spotify URI from Firefox But I can open it from command line using the --uri option. As in, this works fine from the terminal: spotify --uri="spotify:artist:6OqhFYFJDnBBHas02HopPT" and whatever Firefox is doing just launches Spotify without navigating to the thing indicated by the URI Is there, perchance, a simple file edit I can do that will fix this for me?

Ausgewählte Lösung

No, there's no direct analog, but that gave me the right search term to figure out what I was even looking for. Wasn't at all a Firefox problem, sorry about that. And thanks so much for taking the time anyway.

For anyone interested in the future, the solution was to change the file "/var/lib/snapd/desktop/applications/spotify_spotify.desktop" Change the end of line 7, the one starting with "Exec="

from this: /snap/bin/spotify %U

to this: /snap/bin/spotify --uri=%U

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (3)

more options

Hi patrickmcgorrill, Firefox should be sending that entire URL to the app. The URL works from other browsers but not from Firefox?

Unfortunately, what I know about checking the shell open command in the Windows Registry probably doesn't have a direct analog on Linux, but that is where the command line would be defined. Or its equivalent.

more options

Ausgewählte Lösung

No, there's no direct analog, but that gave me the right search term to figure out what I was even looking for. Wasn't at all a Firefox problem, sorry about that. And thanks so much for taking the time anyway.

For anyone interested in the future, the solution was to change the file "/var/lib/snapd/desktop/applications/spotify_spotify.desktop" Change the end of line 7, the one starting with "Exec="

from this: /snap/bin/spotify %U

to this: /snap/bin/spotify --uri=%U

Geändert am von patrickmcgorrill

more options

Spotify is the great app.