Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Unable to install add-ons

  • 5 Antworten
  • 2 haben dieses Problem
  • 47 Aufrufe
  • Letzte Antwort von mmcnally

more options

When I visit any Add-ons page, instead of the button to install the add-on, a button stating "Only with Firefox - Get Firefox now" appears. Clicking this button takes me to the Firefox download page.

This is happening in Firefox, which just updated to the latest version (67.0.1) this morning.

Ausgewählte Lösung

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (5)

more options

The System Details list shows that you have a broken user agent that identifies you as Firefox 50

  • Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20161123 Firefox/50.0; xs-yXXal3WnNSs;

See:

more options

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

I uninstalled Flash. I also followed the instructions for resetting the user agent and restarted Firefox. Firefox is still showing the wrong user agent in about:config.

What's my next option for correcting the user agent?

more options

Ausgewählte Lösung

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

The user.js had a single line in it: user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20161123 Firefox/50.0; xs-yXXal3WnNSs;"); I have no idea where that came from or why it was there.

I was able to delete the user.js and reset the general.useragent.override setting. After restarting Firefox all is working correctly again.

Thanks for your help!