X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

plain text mode

Veröffentlicht

When I select "Edit as New Message" in Thunderbird (v52.9.1) on a Mac, the message editor comes up in html mode even if I have set everything to plain text.

I have read all the articles on this and done all the things people have recommended including messing with Advanced options, account settings, etc. However, none of these solutions work.

Attached is a screenshot showing the problem. The first screenshot shows my inbox. The second shot shows that "Edit as new message" comes up in html mode.

Please advise.

When I select "Edit as New Message" in Thunderbird (v52.9.1) on a Mac, the message editor comes up in html mode even if I have set everything to plain text. I have read all the articles on this and done all the things people have recommended including messing with Advanced options, account settings, etc. However, none of these solutions work. Attached is a screenshot showing the problem. The first screenshot shows my inbox. The second shot shows that "Edit as new message" comes up in html mode. Please advise.
Angefügte Screenshots

Ausgewählte Lösung

I normally recommend this page when a user wants to force an upgrade:

https://www.thunderbird.net/en-US/thunderbird/all/

I just downloaded the Mac version from there and it gave me TB60.2.1. Be aware that many of your add-ons may stop working with this version.

All current and past versions (and even some un-released beta versions) can be found here:

https://ftp.mozilla.org/pub/thunderbird/releases/

This is handy if you need to revert an upgrade.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Weitere Informationen

Veröffentlicht

Fragesteller

Also, note that when I forward the message it comes up in plain text mode. But "Edit As New Message" comes up in html mode.

Also, note that when I forward the message it comes up in plain text mode. But "Edit As New Message" comes up in html mode.
sfhowes
  • Top 10 Contributor
1438 Lösungen 6814 Antworten
Veröffentlicht

What happens if you hold Shift when you Edit as New or Forward?

What happens if you hold Shift when you Edit as New or Forward?
Veröffentlicht

Fragesteller

It comes up in html mode. Like I said, I have tried everything suggested in the discussion groups. This has been a long-standing problem with TBird. It needs to be fixed.

It comes up in html mode. Like I said, I have tried everything suggested in the discussion groups. This has been a long-standing problem with TBird. It needs to be fixed.
sfhowes
  • Top 10 Contributor
1438 Lösungen 6814 Antworten
Veröffentlicht

Not knowing what 'everything suggested' includes, I would ask what you have in Preferences/Composition/General/Send Options. On my system, HTML-format is the default, but holding Shift when I select Edit as New Message opens the Write window in plain text mode (W10/TB 60.2.1).

Not knowing what 'everything suggested' includes, I would ask what you have in Preferences/Composition/General/Send Options. On my system, HTML-format is the default, but holding Shift when I select Edit as New Message opens the Write window in plain text mode (W10/TB 60.2.1).
Veröffentlicht

Fragesteller

Things I have tried:

- obviously, turned off html mode on composition
- Preferences->Composition->Send Options:
    > tried both plain txt only and both
    > set plain text domains to *.*
    > Edited the config options under 
       advanced options->config editor

- tried pressing "Shift" and "Edit as New Message"

Let me know if there are other things to try.

Things I have tried: - obviously, turned off html mode on composition - Preferences->Composition->Send Options: > tried both plain txt only and both > set plain text domains to *.* > Edited the config options under advanced options->config editor - tried pressing "Shift" and "Edit as New Message" Let me know if there are other things to try.
sfhowes
  • Top 10 Contributor
1438 Lösungen 6814 Antworten
Veröffentlicht

The only other thing I can think of is if the recipient of the message that you Edit as New is marked in Address Book as preferring HTML format. In the meantime, if the message composer appears as HTML, you could set Options/Delivery Format to plain text in the Write window.

The only other thing I can think of is if the recipient of the message that you Edit as New is marked in Address Book as preferring HTML format. In the meantime, if the message composer appears as HTML, you could set Options/Delivery Format to plain text in the Write window.
Veröffentlicht

Fragesteller

I set the mode to "plain text only" for the preferred delivery format for this user (it was previously set to unknown". That did not fix the problem.

I also set Options/Delivery Format to plain text in the write window, but that did not change the mode - it is still in html mode.

This must be a Mac issue...

-Joe

I set the mode to "plain text only" for the preferred delivery format for this user (it was previously set to unknown". That did not fix the problem. I also set Options/Delivery Format to plain text in the write window, but that did not change the mode - it is still in html mode. This must be a Mac issue... -Joe
sfhowes
  • Top 10 Contributor
1438 Lösungen 6814 Antworten
Veröffentlicht

Changing the delivery format won't change the Write window from HTML to plain text, but the received message should be plain text.

Not sure if this is a Mac issue, and I would be inclined to create a new profile, set up an account, and see if anything changes. That kind of test would certainly be needed before claiming there is a bug.

Changing the delivery format won't change the Write window from HTML to plain text, but the received message should be plain text. Not sure if this is a Mac issue, and I would be inclined to create a new profile, set up an account, and see if anything changes. That kind of test would certainly be needed before claiming there is a bug.
Veröffentlicht

Fragesteller

If the message comes up in html mode in the write window, is there a way to convert it to plain text easily.

Regarding whether it is a bug, I have been using Thunderbird since forever. I have used it across operating systems. It has always has this behavior as far as I can remember.

If the message comes up in html mode in the write window, is there a way to convert it to plain text easily. Regarding whether it is a bug, I have been using Thunderbird since forever. I have used it across operating systems. It has always has this behavior as far as I can remember.
sfhowes
  • Top 10 Contributor
1438 Lösungen 6814 Antworten
Veröffentlicht

If the message opens in HTML mode, you can't change it to plain text mode, but you can change the delivery format to plain text. Holding the Shift key changes the mode to the opposite of whatever mode appears without the Shift key, and that has always worked for new messages, replies, forwards and edit as new.

If the message opens in HTML mode, you can't change it to plain text mode, but you can change the delivery format to plain text. Holding the Shift key changes the mode to the opposite of whatever mode appears without the Shift key, and that has always worked for new messages, replies, forwards and edit as new.
Veröffentlicht

Fragesteller

Thanks for your help on this. It was very nice of you to spend time on this. I'll submit a bug report on it.

Thanks for your help on this. It was very nice of you to spend time on this. I'll submit a bug report on it.
Toad-Hall
  • Top 10 Contributor
1703 Lösungen 11364 Antworten
Veröffentlicht

Was the original message sent using HTML, but you prefer to read in Plain Text.

Select email in list to read it. click on 'More' and select 'View Source' At the top will be all the headers. then it gets to the actual message areas. Is there only a Plain Text section or is there a HTML section below the Plain Text section ?

Was the original message sent using HTML, but you prefer to read in Plain Text. Select email in list to read it. click on 'More' and select 'View Source' At the top will be all the headers. then it gets to the actual message areas. Is there only a Plain Text section or is there a HTML section below the Plain Text section ?
Veröffentlicht

Fragesteller

Here is the source for the message. It still comes up in html mode. I upgraded to Mac Mohave and that didn't fix anything (I didn't expect it to).

==

Delivered-To: joseph.picone@gmail.com Received: by 2002:a17:90a:c58f:0:0:0:0 with SMTP id l15-v6csp3970066pjt;

       Fri, 19 Oct 2018 12:58:09 -0700 (PDT)

X-Received: by 2002:a02:8a63:: with SMTP id e32-v6mr5555056jal.6.1539979089896;

       Fri, 19 Oct 2018 12:58:09 -0700 (PDT)

ARC-Seal: i=1; a=rsa-sha256; t=1539979089; cv=none;

       d=google.com; s=arc-20160816;
       b=ZSetP6Rl6/BqB1ekldTAdM4vWOM5Tz2ONAmnEJEB9hOXbRSflY7L1fziV1n3A9VcD8
        ORfHfRy4+ELDZge/QYf6Czvyoiev3s0u4pY/LS2WmpqcSu9YYCEhDovVxK0Gf+T3ULke
        BDbwJv+QVM5rWQJWwgfKf3alnvxbwfnpPVu3Cxg3SsuXYstOZBFazD+HJYM6UF5EpP0T
        WO5Fv987MFEiHkQwC1w2D/2NGJCOWs/8Q98gvx6FwI72/BwF+DzomskOkXTEF2LkCgm2
        9dxi1c1LugvlSBSFvHUctnBwSx7UIsxYpQIs1aS/juQN9DEEzIyXtCk2dhyaGNG436rR
        Ictg==

ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20160816;

       h=to:subject:message-id:date:from:in-reply-to:references:mime-version
        :dkim-signature;
       bh=OrR27x0Rbqy1KwQWB+AjD+vQXVeE7WQXNcW5Sgc3ktg=;
       b=dCkM5gRmlsxrnrlHO7UUZkWR/VS1kp6FIsqy+ldhJ174GLBUJQktrJyZv1yOsfeGw/
        khSaPnDnQwBRuq5KUsh98ng2v1cNo8Jpc8n6+MOJZ+S4xOAEnUdi6T2IwwXwc5yMfRQ6
        UwvyxcJIRyYlaKXqrFjh6mA8yKAu5vn2YGjp/o/Ar+PRPzKanaEJdmE1cQfVmNZFgbuz
        pmHlcEmNtlxT+sqFysG+fwm3hr4X7McXL8VoKpeaPV/GFW/nBKQll/ZH8pomHerPQsWG
        zhfV2mirzx/1LD3gqTNj7S/DzlDEN0iPBWRmwXQ/50fwk5T7zANFXknTVQ2ROqMHlUCT
        gx3w==

ARC-Authentication-Results: i=1; mx.google.com;

      dkim=pass header.i=@temple-edu.20150623.gappssmtp.com header.s=20150623 header.b=PRKYkN0N;
      spf=pass (google.com: domain of tug90975@temple.edu designates 209.85.220.41 as permitted sender) smtp.mailfrom=tug90975@temple.edu

Return-Path: <tug90975@temple.edu> Received: from mail-sor-f41.google.com (mail-sor-f41.google.com. [209.85.220.41])

       by mx.google.com with SMTPS id n12-v6sor18080866jao.8.2018.10.19.12.58.09
       for <joseph.picone@gmail.com>
       (Google Transport Security);
       Fri, 19 Oct 2018 12:58:09 -0700 (PDT)

Received-SPF: pass (google.com: domain of tug90975@temple.edu designates 209.85.220.41 as permitted sender) client-ip=209.85.220.41; Authentication-Results: mx.google.com;

      dkim=pass header.i=@temple-edu.20150623.gappssmtp.com header.s=20150623 header.b=PRKYkN0N;
      spf=pass (google.com: domain of tug90975@temple.edu designates 209.85.220.41 as permitted sender) smtp.mailfrom=tug90975@temple.edu

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;

       d=temple-edu.20150623.gappssmtp.com; s=20150623;
       h=mime-version:references:in-reply-to:from:date:message-id:subject:to;
       bh=OrR27x0Rbqy1KwQWB+AjD+vQXVeE7WQXNcW5Sgc3ktg=;
       b=PRKYkN0N2wkUB02sdR4ryi7Tx8zwkwtf6wjtAVCPWwkCbt7gs5Jii5h5HZlyfJ1m6g
        VVis5oYrOifioeM4bSckAhtcVtcxkgdUrfua9xFf6+54iUW4ehsnv3XMPHWJY6sWTfvk
        NBiL0PqQJMwUeEnY0J2R2QfDLojTXB1C8ZKYsJhjPxAK4Hsxs8mEoLTCyX184UlTPRZm
        qHDS6Ca5lYXr6pJ+O28YKg881pDU1eH0c9CrEE8n2/a63eHKbMmX4k28HslxF2XNdg2k
        qTtOtp/6h2Yv0eAIfeYqTw6LBs0AzI9+hYbsVvqFysjY7MMz4mZfBVycXubXeFwauEGs
        5cJA==

X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;

       d=1e100.net; s=20161025;
       h=x-gm-message-state:mime-version:references:in-reply-to:from:date
        :message-id:subject:to;
       bh=OrR27x0Rbqy1KwQWB+AjD+vQXVeE7WQXNcW5Sgc3ktg=;
       b=G11PuoMroaja6UaaUccpNTGzC4wR94ye2ownfzfUrfMt6gf6DL9nLbcf9q85HdHbs0
        kCemP4Bwz/mcU8M8YHkOvzhl4zPQECkYxAi3mSKHcbNIotDaEnUipOxbpQMKDDKJkcxq
        XewXFL1+S1D4I+cDHIxCT3Yh9+F3JZEIHZCB6bpYqY1jjJzCiPFuf7uGBL2pdfz2U6iQ
        1NH2z0P7d49VMsfFN1apeipUJXTaRHyIauO1JnAn1cm7QH0j8j91E6KdTwzCR9x+zOHP
        1raYxGhNjdGGzWjLg32vMERFPZXZ/i3io9US0yZgadThTdw0Na9cpOgUoPCTesFoKRrj
        bv8A==

X-Gm-Message-State: ABuFfohTyyn1d1qoaOwEO0nUL7FQV1yP3HTlj2MfHmLNNyKTOrxKFVqW zuszxt93oVwwYNnJvPsBG5A0SOi2OCYSPMMZQf4i0rgMLzw= X-Google-Smtp-Source: ACcGV62izmSanUzsc9bo4SVpkLFqV9xoAeMUsZQJYeVeLewa5Vm5emlkwC1xa4yAZ0EzQp+/5KplVIw10bu9lOf420c= X-Received: by 2002:a02:3849:: with SMTP id v9-v6mr5187247jae.15.1539979089175;

Fri, 19 Oct 2018 12:58:09 -0700 (PDT)

MIME-Version: 1.0 References: <CAMhyBcQGQ=EqPXOv41PGUO_hV-N3Gxgb7X3W4J5d54_Qoeyybg@mail.gmail.com>

<201df4b1-56a6-a96b-68af-dde6f5c1af2a@gmail.com>

In-Reply-To: <201df4b1-56a6-a96b-68af-dde6f5c1af2a@gmail.com> From: Sean Ferrell <sean.ferrell@temple.edu> Date: Fri, 19 Oct 2018 15:57:58 -0400 Message-ID: <CAMhyBcQ3qwZs9G9Zk=1AZGV6zHwke99AmfFnGBrRrwTQSy3k7Q@mail.gmail.com> Subject: Re: (Draft) Release Announcement: NEDC TUH EEG Seizure (v1.4.0) To: Joseph Picone <joseph.picone@gmail.com> Content-Type: multipart/alternative; boundary="000000000000927fc105789a52f7"

--000000000000927fc105789a52f7 Content-Type: text/plain; charset="UTF-8"

Hello everyone,

We have released v1.4.0 of TUH EEG Seizure (TUSZ). It is available at:

https://isip.piconepress.com/projects/tuh_eeg/downloads/tuh_eeg_seizure/v1.4.0/

TUSZ v1.4.0 includes improvements to the quality of annotations. In the development test dataset, annotation corrections were made on several files. Updates to the training dataset include several annotation corrections and the removal of one session.

Here is a summary of our planned releases:

v1.5.0 (20181115): The expansion of the training dataset that will now include more than 4,500 annotation files. v1.6.0 (20181215): An additional 1,000 annotation files included in the training dataset, resulting in over 5,500 files.

As always, don't hesitate to contact us with your questions or bug reports.

Best regards,

Sean Ferrell NEDC Data Resources Development Manager The Neural Engineering Data Consortium Temple University College of Engineering, ENGR 602 1947 North 12th Street Philadelphia, PA 19122-6018 Tel: 215-204-4841 Fax: 215-204-5960 Email: sean.ferrell@temple.edu

Here is the source for the message. It still comes up in html mode. I upgraded to Mac Mohave and that didn't fix anything (I didn't expect it to). ========== Delivered-To: joseph.picone@gmail.com Received: by 2002:a17:90a:c58f:0:0:0:0 with SMTP id l15-v6csp3970066pjt; Fri, 19 Oct 2018 12:58:09 -0700 (PDT) X-Received: by 2002:a02:8a63:: with SMTP id e32-v6mr5555056jal.6.1539979089896; Fri, 19 Oct 2018 12:58:09 -0700 (PDT) ARC-Seal: i=1; a=rsa-sha256; t=1539979089; cv=none; d=google.com; s=arc-20160816; b=ZSetP6Rl6/BqB1ekldTAdM4vWOM5Tz2ONAmnEJEB9hOXbRSflY7L1fziV1n3A9VcD8 ORfHfRy4+ELDZge/QYf6Czvyoiev3s0u4pY/LS2WmpqcSu9YYCEhDovVxK0Gf+T3ULke BDbwJv+QVM5rWQJWwgfKf3alnvxbwfnpPVu3Cxg3SsuXYstOZBFazD+HJYM6UF5EpP0T WO5Fv987MFEiHkQwC1w2D/2NGJCOWs/8Q98gvx6FwI72/BwF+DzomskOkXTEF2LkCgm2 9dxi1c1LugvlSBSFvHUctnBwSx7UIsxYpQIs1aS/juQN9DEEzIyXtCk2dhyaGNG436rR Ictg== ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20160816; h=to:subject:message-id:date:from:in-reply-to:references:mime-version :dkim-signature; bh=OrR27x0Rbqy1KwQWB+AjD+vQXVeE7WQXNcW5Sgc3ktg=; b=dCkM5gRmlsxrnrlHO7UUZkWR/VS1kp6FIsqy+ldhJ174GLBUJQktrJyZv1yOsfeGw/ khSaPnDnQwBRuq5KUsh98ng2v1cNo8Jpc8n6+MOJZ+S4xOAEnUdi6T2IwwXwc5yMfRQ6 UwvyxcJIRyYlaKXqrFjh6mA8yKAu5vn2YGjp/o/Ar+PRPzKanaEJdmE1cQfVmNZFgbuz pmHlcEmNtlxT+sqFysG+fwm3hr4X7McXL8VoKpeaPV/GFW/nBKQll/ZH8pomHerPQsWG zhfV2mirzx/1LD3gqTNj7S/DzlDEN0iPBWRmwXQ/50fwk5T7zANFXknTVQ2ROqMHlUCT gx3w== ARC-Authentication-Results: i=1; mx.google.com; dkim=pass header.i=@temple-edu.20150623.gappssmtp.com header.s=20150623 header.b=PRKYkN0N; spf=pass (google.com: domain of tug90975@temple.edu designates 209.85.220.41 as permitted sender) smtp.mailfrom=tug90975@temple.edu Return-Path: <tug90975@temple.edu> Received: from mail-sor-f41.google.com (mail-sor-f41.google.com. [209.85.220.41]) by mx.google.com with SMTPS id n12-v6sor18080866jao.8.2018.10.19.12.58.09 for <joseph.picone@gmail.com> (Google Transport Security); Fri, 19 Oct 2018 12:58:09 -0700 (PDT) Received-SPF: pass (google.com: domain of tug90975@temple.edu designates 209.85.220.41 as permitted sender) client-ip=209.85.220.41; Authentication-Results: mx.google.com; dkim=pass header.i=@temple-edu.20150623.gappssmtp.com header.s=20150623 header.b=PRKYkN0N; spf=pass (google.com: domain of tug90975@temple.edu designates 209.85.220.41 as permitted sender) smtp.mailfrom=tug90975@temple.edu DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=temple-edu.20150623.gappssmtp.com; s=20150623; h=mime-version:references:in-reply-to:from:date:message-id:subject:to; bh=OrR27x0Rbqy1KwQWB+AjD+vQXVeE7WQXNcW5Sgc3ktg=; b=PRKYkN0N2wkUB02sdR4ryi7Tx8zwkwtf6wjtAVCPWwkCbt7gs5Jii5h5HZlyfJ1m6g VVis5oYrOifioeM4bSckAhtcVtcxkgdUrfua9xFf6+54iUW4ehsnv3XMPHWJY6sWTfvk NBiL0PqQJMwUeEnY0J2R2QfDLojTXB1C8ZKYsJhjPxAK4Hsxs8mEoLTCyX184UlTPRZm qHDS6Ca5lYXr6pJ+O28YKg881pDU1eH0c9CrEE8n2/a63eHKbMmX4k28HslxF2XNdg2k qTtOtp/6h2Yv0eAIfeYqTw6LBs0AzI9+hYbsVvqFysjY7MMz4mZfBVycXubXeFwauEGs 5cJA== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:references:in-reply-to:from:date :message-id:subject:to; bh=OrR27x0Rbqy1KwQWB+AjD+vQXVeE7WQXNcW5Sgc3ktg=; b=G11PuoMroaja6UaaUccpNTGzC4wR94ye2ownfzfUrfMt6gf6DL9nLbcf9q85HdHbs0 kCemP4Bwz/mcU8M8YHkOvzhl4zPQECkYxAi3mSKHcbNIotDaEnUipOxbpQMKDDKJkcxq XewXFL1+S1D4I+cDHIxCT3Yh9+F3JZEIHZCB6bpYqY1jjJzCiPFuf7uGBL2pdfz2U6iQ 1NH2z0P7d49VMsfFN1apeipUJXTaRHyIauO1JnAn1cm7QH0j8j91E6KdTwzCR9x+zOHP 1raYxGhNjdGGzWjLg32vMERFPZXZ/i3io9US0yZgadThTdw0Na9cpOgUoPCTesFoKRrj bv8A== X-Gm-Message-State: ABuFfohTyyn1d1qoaOwEO0nUL7FQV1yP3HTlj2MfHmLNNyKTOrxKFVqW zuszxt93oVwwYNnJvPsBG5A0SOi2OCYSPMMZQf4i0rgMLzw= X-Google-Smtp-Source: ACcGV62izmSanUzsc9bo4SVpkLFqV9xoAeMUsZQJYeVeLewa5Vm5emlkwC1xa4yAZ0EzQp+/5KplVIw10bu9lOf420c= X-Received: by 2002:a02:3849:: with SMTP id v9-v6mr5187247jae.15.1539979089175; Fri, 19 Oct 2018 12:58:09 -0700 (PDT) MIME-Version: 1.0 References: <CAMhyBcQGQ=EqPXOv41PGUO_hV-N3Gxgb7X3W4J5d54_Qoeyybg@mail.gmail.com> <201df4b1-56a6-a96b-68af-dde6f5c1af2a@gmail.com> In-Reply-To: <201df4b1-56a6-a96b-68af-dde6f5c1af2a@gmail.com> From: Sean Ferrell <sean.ferrell@temple.edu> Date: Fri, 19 Oct 2018 15:57:58 -0400 Message-ID: <CAMhyBcQ3qwZs9G9Zk=1AZGV6zHwke99AmfFnGBrRrwTQSy3k7Q@mail.gmail.com> Subject: Re: (Draft) Release Announcement: NEDC TUH EEG Seizure (v1.4.0) To: Joseph Picone <joseph.picone@gmail.com> Content-Type: multipart/alternative; boundary="000000000000927fc105789a52f7" --000000000000927fc105789a52f7 Content-Type: text/plain; charset="UTF-8" Hello everyone, We have released v1.4.0 of TUH EEG Seizure (TUSZ). It is available at: https://isip.piconepress.com/projects/tuh_eeg/downloads/tuh_eeg_seizure/v1.4.0/ TUSZ v1.4.0 includes improvements to the quality of annotations. In the development test dataset, annotation corrections were made on several files. Updates to the training dataset include several annotation corrections and the removal of one session. Here is a summary of our planned releases: v1.5.0 (20181115): The expansion of the training dataset that will now include more than 4,500 annotation files. v1.6.0 (20181215): An additional 1,000 annotation files included in the training dataset, resulting in over 5,500 files. As always, don't hesitate to contact us with your questions or bug reports. Best regards, Sean Ferrell NEDC Data Resources Development Manager The Neural Engineering Data Consortium Temple University College of Engineering, ENGR 602 1947 North 12th Street Philadelphia, PA 19122-6018 Tel: 215-204-4841 Fax: 215-204-5960 Email: sean.ferrell@temple.edu
Toad-Hall
  • Top 10 Contributor
1703 Lösungen 11364 Antworten
Veröffentlicht

Given all you have done with setting up not to compose in html in your account settings, I'm wondering if a default value is superceding things. Try the following...

Check settings:

  • Thunderbird > Preferences > Advanced > General tab
  • click on 'Config Editor' it will say be carefull :)
  • in top search type: compose

To enforce Plain Text as default, look for these lines. If the Value = 'true', then double click on the line to toggle to 'False'

  • mail.html_compose
  • mail.identity.default.compose_html
  • Close window - top right X
  • click on OK to save changes to Preferences.

Close and reopen Thunderbird. Test a 'Edit as new message'

Please report back on results.

Given all you have done with setting up not to compose in html in your account settings, I'm wondering if a default value is superceding things. Try the following... Check settings: * Thunderbird > Preferences > Advanced > General tab * click on 'Config Editor' it will say be carefull :) * in top search type: '''compose''' To enforce Plain Text as default, look for these lines. If the Value = 'true', then double click on the line to toggle to ''''False'''' * mail.html_compose * mail.identity.default.compose_html * Close window - top right X * click on OK to save changes to Preferences. Close and reopen Thunderbird. Test a 'Edit as new message' Please report back on results.
Veröffentlicht

Fragesteller

I did this a while ago. A screenshot is attached. It is not helping.

One this I noticed is that I only have entries for id2 and id3, not id1. I have been using TBird forever, so don't ask me how it got this way.

I did this a while ago. A screenshot is attached. It is not helping. One this I noticed is that I only have entries for id2 and id3, not id1. I have been using TBird forever, so don't ask me how it got this way.
Matt
  • Top 10 Contributor
  • Moderator
3211 Lösungen 21963 Antworten
Veröffentlicht

The original message is in HTML. so it edits as new in HTML.

The original message is in HTML. so it edits as new in HTML.
Veröffentlicht

Fragesteller

Duh!

But when I edit it, and I have set my settings to plain text mode, it should come up in plain text mode (IMHO).

Also, there is no easy way to convert a message in the composition window to plain text when it is in HTML.

Further, when I forward the message, it comes up in plain text mode.

So the behavior is inconsistent and needs to be fixed.

Duh! But when I edit it, and I have set my settings to plain text mode, it should come up in plain text mode (IMHO). Also, there is no easy way to convert a message in the composition window to plain text when it is in HTML. Further, when I forward the message, it comes up in plain text mode. So the behavior is inconsistent and needs to be fixed.
Matt
  • Top 10 Contributor
  • Moderator
3211 Lösungen 21963 Antworten
Veröffentlicht

picone said

Duh! But when I edit it, and I have set my settings to plain text mode, it should come up in plain text mode (IMHO).

That is not how it works. despite your opinion. You are asking to edit as new a HTML document. and expecting an explicit conversion of the document to text.

Also, there is no easy way to convert a message in the composition window to plain text when it is in HTML.

If your settings are text then there will be nothing to change, except when you are editing HTML mail.

Further, when I forward the message, it comes up in plain text mode.

Forward is not edit as new. When you click on a word document file in the file system to you expect your operating system to open the file in text editor fully converted to text? Most people would expect the program used to create it to open looking exactly as the last time it was edited.

So the behavior is inconsistent and needs to be fixed.

It is perhaps a little inconsistent. It is possible it should be adjusted that forward also retains the original format.

Personally I think we already have the best of both worlds. Instead of edit as new use the appropriate keyboard commands to select all, copy and then paste text only. I do not use expensive computer equipment so i have no idea what the mac commands for those things are.

In windows it would be Ctrl+A, ctrl+C and Ctrl+Shift+V, in sequence. The latter being in a new email.

''picone [[#answer-1166500|said]]'' <blockquote> Duh! But when I edit it, and I have set my settings to plain text mode, it should come up in plain text mode (IMHO). </blockquote> That is not how it works. despite your opinion. You are asking to edit as new a HTML document. and expecting an explicit conversion of the document to text. <blockquote> Also, there is no easy way to convert a message in the composition window to plain text when it is in HTML. </blockquote> If your settings are text then there will be nothing to change, except when you are editing HTML mail. <blockquote> Further, when I forward the message, it comes up in plain text mode. </blockquote> Forward is not edit as new. When you click on a word document file in the file system to you expect your operating system to open the file in text editor fully converted to text? Most people would expect the program used to create it to open looking exactly as the last time it was edited. <blockquote> So the behavior is inconsistent and needs to be fixed. </blockquote> It is perhaps a little inconsistent. It is possible it should be adjusted that forward also retains the original format. Personally I think we already have the best of both worlds. Instead of edit as new use the appropriate keyboard commands to select all, copy and then paste text only. I do not use expensive computer equipment so i have no idea what the mac commands for those things are. In windows it would be Ctrl+A, ctrl+C and Ctrl+Shift+V, in sequence. The latter being in a new email.

Geändert am von Matt

Veröffentlicht

Fragesteller

I appreciate the feedback, but as someone who has been using email for over 40 years, I disagree with your statement about the best of both worlds.

I want a way to set my email to compose in plain text. Edit as New should adopt my plain text settings and convert the document, not edit it as html.

I believe this is consistent with the intention of a user and more user-friendly than the current situation. The problem with forwarding or copy and pasting the text is you have to rebuild the lists of addressees, subject line, etc.

I handle a lot of email (typically several hundred messages per day) so even though this might seem like a small thing, it is a big thing for me.

I appreciate the feedback, but as someone who has been using email for over 40 years, I disagree with your statement about the best of both worlds. I want a way to set my email to compose in plain text. Edit as New should adopt my plain text settings and convert the document, not edit it as html. I believe this is consistent with the intention of a user and more user-friendly than the current situation. The problem with forwarding or copy and pasting the text is you have to rebuild the lists of addressees, subject line, etc. I handle a lot of email (typically several hundred messages per day) so even though this might seem like a small thing, it is a big thing for me.
Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

Matt said

The original message is in HTML. so it edits as new in HTML.

Why do you say that, Matt? I can't see any indication of HTML content in the message source offered by the OP.

''Matt [[#answer-1166496|said]]'' <blockquote> The original message is in HTML. so it edits as new in HTML. </blockquote> Why do you say that, Matt? I can't see any indication of HTML content in the message source offered by the OP.