Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

THREAD LINUX

  • 1 Antwort
  • 1 hat dieses Problem
  • 5 Aufrufe
  • Letzte Antwort von Shadow110

more options

I'm a gnome3-ubunutu16 medium advanced user on firefox 60.0.2 HELLO !

since the quantum version I'm feeling like firefox is heating my computer up. When I watch htop sorted by cpu usage something like 50 (may twice) pid are firefox reserved and sharing the same cpu percentage. actually there are tow types of processes : /usr/lib/firefox//firefox /usr/lib/firefox//firefox -contentproc -childID 1 -isForBrowser -boolPrefs 77:0|93:0|183:1|299:0| -stringPrefs .... they are two processes undergoing in a lot of threads. But, is it possible to limit this number of threads, mostly when streaming video the cpu consumption is too much !

thanks a lot for any answer or complete explanations.

Alle Antworten (1)

more options

Hi,some comments on your Video Card Drivers taken from your info : u'Acceleration blocked by platform', {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled',

Firefox is Multi-Processor and Multi-Thread so your seeing Sandbox, Firefox, Add-ons/Extensions/Video +

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :