Das Adobe Flash-Plugin ist abgestürzt – verhindern, dass es wieder passiert | Fehlerbehebung

Das Adobe Flash-Plugin ist abgestürzt – verhindern, dass es wieder passiert

Die Meldung Das Plugin "Adobe Flash" ist abgestürzt wird angezeigt, wenn das Flash-Plugin unerwarteterweise nicht mehr funktioniert. In den meisten Fällen genügt ein erneutes Laden der Webseite, um das Plugin neu zu starten und damit das Video, das Spiel oder die Animation wieder anzuzeigen.

Plugin - Absturzmeldung - Fx24

Falls das Flash-Plugin weiterhin abstürzt, kann die Aktualisierung von Flash auf die neueste Version das Problem beheben. Dieser Artikel erklärt, wie Sie Adobe Flash aktualisieren können, und zeigt weitere Lösungsmöglichkeiten.

Flash aktualisieren

Die aktuelle Flash-Version sollte auf Ihrem System besser funktionieren und weniger oft abstürzen. Mithilfe der Mozilla Plugin-Testseite können Sie feststellen, ob Sie die aktuelle Version des Flash-Plugins verwenden. Wenn Ihnen dort angezeigt wird, dass Flash aktualisiert werden muss, installieren Sie die aktuelle Version manuell. Folgen Sie dabei dieser Anleitung:

  1. Gehen Sie zu Adobes Download-Seite für den Flash Player und laden Sie das Flash Player-Installationsprogramm herunter.
    Vorsicht: Die Download-Seite von Adobe zeigt manchmal Auswahlkästchen für zusätzliche Software (wie Google Chrome oder McAfee Security Scan), die automatisch aktiviert sind. Wenn Sie diese Auswahlkästchen nicht abwählen, bevor Sie den Download starten, wird diese Software zusätzlich auf Ihrem Rechner installiert, wenn Sie Flash installieren.
  2. Schließen Sie Firefox, nachdem das Herunterladen abgeschlossen ist.

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Beenden close 29 .

  3. Öffnen Sie die heruntergeladene Datei und folgen Sie den Installationsanweisungen.
Hinweis: Wenn Sie Probleme mit dem Installationsprogramm von der Download-Seite von Adobe haben, können Sie diesen Link zum Flash Player-Installationsprogramm verwenden.
  1. Rufen Sie Adobes Download-Seite für den Flash Player auf und laden Sie das Flash-Installationsprogramm herunter.
  2. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Beenden close 29 .

  3. Öffnen Sie die heruntergeladene Datei (z. B. install_flash_player_osx_intel.dmg).
  4. Öffnen Sie im Finder Adobe Flash Player.pkg, um die Installation zu starten. Folgen Sie dann den Installationsanweisungen.

Über die Paketverwaltung

Bei den meisten Linux-Distributionen kann Flash über die Paketverwaltung installiert werden. Diese Pakete sollten immer bevorzugt installiert werden, anstatt Programme von Websites herunterzuladen und händisch zu installieren. Suchen Sie in der Paketverwaltung (bei Ubuntu ab Version 9.10 ist es z. B. als Software-Center bekannt) nach flash oder adobe.

Manche Distributionen wie Debian und Ubuntu bieten die Installation von Flash in Firefox auch automatisch beim ersten Antreffen auf einer Seite an, die Flash benötigt. Folgen Sie dann einfach den Anweisungen zur Installation von Flash.

Von Adobe.com herunterladen

  1. Rufen Sie die Adobes Downloadseite des Flash Players auf.
  2. Laden Sie die Datei install_flash_player_„Version”_linux.„Prozessorart”.tar.gz herunter, wenn Sie dazu aufgefordert werden.
  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Beenden close 29 .

  4. Öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird).

    • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
    • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
    • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.

  5. Wechseln Sie in das Verzeichnis, in das Sie die heruntergeladene Datei abgespeichert haben (z .B. cd /home/Benutzername/Downloads).
  6. Entpacken Sie die Datei libflashplayer.so mit dem Befehl tar -zxvf install_flash_player_„Version”_linux.„Prozessorart”.tar.gz.
  7. Kopieren Sie die Datei libflashplayer.so als Superuser in das Unterverzeichnis plugins des Programmverzeichnisses von Firefox. Wenn z. B. Firefox im Verzeichnis /usr/lib/mozilla installiert ist, führen Sie den Befehl sudo cp libflashplayer.so /usr/lib/mozilla/plugins aus und geben Sie dann Ihr Superuser-Passwort ein, wenn Sie dazu aufgefordert werden.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Hardwarebeschleunigung in Flash deaktivieren

Viele Probleme mit Flash können gelöst werden, indem Sie in den Einstellungen des Flash Players die Hardwarebeschleunigung deaktivieren. Einzelheiten finden Sie auf der Hilfeseite des Adobe Flash Players im Abschnitt Anzeigeeinstellungen. Um die Hardwarebeschleunigung in Flash zu deaktivieren:

  1. Besuchen Sie diese Hilfeseite zu Adobe Flash Player.
  2. Klicken Sie mit der rechten MaustasteHalten Sie die Ctrl-Taste gedrückt und klicken Sie mit der Maus dort auf das Logo des Flash Players und wählen Sie im Kontextmenü den Eintrag Einstellungen. Das Fenster Einstellungen für Adobe Flash Player öffnet sich.
  3. Das Fenster „Anzeige” mit dem Kontrollkästchen für die Hardwarebeschleunigung wird angezeigt. Wenn das nicht der Fall ist, klicken Sie im Fenster Einstellungen für Adobe Flash Player links unten auf das Symbol, um das Fenster „Anzeige” mit dem Kontrollkästchen für die Hardwarebeschleunigung zu öffnen.
  4. Entfernen Sie das Häkchen vor Hardwarebeschleunigung aktivieren.
    FPEinstellungen1
  5. Klicken Sie auf Schließen, um das Fenster Einstellungen für Adobe Flash Player zu schließen.
  6. Starten Sie Firefox neu.

Den geschützten Modus von Flash deaktivieren

Wichtig: Die folgende Lösung betrifft nicht die 64-Bit-Version von Firefox für Windows.
Adobes geschützter Modus von Flash kann bei einigen Nutzern den Absturz oder das Hängen des Flash-Plugins verursachen. Mit folgenden Schritten können Sie diesen Modus deaktivieren:
Warnung: Der geschützte Modus ist eine standardmäßig aktivierte Sicherheitsfunktion von Adobe Flash. Das Abschalten dieser Funktion deaktiviert den Sicherheitsschutz.
  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung öffnet sich.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Die Add-ons-Verwaltung öffnet sich.

    Add-ons-Manager öffnen - fx29 - Win8 Add-ons-Manager aufrufen - Fx39 - Win8 Add-ons-Manager öffnen - fx35 - Mac Linux: Australis - Add-ons öffnen

  2. Gehen Sie im Tab mit der Add-ons-Verwaltung zum Abschnitt Plugins.
  3. Suchen Sie in der Liste der Plugins nach Shockwave Flash und klicken Sie auf die Schaltfläche Optionen.
  4. Entfernen Sie das Häkchen bei Geschützten Modus von Flash aktivieren.
    geschützter-Modus-Flash-Einstellungen-Firefox
    Hinweis: Lesen Sie dazu auch den Artikel Der geschützte Modus von Adobe Flash in Firefox.
  5. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Beenden Close 29 . Dadurch schließen Sie Firefox vollständig und die geänderte Einstellung wird übernommen.
  6. Starten Sie Firefox neu.

Weitere Lösungen

War der Artikel hilfreich?

Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: philipp, Coce, ThomasLendo, Wawuschel, boersenfeger, androdev91, jonius, pollti, Artist, graba, beategm, Daniel2099. Auch Sie können helfen – erfahren Sie, wie.

Letzte Aktualisierung: 2016-11-15

Hilfe zu einer anderen Plattform erhalten:
Artikel anzeigen für:

Firefox