Frequently asked questions - Firefox add-on technology is modernizing

Tento článek zatím nikdo nepřeložil. Jestli máte s překlady na SUMO zkušenosti, můžete jej nyní přeložit. Pokud byste se chtěli dozvědět, jak se na SUMO články překládají, začněte prosím zde.

Here are some frequently asked questions about the transition to new add-on technology in Firefox:

Can you recommend replacements for my legacy extensions?

Yes! Use the extension finder utility to look up the extension you would like to replace and discover recommended replacements.

Keep in mind that many developers are in the process of updating to the new technology. Some will be ready by the time Firefox 57 is released (when legacy add-ons will be disabled), and some will be updated after. If you’re not necessarily looking for replacements for your legacy add-ons, but want to browse what’s available, go to addons.mozilla.org and try out extensions labeled with “Compatible with Firefox 57+”. Our featured collection is a great place to start!

There aren’t any recommended replacements for one of my legacy extensions. What now?

  • If you don’t find a suitable replacement, please head over to our forum to ask the community for suggestions.
  • If you like digging into details and want to know where developers are with their migrations, check out arewewebextensionsyet.com.

If I see the “legacy” label, does that mean my extension will break?

It depends on the extension. In some cases, developers will need to work up to the deadline to make their extensions compatible by the Firefox 57 release on November 14, 2017. Other extensions may become compatible after the deadline has passed. In these cases, the extension will automatically update when the compatible version becomes available.

However, there are some extensions that will break permanently following the release of Firefox 57. You can check the migration status of your legacy extension by visiting arewewebextensionsyet.com or asking about it on our forum.

How can I find extensions that are compatible with Firefox 57 and beyond?

You can search addons.mozilla.org (AMO) for compatible extensions by using the search term “Firefox 57.” All compatible extensions will be labeled “Compatible with Firefox 57+.” Our featured collection also includes great extensions that will be compatible beyond Firefox 57.

Why haven't some of the most popular tab extensions migrated?

While there are a number WebExtension APIs currently available for tabs, there are still more in development. In some cases, legacy tab extensions cannot migrate by the Firefox 57 release because they lack the necessary APIs to create feature parity. However, as more APIs become available over time, we should see the emergence of more and varied tab extensions. Please know that tab APIs are regarded as a very high priority for the add-on team. In the meantime, you can explore compatible tab extensions here.

Will my themes break with Firefox 57?

If you are using a Lightweight Theme, you should not experience any disruption. If you are using a Complete Theme, it will be disabled in Firefox 57 and will no longer work. If you use a dark complete theme, the Dark Theme option in the Add-on Manager might be a good option for you. Go to the Themes tab in about:addons and give it a try. We are making improvements to themes in the coming months, so look for themes with additional functionality beyond an image overlay in future releases.

Byl tento článek srozumitelný? Počkejte prosím...

Tito lidé pomohli se sepsáním tohoto článku: Joni, Caitlin Neiman. Také můžete pomoci - přečtěte si jak.