Často kladené dotazy – modernizace technologie doplňků Firefoxu

Co jsou to zastaralá rozšíření?

Rozšíření vytvořená pomocí frameworků, které nejsou kompatibilní s Firefoxem 57 a vyšším (např. SDK nebo XUL), jsou brána jako “zastaralá”.

Jak poznám, jestli mám nainstalována nějaká zastaralá rozšíření?

Chcete-li zjistit, jestli máte nainstalované nějaké nekompatibilní rozšíření, jděte do správce doplňků (nabídka Nástroje > Doplňky nebo zadejte do adresního řádku “about:addons”). Pokud nějaké máte, uvidíte v horní části obrazovky text "Něco chybí? Některá rozšíření už Firefox nepodporuje. Zobrazit zastaralá rozšíření".

Klepněte na odkaz “Zobrazit zastaralá rozšíření” pro zobrazení seznamu zastaralých rozšíření, která máte v prohlížeči nainstalována. Klepnutím na “Najít náhradu” vedle každého z rozšíření zobrazíte doporučovanou alternativu. Více se o této funkci dozvíte na našem blogu.

Vidím-li označení "zastaralé", znamená to, že při aktualizaci na Firefox 57 či vyšší se dané rozšíření stane nefunkčním?

Ano, doplňky označené jako "zastaralé" nebudou s největší pravděpodobností po aktualizaci fungovat. Nicméně většina nejpopulárnějších rozšíření Firefoxu jsou s verzí 57+ kompatibilní. V pár případech vývojáři pracují na aktualizaci svých rozšíření, aby byly kompatibilní s nejnovějšími verzemi Firefoxu. Další rozšíření se mohou stát kompatibilními časem. V takovém případě se rozšíření poté, co bude dostupná jeho kompatibilní verze, automaticky zaktualizuje.

Když vidím označení "zastaralé", znamená to, že je dané rozšíření nefunkční?

Ano, doplňky označené jako "zastaralé" nebudou ve Firefoxu 57 fungovat. V některých případech budou vývojáři muset pokračovat v práci na rozšíření ještě i po dni vydání 14. listopadu 2017. V takovém případě se rozšíření poté, co bude dostupná jeho kompatibilní verze, automaticky zaktualizuje.

Můžete doporučit nějaké náhrady za má zastaralá rozšíření?

Ano! Můžete si projít naší kolekci doporučených rozšíření, která sestává z většinově používaných rozšíření nebo hledaných na webu addons.mozilla.org (AMO), a v níž naleznete samá kompatibilní rozšíření.

Případně můžete použít nástroj extension finder, který vyhledá rozšíření, které byste rádi nahradili a nalezne doporučované náhrady.

Ano! Jděte do správce doplňků (nabídka Nástroje > Doplňky nebo zadejte do adresního řádku “about:addons”) a přejděte do sekce Zastaralá rozšíření. Klepněte na “Najít náhradu” vedle každého z rozšíření a zobrazíte doporučovanou alternativu. Více se o této funkci dozvíte na našem blogu.

Doporučujeme kompatibilní rozšíření vyhledat na webu addons.mozilla.org (AMO) nebo si projít kolekci doporučených rozšíření.

Případně můžete použít nástroj extension finder, který vyhledá rozšíření, které byste rádi nahradili a nalezne doporučované náhrady.

Pro jedno z mých zastaralých rozšíření neexistuje doporučovaná náhrada. Co teď?

Pokud nenaleznete vhodnou náhradu, zamiřte na naše fórum a požádejte komunitu o návrhy (anglicky).

Jak naleznu rozšíření, která jsou kompatibilní s Firefoxem 57 a pozdějším?

Můžete prohledat web addons.mozilla.org, kde najdete kompatibilní rozšíření. Kolekce doporučených rozšíření také obsahuje skvělá rozšíření, která budou kompatibilní s Firefoxem 57 a následnými verzemi.

Kdy Firefox ESR přestane podporovat zastaralá rozšíření?

Verze Firefoxu 52 (vydání s rozšířenou podporou) je poslední verze, která bude podporovat zastaralá rozšíření. ESR 52 přestane být podporována 5. září 2018.

V říjnu 2018 budou všechny zastaralé doplňky na webu addons.mozilla.org (AMO) znepřístupněny, tzn. že uživatelé již nebudou moci zastaralé doplňky na AMO nalézt.

Jestliže se rozhodnete provozovat nepodporované vydání Firefoxu, abyste mohli používat zastaralé doplňky, učiní vás to zranitelnými vůči bezpečnostním nedostatkům a my jejich používání důrazně nedoporučujeme.

Přestanou fungovat ve Firefoxu 57 moje motivy vzhledu?

Pokud používáte odlehčené motivy vzhledu, neměli byste se setkat se žádným porušením. Pokud používáte úplné motivy vzhledu, budou počínaje Firefoxem 57 zakázány a již nebudou fungovat. Jestli používáte nějaký tmavý úplný motiv vzhledu, mohla by být pro vás dobrá volba možnost Tmavý motiv vzhledu ve správci doplňků. Jděte do sekce Motivy vzhledu na stránce about:addons a vyzkoušejte ho.

Co se stalo s mým úplným motivem vzhledu?

Úplné motivy vzhledu ve Firefoxu 57 a novějších nefungují a jsou zakázány. Jestli používáte nějaký tmavý úplný motiv vzhledu, mohla by být pro vás dobrá volba možnost Tmavý motiv vzhledu ve správci doplňků. Jděte do sekce Motivy vzhledu na stránce about:addons a vyzkoušejte ho. V nadcházejících měsících budeme provádět různá vylepšení motivů vzhledu, takže v budoucích vydáních hledejte motivy s dalšími prvky než je pouhý obrázkový "potah".

Co se stalo s mým doplňkem pracujícím s Flashem?

Počínaje Firefoxem 55 se Adobe Flash ve výchozím nastavení nespouští, jelikož je do prohlížeče zabudována technologie Klikni a spusť Flash. Můžete zvolit, jak chcete, aby se Flash choval na určitých stránkách nebo na všech stránkách.

Některá z nejpopulárnějších rozšíření pracujících s Flashem poskytovala tuto funkcionalitu předtím, než se stala součástí prohlížeče. Vzhledem k tomu, že jsou tato rozšíření nyní přežitá, nebudou je už pravděpodobně vývojáři podporovat a nebudou už fungovat.

V některých případech máme WebExtension API pro další schopnosti Flashe (např. vymazání LSO) a očekáváme, že doplňky budou mít časem více schopností Flashe a stejně jako spolupracujeme na odhalení, co je potřeba k vytvoření stejné funkčnosti.

// Tito lidé pomohli se sepsáním tohoto článku:soucet. Také můžete pomoci.

Byl tento článek srozumitelný? Počkejte prosím...

Pomáhejte s Mozillou