Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

UAC notification suddenly popping up

  • 4 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

UAC notification pops up every time I try to open Firefox since last update on 5/5/22. I've deselected all options that run the program as an administrator, but it still shows up every time. I've checked that no admin is selected in both the shortcut I use and in the program itself. Any suggestions?

UAC notification pops up every time I try to open Firefox since last update on 5/5/22. I've deselected all options that run the program as an administrator, but it still shows up every time. I've checked that no admin is selected in both the shortcut I use and in the program itself. Any suggestions?

Chosen solution

Can you check how is your UAC permissions?

  • Type UAC in your windows search and click at the first one, Windows will tell you when the UAC it will be needed.

Firefox and Thunderbird install an optional service called the Mozilla Maintenance Service which allows application updates to occur in the background, without requiring you to click Yes in the Windows User Account Control (UAC) dialog.

Disabling the Mozilla Maintenance Service

If you'd like to be prompted to authorize updates, you can disable the Mozilla Maintenance Service as follows:

  1. Click the menu button Fx89menuButton and select Settings.
  2. Click the General panel.
  3. Scroll down to Firefox Updates. (Tip: You can also search for updates in the search box.)
  4. Uncheck the box next to Use a background service to install updates.

You can uninstall the Mozilla Maintenance Service from your computer if you wish.

Read this answer in context 👍 0

All Replies (4)

more options

You need to go to Windows and search for how to disable UAC properly since this is seems to be coming from Windows.

Helpful?

more options

Chosen Solution

Can you check how is your UAC permissions?

  • Type UAC in your windows search and click at the first one, Windows will tell you when the UAC it will be needed.

Firefox and Thunderbird install an optional service called the Mozilla Maintenance Service which allows application updates to occur in the background, without requiring you to click Yes in the Windows User Account Control (UAC) dialog.

Disabling the Mozilla Maintenance Service

If you'd like to be prompted to authorize updates, you can disable the Mozilla Maintenance Service as follows:

  1. Click the menu button Fx89menuButton and select Settings.
  2. Click the General panel.
  3. Scroll down to Firefox Updates. (Tip: You can also search for updates in the search box.)
  4. Uncheck the box next to Use a background service to install updates.

You can uninstall the Mozilla Maintenance Service from your computer if you wish.

Helpful?

more options

Latest edit: Okay, looks like deleting the taskbar icon and recreating it from the desktop icon that now works without showing the UAC pop-up worked! THANK YOU ALL!!

Original response: The UAC still pops up when I try to open Firefox from the icon pinned to my taskbar. But it doesn't pop up when I open Firefox from my desktop icon. I have no idea why.

Modified by catjenkins74

Helpful?

more options

Did you check all Firefox shortcuts ?

Check that Firefox isn't set to run as Administrator.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab.

Make sure all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.