X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

I'm having problems finding how can I change my extention's xul so that it works on firefox 4

Objavljeno

My extension uses the tag: <toolbarpalette id="BrowserToolbarPalette"> to add the button. How it is made now on FF4 and how do I prepare the extension so that it works on FF3 and FF4?

My extension uses the tag: <toolbarpalette id="BrowserToolbarPalette"> to add the button. How it is made now on FF4 and how do I prepare the extension so that it works on FF3 and FF4?

Izabrano rješenje

Try the Firefox Builds Forum or the Extension Development Forum over at MozillaZine, there are a few on-going threads discussing the changes needed for Firefox 4.0.

http://forums.mozillazine.org/index.php

Pročitajte ovaj odgovor sa objašnjenjem 0

Dodatni detalji o sistemu

Instalirani priključci

  • Pando Web Plugin
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50917.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Live Update v1.5
  • NPWLPG
  • Google Update
  • Version 1.1.4, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Više informacija

Application Basics
Name
Firefox
Version
4.0b6
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Feedback
1.0.3
true
testpilot@labs.mozilla.com
Adblock Plus Pop-up Addon
0.1.8
true
adblockpopups@jessehakanen.net
Travsync syncronizer
0.1
true
travsyncsync@brunoais.pt
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20100914073604
browser.startup.homepage_override.mstone
rv:2.0b6
extensions.lastAppVersion
4.0b6
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
127811
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
NVIDIA GeForce GT 230M
Vendor ID
10de
Device ID
0a2a
Adapter RAM
512
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.16.11.8783
Driver Date
11-2-2009
Direct2D Enabled
true
DirectWrite Enabled
true

the-edmeister
  • Moderator
5391 rješenja 40020 odgovora

Odabrano rješenje

Try the Firefox Builds Forum or the Extension Development Forum over at MozillaZine, there are a few on-going threads discussing the changes needed for Firefox 4.0.

http://forums.mozillazine.org/index.php

Try the Firefox Builds Forum or the Extension Development Forum over at MozillaZine, there are a few on-going threads discussing the changes needed for Firefox 4.0. http://forums.mozillazine.org/index.php