X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Upgrade from ESR 38 to ESR 60 loses bookmarks

Objavljeno

Is there anyway to script updating the places.sqlite database to fix this problem? We are trying to upgrade to ESR60 everywhere, but all users are going to lose their bookmarks as things stand.

Is there anyway to script updating the places.sqlite database to fix this problem? We are trying to upgrade to ESR60 everywhere, but all users are going to lose their bookmarks as things stand.

Izabrano rješenje

I spoke with the development team on this, and going from 38 to 60 will definitely not work for various reasons.

The problem is you are just too far behind our current releases. We recommend going through each ESR release to get things correct.

Pročitajte ovaj odgovor sa objašnjenjem 0

Dodatni detalji o sistemu

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36

Više informacija

Mike Kaply
  • Moderator
40 rješenja 210 odgovora
Objavljeno

Upgrading to Firefox 60 should not cause users to lose their bookmarks.

What exactly are you seeing?

That being said, you can try deleting places.sqlite and bookmarks wil revert to the previous backup.

Upgrading to Firefox 60 should not cause users to lose their bookmarks. What exactly are you seeing? That being said, you can try deleting places.sqlite and bookmarks wil revert to the previous backup.

Vlasnik pitanja

basically once we install v60, places.sqlite gets renamed as places.sqlite.corrupt and a new one is created. Deleting the places.sqlite doesn't help unfortunately.

Going to esr 52 and then to esr 60 works ok, so i wondered if there was a way to upgrade the places.sqlite file outside of having to run the intermediate version of Firefox?

basically once we install v60, places.sqlite gets renamed as places.sqlite.corrupt and a new one is created. Deleting the places.sqlite doesn't help unfortunately. Going to esr 52 and then to esr 60 works ok, so i wondered if there was a way to upgrade the places.sqlite file outside of having to run the intermediate version of Firefox?
cor-el
  • Top 10 Contributor
  • Moderator
17774 rješenja 160790 odgovora
Objavljeno
See also: *https://developer.mozilla.org/en-US/Mozilla/Tech/Places/places.sqlite_Database_Troubleshooting
Mike Kaply
  • Moderator
40 rješenja 210 odgovora
Objavljeno

Odabrano rješenje

I spoke with the development team on this, and going from 38 to 60 will definitely not work for various reasons.

The problem is you are just too far behind our current releases. We recommend going through each ESR release to get things correct.

I spoke with the development team on this, and going from 38 to 60 will definitely not work for various reasons. The problem is you are just too far behind our current releases. We recommend going through each ESR release to get things correct.