Firefox no longer works with some versions of Windows XP

No one has helped translate this article yet. If you already know how localizing for SUMO works, start translating now. If you want to learn how to translate articles for SUMO, please start here.

Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1. They won't be updated with security and stability fixes. While Firefox will work on Windows XP Service Pack 2, to keep your computer and personal information safe, we recommend that you upgrade for free to Windows XP Service Pack 3 and install the latest Firefox. This article goes over your upgrade options.

Note: This article only applies to Windows.
Warning: Firefox 3.6 and Firefox 12 have known vulnerabilities that allow hackers to infect your computer or steal your personal information. To keep your computer and personal information safe, please follow the recommendations below.

Option 1: Upgrade for free to the latest Windows XP Service Pack (recommended)

Windows XP Service Pack 2 and Service Pack 3 are both free upgrades from Microsoft. While Firefox is supported on Windowx XP Service Pack 2, upgrading to Windows XP Service Pack 3 is the most secure option and will allow you to run the latest and greatest Firefox.

  1. Learn more at Microsoft's website.
  2. Update Firefox

Option 2: Switch to Opera

If you can't upgrade Windows, you can switch to the latest version of the Opera web browser.

Warning: Continuing to use the original version of Windows XP, Windows XP Service Pack 1 or Service Pack 2 is no longer supported by Microsoft and poses a significant security risk.

Споделете статията:

Беше ли ви полезна тази статия? Моля, изчакайте...

These fine people helped write this article: AliceWyman, Verdi, Swarnava, mluna, ouesten, upwinxp, jsavage. You can help too - find out how.