Showing questions tagged: اعرض كل الأسئلة

Audio Completely Missing

After the latest boot-up on my Manjaro desktop, Firefox is compeletely mute. All other applications are producing sound as normal, it's just Firefox that's gone silent. C… (read more)

After the latest boot-up on my Manjaro desktop, Firefox is compeletely mute. All other applications are producing sound as normal, it's just Firefox that's gone silent. Checked the mute settings on the individual tabs, Checked the speakers, checked the linux system settings, checked ever volume control I can find, still no sound. I'm stumped. As far as I can tell, there's nothing telling Firefox to keep quiet, it just is for some inexplicable reason.

Asked by E.T.Smith 1 week ago

Last reply by jonzn4SUSE 21 minutes ago

Firerox Instantly crashes when playing any video.

Running Fedora on a Samsung Chromebook 3 using MrChromebox's coreboot 4.14 Firmware ExceptionHandler::GenerateDump cloned child 14197 ExceptionHandler::SendContinueSigna… (read more)

Running Fedora on a Samsung Chromebook 3 using MrChromebox's coreboot 4.14 Firmware

ExceptionHandler::GenerateDump cloned child 14197 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal... [Child 13910, MediaDecoderStateMachine #1] WARNING: 7ff1a7ce4f10 Could not set cubeb stream name.: file /builddir/build/BUILD/firefox-93.0/dom/media/AudioStream.cpp:367 Exiting due to channel error. Exiting due to channel error. Exiting due to channel error. [Child 13910, MediaDecoderStateMachine #1] WARNING: Decoder=7ff1aa941000 [OnMediaSinkAudioError]: file /builddir/build/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3980 Exiting due to channel error.

Asked by Srjosney 2 days ago

Last reply by jonzn4SUSE 1 hour ago

Youtube videos cannot play smoothly in firefox.

I am using firefox in linux mint basically and today I noticed that when I click on a youtube link it opens my firefox and then the youtube website and the video loads bu… (read more)

I am using firefox in linux mint basically and today I noticed that when I click on a youtube link it opens my firefox and then the youtube website and the video loads but the video doesn't play and keeps buffering when I click on the play video button. And then if I click on other youtube video those doesn't work too. So I have to close firefox everytime and then when I manually visit the youtube website everything works. But if my browser is closed and then I click on the youtube video it loads the video but doesnt play it and keeps buffering.

Asked by vtqgeuxaxxmmwhz 9 hours ago

Last reply by jonzn4SUSE 1 hour ago

Trying to open Firefox results in a blank window quickly opening and reclosing.

I just installed the Firefox browser using the installer on the official website. When I attempt to open Firefox, even as administrator, the window either quickly opens a… (read more)

I just installed the Firefox browser using the installer on the official website. When I attempt to open Firefox, even as administrator, the window either quickly opens and closes or doesn't open at all. I have no clue what is happening.

Asked by grayhoang 1 day ago

Last reply by grayhoang 7 hours ago

Slow Printing in Firefox!

Preview is opened as default when printing. I prefer to use the system printing. How can I discard Preview? The printing task now takes more than a minute to access the p… (read more)

Preview is opened as default when printing. I prefer to use the system printing. How can I discard Preview? The printing task now takes more than a minute to access the printer. It all started since Preview was introduced as default! Meanwhile Firefox i locked and I can't do anything in Firefox.

Asked by Carl-Erik.Lundgren 4 months ago

Last reply by Carl-Erik.Lundgren 7 hours ago

How do you identify the process id of a specific tab

Hi, I have scoured the web and can't seem to find a solution to this. Either firefox doesn't support this feature or I haven't looked enough. How can you identify the p… (read more)

Hi,

I have scoured the web and can't seem to find a solution to this. Either firefox doesn't support this feature or I haven't looked enough.

How can you identify the pid of a tab in firefox? There isn't a tab in the task manager that shows this, like with chrome, opera, and edge.

I'd appreciate any help.

Thanks

Asked by dpma123 8 hours ago

Last reply by cor-el 8 hours ago

Firefox 88 - very slow to create print preview

When I try to print from Firefox 88 on my Mac Laptop running OSX 10.12.6 the new print preview window takes a very long time to load the preview before I can print. I cou… (read more)

When I try to print from Firefox 88 on my Mac Laptop running OSX 10.12.6 the new print preview window takes a very long time to load the preview before I can print. I could not find a work around.

I tried switching to the Classic print system via (print.tab_modal.enabled - False) Now I don't have the preview to deal with so I can print immediately like I used to. However, if I try to open a PDF in Preview from the Print Dialog window, it takes a very long time to load the preview which it did not do in earlier versions of Firefox.

I am surmising that one of the Firefox updates added the print preview function which doesn't work quite right on my Mac.

Any ideas would be appreciated. Andy

Asked by andy162 5 months ago

Last reply by egutwillig 9 hours ago

  • حُلّت

Firefox needs a memory limit

Firefox needs a limit on memory usage. I was developing a tiny web page on Linux (PopOS) and accidentally created an endless loop in Javascript that ate memory (by growi… (read more)

Firefox needs a limit on memory usage. I was developing a tiny web page on Linux (PopOS) and accidentally created an endless loop in Javascript that ate memory (by growing an array). My entire OS became inoperable and had to be hard-rebooted. I was surprised this could happen due to Javascript (a sandboxed browser language), running in a web page (a sandboxed app) running in a Firefox browser that is supposed to protect users from the world wild web. One errant line of legal Javascript in HTML should not equate to a denial-of-service attack.

A sensible approach would be similar to the nice warning given when a script takes too much CPU, offering the user the choice to continue or stop the script when a tab exceeds some reasonable size: a fixed MB size, or say 10% of real RAM memory.

Ideally there should also be some hard limit calculated by Firefox according to the machine's available memory and Firefox's reasonable percentage of it. For example, maybe limit Firefox (all tabs combined) to 50% or maybe 75% of real memory, so that the O/S has a reasonable chance to remain operational so that a bad tab can be closed. Otherwise, Firefox could cause the O/S to lock up, resulting in data loss if there are tabs or other apps outside of Firefox that have unsaved changes.

Thanks for your consideration!

Asked by firefox1574 12 hours ago

Answered by jscher2000 12 hours ago

Volume control streaming video in Windows 10 FireFox

When streaming video or sound from any website i.e. YouTube, Netflix etc. my audio changes level automatically. I will start a video, the audio level will be set and when… (read more)

When streaming video or sound from any website i.e. YouTube, Netflix etc. my audio changes level automatically. I will start a video, the audio level will be set and when I pause and resume playing, especially multiple times in a row, the audio level will increase by itself every time i resume playing however not by increasing either the YouTube/streaming site's volume setting nor my Windows volume slider. If an episode on Netflix finishes and the next episode starts automatically, the volume will be much lower once playback resumes but again, no volume settings/sliders have changed. If I pause and play again, the volume goes up and if i pause and play multiple times it will gradually go back to the original level. I have removed application control of volume in Windows from Firefox and have tried searching for this issue but have yet to find a solution. Chrome does not have this issues on my same device. On rare occasions, the audio will automatically boost all the way up to maximum level and become distorted regardless of which audio device I'm using i.e. wireless headphones, external sound card, any other audio device. I then need to pause and un-pause a few times before it goes back to normal Please help!

Windows 10 latest version 20H2 x64 KB4023057 Firefox latest current version 93.0 (64-bit)

Asked by E420 11 hours ago

Absolute waste of RAM

I'm pissed of. HOW??? HOW??? How a single browser can take 90% of the memory until freezing your PC, ON A LINUX MINT FOR GOD SAKE! With 16GB Memory! I saw people defendin… (read more)

I'm pissed of. HOW??? HOW??? How a single browser can take 90% of the memory until freezing your PC, ON A LINUX MINT FOR GOD SAKE! With 16GB Memory!

I saw people defending this saying that "uuuh, mozilla takes advantage of-" BS! It doesn't take advantage of nothing, it only wastes your ram and your time.

HOW DO I LIMIT THE RAM USAGE? I DON'T WANT FANCY PERFORMANCE TABS I WANT A DIRECT ANSWER ON HOW TO STOP FIREFOX WASTING MY RAM

Asked by Luan Himmlisch 3 weeks ago

Last reply by Luan Himmlisch 11 hours ago

Firefox constantly loses server - tried everything!

Ironically since around the last Firefox update (approximately)... maybe around 4-5 months or so, I'll be working in Firefox (my browser of choice for like 15 years) and … (read more)

Ironically since around the last Firefox update (approximately)... maybe around 4-5 months or so, I'll be working in Firefox (my browser of choice for like 15 years) and then all of a sudden, I'll try to open a tab to go to a new site, and "server not found" error. Suddenly Firefox is useless and won't load anything. Chrome works just fine, and so I know it's not an internet or wifi problem. So far the ONLY solution I can find is that I restart my machine. Sometimes this means I can use Firefox for a week, sometimes it's only a few hours before it happens again.

Here are things I've tried (and have not worked) based on various threads including Firefox's own help pages: 1) Tried to change network settings to "no proxy" 2) Ensured that the "network.dns.disablePrefetch" is set to "true" (also network.dns.PrefetchFromHTTPS). 3) Tried closing everything and exiting Firefox and restarting

All other solutions seem focused on OTHER problems (e.g., specific sites, all browsers don't work.) Any and all help would be more than welcome. I'm getting to the point that I'm going to just ditch firefox and port all my bookmarks over to chrome.

Asked by claire.arthur81 16 hours ago

Last reply by jonzn4SUSE 14 hours ago

Caches the server response, even if it has changed

I have a VPN for work, some internal sites are inaccessible without this VPN. When I try to access them with the VPN turned off I legitimately get a 403. However, when I … (read more)

I have a VPN for work, some internal sites are inaccessible without this VPN. When I try to access them with the VPN turned off I legitimately get a 403. However, when I turn on the VPN firefox keeps showing 403 while other browsers work fine. This also works the other way around. When I turn off the VPN and try to go to one of the internal sites I don't get a 403 (as I should), instead firefox gets stuck at the page loading stage and nothing happens. There seems to be some kind of caching or optimization going on, but it's terribly interfering. Deleting cookies, caches, etc doesn't help at all. The only thing that helps in this situation is restarting firefox.

Asked by exdis 16 hours ago

Slow Firefox

System: MSI B640 Tomahawk. I5 10600KU 32GB RAM Video: MSI 3070 X3 System Drive: 250GB fast Samsung SSD, with 50% free. System OS: W10Pro_x64 21H1, Defender, no Firewall,… (read more)

System: MSI B640 Tomahawk. I5 10600KU 32GB RAM

Video: MSI 3070 X3

System Drive: 250GB fast Samsung SSD, with 50% free.

System OS: W10Pro_x64 21H1, Defender, no Firewall, no extra AV. Firefox_93.0_x64

Network: TYPE: Dedicated FIBER LAN Provider: Telenet Account Type: FIBER_200 Plus +


Addons: Adblock + µblock FBPurity Block Sender New Tab Override Cookie Manager and Cookie quick Manager Auto-High-Quality for youtube Ant Downloader Video Downloadhelper Cute Save Button WebP Image Converter Translate Web Page

Additional Information: Open Pinned Tabs: In between 25 and 60, depending on my current activities.

Tried: Disabling each add-on until all were off. Safe Start. Nothing helps.

Understandings: 1) No browser is made to run up to 60 open tabs (possibly even more)!!! 2) I run a "plethora" (compared to most users) if add-ons; these also bring the use speed down. 3) Resource used: 2GB (with "mere 30 pages" open.

BUT: DESPITE that: I ALSO understand that, considering my system and Network Type, it should not even be problematic with 200 pages open at once. 2GB over 32GB of RAM? Not the slightest issue (and it often runs at 4GB RAM in use). My CPU never runs half high, even when I have like 60 pages open: Should not be an issue then either. My Video Card has plenty resource over as well when at highest for me usage." Again, it should be no issue. My Fiber Netware? Telenet BVBA, Mechelen Test results: Ping: 5ms Jitter: 2ms Download: 904.2 Mbps Upload: 038.3 Mbps Not the best, not the worst, but for simple browsing, more than, I would assume, plenty.

So, what gives, what is the issue? No extreme strain on the system, no background high-resource issues, sure: one or two add-ons in Firefox but these as well do not strain my system, no AV issues, no Firewall issues (I turned that off, I fail to get the need for one as a house-dog-tree user), yet slow performance. Also, while 30'ish tabs running, 2GB used of RAM? My my, what the hell do they do as Site Admins to have these amounts (and NO, I do not do porn, thank you.  :P I am well aware of other people having insane issues surfing porn, as I helped many of these folks)? Sure, Deviant is a larger one that is open, being a graphical site, but like Quora, FB, Hot- and G-Mail and similar, these ain't, so to get a 2GB usage is weird, I would assume. I said, assume: yes, I am not specifically an internet know-all, I know of networking as a former NOVEL Netware Supervisor under UNIX (also Spupervisor), but Networking in a company is not the same as internet.

So, what is going on, why is my browser so slow? Having turned of all and 1 page open it's lightning fast, but now ... So, it is the open tabs, and the add-ons, though when turned off, I see no real difference. Brings it to tabs. How come, it is this "heavy", even for my system, please?

Thank you. Xog.

Asked by Xogroroth 2 days ago

Last reply by FredMcD 16 hours ago

Unable to Send Voice Clip in Facebook Messenger

Hi there Firefox team! I'm experiencing a problem with Facebook's in-bedded messenger when I'm trying to send a voice clip to a friend. It doesn't allow the action and gi… (read more)

Hi there Firefox team!

I'm experiencing a problem with Facebook's in-bedded messenger when I'm trying to send a voice clip to a friend. It doesn't allow the action and gives me the following error: You haven't allowed Facebook access to your microphone

The problem is that I did, both in browser and on-site, and I can make audio calls and video calls with microphone working on the messenger just fine. Only sending the voice clip doesn't work. I don't know why and whether the issue is with Firefox or with Facebook's code for Firefox, but the issue definitely is annoying.

I've also changed Firefox privacy controls from Strict to Standard, and that didn't help either.

If anyone knows what to do, please help. I love using Firefox, and it's been my default browser for like, decades, and I don't intend to leave it because of this one issue... it's just frustrating. And I've seen some people experiencing the same issue on the web.

I don't know. May the Lord bless you! :D

Asked by Borius 17 hours ago

Some things simply not showing / working

So sometimes when I'm browsing websites, elements simply don't load / work. For example, I'm trying to login to a service I own at PebbleHost but I cannot since the ReCap… (read more)

So sometimes when I'm browsing websites, elements simply don't load / work. For example, I'm trying to login to a service I own at PebbleHost but I cannot since the ReCaptcha does not show up. Also, signing in at NoIP didn't work about a week ago, does work now.

Asked by Osoa 1 day ago

Last reply by FredMcD 18 hours ago

Job application form stuck and won't submit

I am really frustrated after having spent and hour on a job application using my MacBook on Firefox, I can't submit. It keeps going around in circles. I am afraid to re… (read more)

I am really frustrated after having spent and hour on a job application using my MacBook on Firefox, I can't submit. It keeps going around in circles. I am afraid to refresh or empty cache because I will lose all my work! Any suggestions?

Asked by Run4peace 2 days ago

Last reply by jscher2000 1 day ago

  • حُلّت

white bars on sides of window when title bar is disabled

Since three updates ago there are white bars on three sides of my Firefox window whenever I disable the title bar. (The bars should be visible if you open the first pictu… (read more)

Since three updates ago there are white bars on three sides of my Firefox window whenever I disable the title bar. (The bars should be visible if you open the first picture I've attached over a coloured background. The second picture shows the bars disappearing when the title bar is switched on.)

This problem persists in Safe Mode and even after a fresh installation of Firefox, so I am confident that my add-ons and themes are not the issue. The bars also show up when using the Firefox default theme, so a custom theme is not the problem either.

I have also tried, to no avail: Updating my graphics driver, changing my screen scaling, cleaning the registry. And of course simply restarting my computer.

I am at a loss as to what the issue is or how I can fix it.

Asked by white_bars 1 week ago

Answered by white_bars 1 day ago

cannot find servers

I am running a macmini with MacOS 10.13.6. I downloaded Firefox 93.0. The app will start up, load the urls but cannot access any of the servers. E.g. "We can’t connect to… (read more)

I am running a macmini with MacOS 10.13.6. I downloaded Firefox 93.0. The app will start up, load the urls but cannot access any of the servers. E.g. "We can’t connect to the server at www.cbc.ca." I connected to your site via another browser and followed instructions to add another profile, reinstall Firefox, and restart in trouble shooting mode. The "terminal" tried to send a crash report but could not because of a problem accessing your server.

At the same time my Mail accounts are all offline and cannot be put back on line.

I am dead in the water, and am using a Windows laptop to read emails. Please help.

Alan O'Connor - ...

=========

Firefox screen contents below:

Hmm. We’re having trouble finding that site.

We can’t connect to the server at www.cbc.ca.

If that address is correct, here are three other things you can try:

Try again later. Check your network connection. If you are connected but behind a firewall, check that Firefox has permission to access the Web.

Asked by alan 1 day ago

Last reply by FredMcD 1 day ago

Fals Crash Report maybe malware?

Over the past week I keep getting a Crash Report popup when Firefox obviously hasn't crashed, since I can continue browsing through multiple tabs. I've been able to close… (read more)

Over the past week I keep getting a Crash Report popup when Firefox obviously hasn't crashed, since I can continue browsing through multiple tabs. I've been able to close that dialog box and continue surfing. It has also happened after I've closed Firefox in the evening, after closing all tabs, signing out of email, etc, before turning the computer off. I suspect some type of malware, but Defender says there isn't a problem, and the popup looks exactly like the one shown on the Crash Report help page. I'm attaching a screenshot from this morning.

Asked by galenstrickland 1 day ago

Last reply by FredMcD 1 day ago