ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browser crashes on opening certain filetypes (notably PDF)

  • 3 ردود
  • 0 have this problem
  • 1 view
  • آخر ردّ كتبه jonzn4SUSE

more options

Hi everyone,

I'm running Firefox which I compiled with vaapi support because I was trying to use hardware acceleration for videos, so I think this bug may have something to do with that. Every time I open a pdf file my browser instantly crashes. When I use troubleshoot mode I have no such issue. I then tried with a fresh all-default user profile with no add-ons, nothing, and still I crash when loading a PDF. Any pointers would be appreciated.

Hi everyone, I'm running Firefox which I compiled with vaapi support because I was trying to use hardware acceleration for videos, so I think this bug may have something to do with that. Every time I open a pdf file my browser instantly crashes. When I use troubleshoot mode I have no such issue. I then tried with a fresh all-default user profile with no add-ons, nothing, and still I crash when loading a PDF. Any pointers would be appreciated.

All Replies (3)

more options

Try downloading Firefox from Mozilla, run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Is it any pdf or certain one you're working with? Try a pdf from this site. https://www.irs.gov/downloads/irs-pdf Works for me. see screenshot

What OS? What Desktop? X11 or Wayland?


Operating System: openSUSE Tumbleweed 20240310 KDE Plasma Version: 5.27.10 KDE Frameworks Version: 5.115.0 Qt Version: 5.15.12 Kernel Version: 6.7.7-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600 Manufacturer: Hewlett-Packard Product Name: HP ZBook 17 G2

Helpful?

more options

Hi, I have tried firefox-bin to the same effect. I run Gentoo with Hyprland (wayland). I have removed any possible offensive environment variables that could affect it. I have found it crashes in certain other circumstances as well: - Pressing the "back page" button on youtube sometimes - Rendering certain filetypes in Discord - desmos.com - Excalidraw - Seemingly most interactive webapps

This is definitely a me issue, not a bug with firefox. I just don't really know where to look next. Perplexing is that troubleshoot mode fixes it, but a fresh profile does not.

Helpful?

more options

Updated after watching a few videos about Tiling Window Managers.  ;-/ It's definitely a you issue and not a browser issue and I'm not a fan of Hyperland nor Wayland. Test your issue in a Desktop Environment and see what happens. Gentoo... since you're using it and having issues, why not go to their forum.

Here is my opinion on Hyperland. https://www.youtube.com/watch?v=5n_rl9jWUMo


Operating System: openSUSE Tumbleweed 20240506 KDE Plasma Version: 6.0.4 KDE Frameworks Version: 6.1.0 Qt Version: 6.7.0 Kernel Version: 6.8.8-1-default (64-bit) Graphics Platform: X11 Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz Memory: 125.1 GiB of RAM Graphics Processor: Mesa Intel® UHD Graphics 630 Manufacturer: HP Product Name: HP ZBook 17 G6

Modified by jonzn4SUSE

Helpful?

اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.