ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox unusable on eBay!

more options

I've used Firefox forever, however in the last couple weeks, I can no longer use eBay as the webiste looks weird and my account is inaccessible. (See attachment.)

I've cleared all history/caches/etc. per forum suggestions. No change. So now to use eBay, I have to switch to Safari or Chrome (which I rarely use.)

Using new 2020 Macbook Pro and latest Firefox 80.0 update. Any suggestions would be greatly appreciated!

-G

Attached screenshots

الحل المُختار

It looks like Firefox is blocking files it believes are being used to track you. Unfortunately, it appears that Ebay also has core functionality components mixed into those files. Since Firefox is blocking those files from loading, Ebay will appear broken if your Enhanced Tracking Protection settings are too strict in Firefox.

To fix this, go to the Ebay website. You should see a little purple or blue shield icon on the left side of the Firefox address bar, next to the padlock icon. If you click it, press the little toggle switch to turn off Firefox's Enhanced Tracking Protection feature on Ebay. The website should reload automatically and it should be fixed.

See Enhanced Tracking Protection in Firefox for desktop for more information.

Hope this helps.

Read this answer in context 👍 4

All Replies (8)

more options

الحل المُختار

It looks like Firefox is blocking files it believes are being used to track you. Unfortunately, it appears that Ebay also has core functionality components mixed into those files. Since Firefox is blocking those files from loading, Ebay will appear broken if your Enhanced Tracking Protection settings are too strict in Firefox.

To fix this, go to the Ebay website. You should see a little purple or blue shield icon on the left side of the Firefox address bar, next to the padlock icon. If you click it, press the little toggle switch to turn off Firefox's Enhanced Tracking Protection feature on Ebay. The website should reload automatically and it should be fixed.

See Enhanced Tracking Protection in Firefox for desktop for more information.

Hope this helps.

more options

THANK YOU WESLEY! You crushed it!!

more options

EXCELLENT, Wesley!!! Thank you!!!

I've contacted eBay about this numerous times . This is not an easy task: eBay "Help" has no options for tech support, and if you can get them to call you by pretending you have a question about buying or selling, they'll tell you that they'll tell their tech team about your problem and get back to you, but they never do - UGH!!!

more options

here another fix. go menu for browser select protections dashboard and select standard protections, refresh and now ebay should display.

Protections Dashboard

Firefox protects your privacy behind the scenes while you browse. This is a personalized summary of those protections, including tools to take control of your online security.

Manage your privacy and security settings

more options

I had this problem - MASSIVE In my instance, after reading lots on web, I suddenly chanced or realised their might be issues in relation to my plugins relating to blocking trackers etc . On my browser i have Ghostery, Disconnect and one other ( not sure if its already been mentioned ) I went in and unblocked ebay on Disconnect. After that - Voila - Everything seems to be rendering fine . Perhaps , everyone having this problem may need to check if the have any blocking , ad-blocking plugins / software Ebay appears to not function if their ads etc are blocked ?

This solution worked in CHROME too

Modified by rg.firefoxsync

more options

I have tried the solutions mentioned above a number of times across a few months and they have not worked for me. Ebay has a captcha verification method where you slide a puzzle piece into the right place. I do that, it says verification complete, but then there is a Firefox popup that says "To display this page, Firefox must send information that will repeat any action (such as a search or order confirmation) that was performed earlier." It loops back to the same verification page if I click resend. So it keeps looping.

I turned of enhanced protections by clicking the shield icon. I disabled the add on "Facebook Container". I added a popup permission for ebay.

I don't know what else to try.

more options

Its very important to try in Safe Mode or at least a Private Window as long as all your extensions are not working in Private Windows. So many extensions interfere with the operation of Firefox. They may work great for few sites then others don't work. You have to disable one by one to know which is the offender. It sure would be great if there was more standardization in web design. Right now its a mess. And as most of the public is too stupid to try alternatives to the fenced in Chrome experience, web designers just design for Chrome pretty much. If it works in Firefox so much the better. They simply don't care because so few people use Firefox. What Firefox needs to do is swallow their pride and align their code more with Chrome. Otherwise their market share is going to keep sliding as this problem gets worse and worse. In the last month its significantly worse.

And that infernal, moronic, utterly mindless "To display this page, Firefox must send information that will repeat any action (such as a search or order confirmation) that was performed earlier" popup that interferes with auto screen refreshing (financial sites anyone?) is just typical of how out of touch Firefox is today.

Its like Firefox is run by 80 year olds set in their ways. It has so much potential and they seem to be OK with letting things deteriorate. Chrome offers so little control. Just what idiots love. That way they don't need to make a decision.

Opera and Edge are tiny improvements over Google but just using any of them you know its so restricted by design. Hopefully Firefox will get it together. I shudder to think what having to use Chrome based browsers all day might be like. Week by week I need to use Chromium browsers more and more.

more options

Wesley Branton said

To fix this, go to the Ebay website. You should see a little purple or blue shield icon on the left side of the Firefox address bar, next to the padlock icon. If you click it, press the little toggle switch to turn off Firefox's Enhanced Tracking Protection feature on Ebay. The website should reload automatically and it should be fixed.

For me that was only the first step of the solution. I could login via Edge so I used a User Agent Switcher to tell the Website "I am Edge" and it worked instantaneously! (And I kept the tracking exception for Ebay as described above) User Switcher used: https://addons.mozilla.org/de/firefox/addon/user-agent-string-switcher/

Modified by official.address243