ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Facebook won't load in Firefox and I've tried quite a few things, any tips?

  • 10 ردود
  • 2 have this problem
  • آخر ردّ كتبه blackpoppy

more options

Out of nowhere (I have not recently added any new extensions or updated my Firefox) my Facebook is no longer working on Firefox. It loads the top bar, and a blank screen.

I have been reading articles about this and have tried a few different things, including clearing cache and cookies, and starting Firefox in safe mode. So far nothing has helped. Facebook works fine in the other browsers. This is really just a minor inconvenience, but since my security setup and bookmarks are all in Firefox then I do prefer it. Any suggestions welcome!

Attached screenshots

All Replies (10)

more options

This is happening with some other websites as well, I've noticed!

more options

How about in a private window: does Facebook work there?

If so, it could be a disk storage problem (private windows just use memory for temporary storage). The following diagnostic should pass all four tests; if some fail, that can cause problems with websites that use those types of local storage.


more options

It did work in a private window! So is there away to fix it in a regular window? When I look at my disk storage, it says 35 GB available though - almost a third of what's available.

Also, the Firefox storage results are as follows: Storage is working. This is your first visit or all storage was automatically cleared.


   Good: Totally Working. (fullyOperational)


   Good: Totally Working. (fullyOperational)


   Good: Totally Working. (fullyOperational)

Cache API

   Good: Totally Working. (fullyOperational)
more options

Some other differences between regular and private windows:

  • Private doesn't use cached files from regular windows
  • Private doesn't use cookies previously set in regular windows
  • Some extensions that are enabled in regular windows might be disabled in private windows
  • Some storage permissions might be more lenient in private windows because it's all temporary anyway

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?


You can scan down the Add-ons page and see which extensions have the private window icon and which don't; that might provide a clue. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then scan down the right side. Anything you might want to test disabling in regular windows?

It's also a good time to check whether there is anything unexpected here. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

more options

Thank you for your help! Unfortunately, I am still stumped on this one.

I did try clearing the cache and cookies. I tried this again and this time, I also clicked "Delete cookies & site data when Firefox is closed" under Preferences, and exited and reopened Firefox;

I tried clearing the cookies and site data also via the lock icon, and reloading the page, which did not seem to have an effect;

I deleted one extension I was unfamiliar with and closed and reopened Firefox. No effect. I also tried disabling all the remaining ones. In addition, all of my extensions are enabled in Private Browsing AND I had tried starting in Safe Mode and still had an issue. This leads me to think that my extensions are not the problem.

more options

Well, this is very mysterious. How about Enhanced Tracking Protection? You can check what is being blocked by that feature using the shield icon at the left end of the address bar. Usually Private windows are more restrictive, so this doesn't seem likely to be the culprit, but worth a double-check. More info: Enhanced Tracking Protection in Firefox for desktop.

Does Facebook load the news feed from its mobile URL:


more options

Interesting - it does load via the mobile link you shared. What does this mean?

I tried turning off Enhanced Tracking Protection and reloading, but that didn't seem to work.

more options

I don't have any new ideas yet. The mobile layout is very simplified, so perhaps the more complex layout is running into a problem? But since it works in a private window... it's not adding up. I don't get.

more options

I've noticed that I'm seeing a LOT more ads on Facebook starting perhaps a week ago, although I haven't changed any of my settings or ad blockers. Makes me wonder if it is something on Facebook's end that is causing the problem.

I'll just use a private window for now. Thanks for your help!

more options

Anyone else have any ideas with how to fix this problem - Facebook that works on Private Browsing but does not work on regular browsing on Firefox?

Basically I have a problem with opening too many tabs, and when Firefox or computer crashes (this happens quite often) then I lose all of the articles I wanted to read because I'm in a private window :,(